Devuan bug report logs - #146
init-systems-helper in ascii arm64 is still old version

Package: init-system-helpers; Reported by: Michael Knoop <mknoop@sbcglobal.net>;
Date: Tue, 19 Sep 2017 19:48:01 UTC;
Maintainer for init-system-helpers is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#146; Package init-system-helpers. Full text available.



Acknowledgement sent to Michael Knoop <mknoop@sbcglobal.net>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

To: submit@bugs.devuan.org
From: Michael Knoop <mknoop@sbcglobal.net>
Subject: init-systems-helper in ascii arm64 is still old version
Date: Tue, 19 Sep 2017 14:39:40 -0500

Package: init-system-helpers
Version: 1.24+devuan1.0

ascii for arm64 and others still only have version 1.24+devuan1.0 of init-system-helpers available, but

procps sysv-rc sysvinit-utils

require later versions to upgrade from jessie.

For example:

pi@devuan:~$ sudo apt-get install procps
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  procps : Depends: init-system-helpers (>= 1.29~) but 1.24+devuan1.0 is to be installed
E: Unable to correct problems, you have held broken packages.

pi@devuan:~$ sudo apt-get install sysv-rc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  sysv-rc : PreDepends: init-system-helpers (>= 1.25~) but 1.24+devuan1.0 is to be installed
E: Unable to correct problems, you have held broken packages.

pi@devuan:~$ sudo apt-get install sysvinit-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  sysvinit-utils : Depends: init-system-helpers (>= 1.25~) but 1.24+devuan1.0 is to be installed
E: Unable to correct problems, you have held broken packages.

Most of the other platforms have version 1.46.






Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sat, 21 Oct 2017 17:40:03 UTC