Devuan bug report logs - #167
Thunderbird language pack incompatible with current Thunderbird version

Package: thunderbird; Reported by: Stefan Baur <newsgroups.mail2@stefanbaur.de>;
Date: Thu, 7 Dec 2017 09:33:01 UTC;
Tags: ascii;
Maintainer for thunderbird is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#167; Package thunderbird. Full text available.



Acknowledgement sent to Stefan Baur <newsgroups.mail2@stefanbaur.de>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

To: submit@bugs.devuan.org
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
Subject: Thunderbird language pack incompatible with current Thunderbird
Date: Thu, 7 Dec 2017 10:29:11 +0100

Package: thunderbird
Version: 1:52.4.0-1~deb8u1

When trying to install thunderbird-l10n-de, it depends on an older
Thunderbird version and thus cannot be installed:

apt-get install thunderbird-l10n-de thunderbird
Reading package lists... Done
Building dependency tree
Reading state information... Done
thunderbird is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 thunderbird-l10n-de : Depends: thunderbird (< 1:45.8.0-3~deb8u1.1~) but
1:52.4.0-1~deb8u1 is to be installed
E: Unable to correct problems, you have held broken packages.

Please fix this, preferably by pulling in an updated thunderbird-l10n-de
from the-distribution-that-shall-not-be-named. ;-)

Note that other thunderbird-l10n-* packages may be affected as well, I
did not test that.

Kind Regards,
Stefan Baur





Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#167; Package thunderbird. Full text available.



Acknowledgement sent to KatolaZ <katolaz@freaknet.org>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at 167@bugs.devuan.org:

Date: Thu, 7 Dec 2017 10:04:48 +0000
From: KatolaZ <katolaz@freaknet.org>
To: 167@bugs.devuan.org
Subject: due to old-amprolla

[Message part 1 (text/plain, inline)]

Hi,

the language pack you are referring to in in jessie-security. There
seems to be a problem with the old amprolla at
auto.mirror.devuan.org:

    $ apt-cache policy thunderbird
    thunderbird:
      Installed: (none)
      Candidate: 1:52.4.0-1~deb8u1
      Version table:
         1:52.4.0-1~deb8u1 0
            500 http://auto.mirror.devuan.org/merged/ jessie-security/main i386 Packages
         1:45.8.0-3~deb8u1 0
            500 http://auto.mirror.devuan.org/merged/ jessie/main i386 Packages
    
    $ apt-cache policy thunderbird-l10n-de
    thunderbird-l10n-de:
      Installed: (none)
      Candidate: 1:45.8.0-3~deb8u1
      Version table:
         1:45.8.0-3~deb8u1 0
            500 http://auto.mirror.devuan.org/merged/ jessie/main i386 Packages
            500 http://auto.mirror.devuan.org/merged/ jessie-security/main i386 Packages
    			   

All is fine instead if you use the new amprolla repo at
pkgmaster.devuan.org:

    $ apt-cache policy thunderbird
    thunderbird:
      Installed: (none)
      Candidate: 1:52.4.0-1~deb8u1
      Version table:
         1:52.4.0-1~deb8u1 0
            500 https://pkgmaster.devuan.org/merged/ jessie-security/main i386 Packages
         1:45.8.0-3~deb8u1 0
            500 https://pkgmaster.devuan.org/merged/ jessie/main i386 Packages
    				
    
    $ apt-cache policy thunderbird-l10n-de
    thunderbird-l10n-de:
      Installed: (none)
      Candidate: 1:52.4.0-1~deb8u1
      Version table:
         1:52.4.0-1~deb8u1 0
            500 https://pkgmaster.devuan.org/merged/ jessie-security/main i386 Packages
         1:45.8.0-3~deb8u1 0
            500 https://pkgmaster.devuan.org/merged/ jessie/main i386 Packages
    				
We must investigate this, but since the old amprolla is due to be
decommissioned (sooner or later), I would probably suggest to switch
your repos to pkgmaster.devuan.org. 

My2Cents

KatolaZ


[signature.asc (application/pgp-signature, inline)]






Tags added: ascii Request was from KatolaZ <katolaz@freaknet.org> to control@bugs.devuan.org. Full text available.



Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 12 Dec 2017 21:55:34 UTC