Devuan bug report logs - #68
udev logging not working in Devuan Jessie rc

Package: udev; Reported by: Enrico Menotti <enrico.menotti@libero.it>;
Date: Sat, 29 Apr 2017 18:33:01 UTC;
Maintainer for udev is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#68; Package udev. Full text available.



Acknowledgement sent to Enrico Menotti <enrico.menotti@libero.it>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

Received: (at submit) by bugs.devuan.org; 29 Apr 2017 18:20:04 +0000
Return-Path: <enrico.menotti@libero.it>
Delivered-To: devuanbugs@dyne.org
Received: from mail.dyne.org [178.62.188.7]
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Sat, 29 Apr 2017 20:20:04 +0200 (CEST)
Received: from libero.it (smtp-33-i5.italiaonline.it [212.48.25.234])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by tupac2.dyne.org (Postfix) with ESMTPS id 4090918D0C5
	for <submit@bugs.devuan.org>; Sat, 29 Apr 2017 18:19:53 +0000 (UTC)
Authentication-Results: tupac2.dyne.org; dkim=pass
	reason="2048-bit key; unprotected key"
	header.d=libero.it header.i=@libero.it header.b=i9vlztpR;
	dkim-adsp=pass; dkim-atps=neutral
Received: from oxmiddle-05-021.iol.local ([10.255.27.99])
	by smtp-33.iol.local with SMTP
	id 4WyGdl0buROpj4WyGdfngW; Sat, 29 Apr 2017 20:19:52 +0200
x-libjamoibt: 1601
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=libero.it; s=s2014;
	t=1493489992; bh=IgmY4J4u38b0V6HSigJWERHiVnxcmUT9KY9cQoPrcqo=;
	h=Date:From:To:Subject;
	b=i9vlztpRjA4KtLbDOcsLstJyfbP2ukRut0WTpUpLLdFR7DlUXDnHj3s/23n5VuVGn
	 R8K943zn3FFHBuJ07RYsHhlCg9pgbXMbIwdisjxxLfRxaxVNd308gL7PgRkzO4f1gA
	 tIKfAEZ+PlwHPQr1+yDMvDKa43X4ASx0GkXQ/Vg5zSw1rTBxNRLmY5v8NTl205gzvp
	 Ayi5WjVtjdPcGCMb+Nm4T9CXoowePXKDjxziTOAeaY553s0hkq5rH5rQHzXmL9wswd
	 uG9nCQFhi5aH7Mm79uTJFqYdNYZMoIDPpLdVBs0FDZV5BNqprAW8wpW+F4Tomb8yqQ
	 ipxVWLmGWeaCg==
X-CNFS-Analysis: v=2.2 cv=Oso/823t c=1 sm=1 tr=0
 a=1xMwhBpz0s/FDnX+xB/mcg==:117 a=LRNa1XT_PvUA:10 a=JWWEyAbFJniNHR54WdIA:9
 a=QEXdDO2ut3YA:10 a=vi-5rjF6_HNk-t2m7MUA:9 a=_W_S_7VecoQA:10
Date: Sat, 29 Apr 2017 20:19:52 +0200 (CEST)
From: Enrico Menotti <enrico.menotti@libero.it>
To: submit@bugs.devuan.org
Message-ID: <1520581347.11159.1493489992616@mail.libero.it>
Subject: udev logging not working in Devuan Jessie rc
MIME-Version: 1.0
Content-Type: multipart/alternative; 
	boundary="----=_Part_11158_1516137687.1493489992609"
X-Priority: 3
Importance: Medium
X-Mailer: Open-Xchange Mailer v7.8.3-Rev21
X-Originating-IP: 82.48.216.147
X-Originating-Client: open-xchange-appsuite
x-libjamsun: XThyMpnyWZSAZ4njzBGW5Lg5+s4h9o8rgD8I+vwHvAU=
x-libjamv: ciRk/482jxs=
X-CMAE-Envelope: MS4wfER6XPegzI5KyWA1HkFZGJvrJYIVRjzjmjKWHWVqB/ddkdT3XwmiqiBnWBAWbKcTlr2R54vnwrogEpRxVfdTYa5PQHcqHSlJGxMIiq9yUdNHPu2RSERY
 IorxU8zYwOVVQqax0E/f2FQWehiJE52xcWVEUp7QHI/ob/VvM8mQcG58f7BaG4oDyapXXlwMYu+3zw==
X-Spam-Status: No, score=-0.1 required=5.0 tests=DKIM_SIGNED,DKIM_VALID,
	DKIM_VALID_AU,FREEMAIL_FROM,HTML_MESSAGE,RCVD_IN_DNSWL_NONE,SPF_HELO_PASS,
	SPF_PASS autolearn=disabled version=3.4.0
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on tupac2

[Message part 1 (text/plain, inline)]

Package: udev

Version: 215-17+deb8u6

I had the need to get a log from udev. I found four ways to do this:

1. changing /etc/udev/udev.conf, and inserting there udev_log="debug"

2. passing to the kernel the parameter udev.log-priority=debug (at boot time)

3. declaring the environment variable UDEV_LOG=debug

4. using udevadm (this only works after boot)

I tried the first three options (I needed a log at boot), and none worked.

So I downgraded udev to the version included with Debian Wheezy (175-7.2). This allowed a log (I used the first method) in /var/log/daemon.log.

I suspect udev in Jessie to rely on systemd for producing logs.
[Message part 2 (text/html, inline)]






Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 27 Jun 2017 12:15:12 UTC