Devuan bug report logs - #68
udev logging not working in Devuan Jessie rc

Package: udev; Reported by: Enrico Menotti <enrico.menotti@libero.it>;
Date: Sat, 29 Apr 2017 18:33:01 UTC;
Maintainer for udev is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#68; Package udev. Full text available.



Acknowledgement sent to Enrico Menotti <enrico.menotti@libero.it>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

Date: Sat, 29 Apr 2017 20:19:52 +0200 (CEST)
From: Enrico Menotti <enrico.menotti@libero.it>
To: submit@bugs.devuan.org
Subject: udev logging not working in Devuan Jessie rc

[Message part 1 (text/plain, inline)]

Package: udev

Version: 215-17+deb8u6

I had the need to get a log from udev. I found four ways to do this:

1. changing /etc/udev/udev.conf, and inserting there udev_log="debug"

2. passing to the kernel the parameter udev.log-priority=debug (at boot time)

3. declaring the environment variable UDEV_LOG=debug

4. using udevadm (this only works after boot)

I tried the first three options (I needed a log at boot), and none worked.

So I downgraded udev to the version included with Debian Wheezy (175-7.2). This allowed a log (I used the first method) in /var/log/daemon.log.

I suspect udev in Jessie to rely on systemd for producing logs.
[Message part 2 (text/html, inline)]






Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sun, 20 Aug 2017 07:56:53 UTC