Package: youtube-dl
Version: 2019.01.17-1.1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

I was attempting to downloading a video from YouTube. Usually I list the available formats by using the -F flag. I was downloading a YouTube video with the video ID Cet_uDiB3TM. When I typed "youtube-dl -F https://www.youtube.com/watch?v=CEt_uDiB3TM", it does download the webpage and the info, but then exits with error "YouTube said: Invalid parameters". The same when I tried to download it with "-f 308+251".

It seems the beowulf-backports version fixes this, as typing the same command both for listing available formats and downloading 308+251 works in 2020.06.16.1-1~bpo10+1.


-- System Information:
Distributor ID: Debian
Description: Devuan GNU/Linux 3 (beowulf)
Release: 3
Codename: beowulf
Architecture: x86_64

Kernel: Linux 4.19.0-9-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_PH.UTF-8, LC_CTYPE=en_PH.UTF-8 (charmap=UTF-8), LANGUAGE=en_PH:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages youtube-dl depends on:
ii  python3                3.7.3-1
ii  python3-pkg-resources  40.8.0-1

Versions of packages youtube-dl recommends:
ii  ca-certificates  20190110
ii  curl             7.64.0-4+deb10u1
ii  ffmpeg           7:4.1.4-1~deb10u1
pn  mpv | mplayer    <none>
ii  python3-pyxattr  0.6.1-1
ii  rtmpdump         2.4+20151223.gitfa8646d.1-2
ii  wget             1.20.1-1.1

-- no debconf information