Devuan bug report logs - #110
devuan-installer: GRUB installation fails on NMVe drives

Package: devuan-installer; Maintainer for devuan-installer is Ralph Ronnquist <ralph.ronnquist@gmail.com>;

Reported by: Olaf Meeuwissen <paddy-hack@member.fsf.org>

Date: Sun, 25 Jun 2017 07:03:02 UTC

Severity: normal

Tags: jessie

Done: "Ralph Ronnquist (rrq)" <ralph.ronnquist@gmail.com>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, Olaf Meeuwissen <paddy-hack@member.fsf.org>, Daniel Reurich <daniel@centurion.net.nz>:
bug#110; Package devuan-installer. (full text, mbox, link).


Acknowledgement sent to Olaf Meeuwissen <paddy-hack@member.fsf.org>:
New bug report received and forwarded. Copy sent to Olaf Meeuwissen <paddy-hack@member.fsf.org>, Daniel Reurich <daniel@centurion.net.nz>.

Your message specified a Severity: in the pseudo-header, but the severity value important was not recognised. The default severity normal is being used instead. The recognised values are: critical, grave, normal, minor, wishlist.

(full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Olaf Meeuwissen <paddy-hack@member.fsf.org>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: devuan-installer: GRUB installation fails on NMVe drives
Date: Sun, 25 Jun 2017 15:39:13 +0900
[Message part 1 (text/plain, inline)]
Package: devuan-installer
Severity: important

Dear Maintainer,

Installing with the devuan_jessie_1.0.0_amd64_NETINST.iso installer
worked like a charm until it tried to install GRUB2.  That failed with

  main-menu[226]: WARNING **: Configuring 'grub-installer' failed with error code 1
  main-menu[226]: WARNING **: Menu-item 'grub-installer' failed.
  main-menu[226]: INFO: Modifying debconf priority limit from 'high' to 'medium'
  debconf: Setting debconf/priority to medium
  lilo-installer: LILO not usable on EFI PCs withouBIOS compatibility: use grub-efi

Comparing with the Debian 8.8.0 and 9.0.0 installers, I found that the
8.8.0 version displayed the same behaviour.  The installer for 9.0.0
worked fine though.

Comparing the grub-installer.udebs I noticed that NVMe drives are not
supported in the Devuan installer.  The attached patch worked fine for
me (UEFI install, encrypted LVM with separate partitions for /home, /var
and /tmp).  I "applied" the patch by executing a shell and editing the
/usr/bin/grub-installer with nano.

The patch as well as some other fixes are included in version 1.140 of
the grub-installer udeb.

# I'm aware of #23 but as that had zero detail of what the problem was I
# decided to submit this as a separate issue.  As this only affects NVMe
# drives, I figured important was good enough a priority.

Hope this helps,
--
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join
[grub-installer.patch (text/x-diff, attachment)]

Tags added: jessie Request was from KatolaZ <katolaz@freaknet.org> to control@bugs.devuan.org. (full text, mbox, link).


Reply sent to "Ralph Ronnquist (rrq)" <ralph.ronnquist@gmail.com>:
You have taken responsibility. (Fri, 17 Jan 2020 13:33:01 GMT) (full text, mbox, link).


Notification sent to Olaf Meeuwissen <paddy-hack@member.fsf.org>:
bug acknowledged by developer. (Fri, 17 Jan 2020 13:33:03 GMT) (full text, mbox, link).


Message #12 received at 110-done@bugs.devuan.org (full text, mbox, reply):

From: "Ralph Ronnquist (rrq)" <ralph.ronnquist@gmail.com>
To: 110-done@bugs.devuan.org
Subject: done
Date: Sat, 18 Jan 2020 00:11:21 +1100
[Message part 1 (text/plain, inline)]
Resolved for beowulf ISOs

Ralph.

[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Fri Jul 10 07:03:12 2020;