Devuan bug report logs - #163
File size mismatch using apt-transport-https

Package: apt-transport-https; Maintainer for apt-transport-https is Andreas Messer <andi@bastelmap.de>;

Reported by: Chillfan <chillfan@protonmail.com>

Date: Thu, 23 Nov 2017 19:48:01 UTC

Severity: normal

Tags: ascii

Done: KatolaZ <katolaz@freaknet.org>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#163; Package apt-transport-https. (full text, mbox, link).


Acknowledgement sent to Chillfan <chillfan@protonmail.com>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Chillfan <chillfan@protonmail.com>
To: "submit@bugs.devuan.org" <submit@bugs.devuan.org>
Subject: File size mismatch using apt-transport-https
Date: Thu, 23 Nov 2017 14:35:46 -0500
[Message part 1 (text/plain, inline)]
Package: apt-transport-https
Version: 1.0.9.8.4

Installing a package over https using apt-transport https causes apt to report that the file size does not match what the server reported. Others have mentioned having this issue on the freenode channels.

Here is some of the output:

W: Size of file /var/cache/apt/archives/partial/wget_1.16-1+deb8u4_i386.deb is not what the server reported 503980 923
W: Size of file /var/cache/apt/archives/partial/iceweasel_52.5.0esr-1~deb8u1_all.deb is not what the server reported 121762 4889
W: Size of file /var/cache/apt/archives/partial/xserver-common_2%3a1.16.4-1+deb8u2_all.deb is not what the server reported 1758568 1719696
W: Size of file /var/cache/apt/archives/partial/xserver-xorg-core_2%3a1.16.4-1+deb8u2_i386.deb is not what the server reported 3129878 3122808

After a little testing I found I could only reproduce this on Jessie. It can be reproduced by installing a package from the mirror using apt-transport-https.
This looks to be the same as a Debian bug that was closed, but does not look to be fixed in Jessie: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=802617)

Sent with [ProtonMail](https://protonmail.com) Secure Email.
[Message part 2 (text/html, inline)]

Tags added: ascii Request was from KatolaZ <katolaz@freaknet.org> to control@bugs.devuan.org. (full text, mbox, link).


Reply sent to KatolaZ <katolaz@freaknet.org>:
You have taken responsibility. (full text, mbox, link).


Notification sent to Chillfan <chillfan@protonmail.com>:
bug acknowledged by developer. (full text, mbox, link).


Message #12 received at 163-close@bugs.devuan.org (full text, mbox, reply):

From: KatolaZ <katolaz@freaknet.org>
To: 163-close@bugs.devuan.org
Subject: solved in ascii
Date: Fri, 15 Dec 2017 13:30:16 +0000
[Message part 1 (text/plain, inline)]
This is only present in Devuan Jessie, and solved in Devuan
ASCII. Please see the corresponding Debian bug:

  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=802617

which apparently remains open to date (basically due to the fact that
Debian Jessie became oldstable...)

[signature.asc (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sun May 31 01:08:51 2020;