Devuan bug report logs - #186
nut-server: package fails to install with udev error

Package: nut-server; Maintainer for nut-server is (unknown);

Reported by: Tom <wirelessduck@gmail.com>

Date: Tue, 20 Feb 2018 23:18:02 UTC

Severity: normal

Done: Svante Signell <svante.signell@gmail.com>

Full log


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

Received: (at submit) by bugs.devuan.org; 20 Feb 2018 23:10:04 +0000
Return-Path: <wirelessduck@gmail.com>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Wed, 21 Feb 2018 00:10:04 +0100 (CET)
Received: from mail-ot0-f182.google.com (mail-ot0-f182.google.com [74.125.82.182])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	(No client certificate requested)
	by vm6.ganeti.dyne.org (Postfix) with ESMTPS id 2605FF609A4
	for <submit@bugs.devuan.org>; Wed, 21 Feb 2018 00:09:59 +0100 (CET)
Authentication-Results: vm6.ganeti.dyne.org;
	dkim=pass (2048-bit key; unprotected) header.d=gmail.com header.i=@gmail.com header.b="cPJCa6tN";
	dkim-atps=neutral
Received: by mail-ot0-f182.google.com with SMTP id 41so7875120otd.13
        for <submit@bugs.devuan.org>; Tue, 20 Feb 2018 15:09:24 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
        h=mime-version:from:date:message-id:subject:to;
        bh=NiJb+qP6pDFBIsa23ymqNV/vUbc7drUzZYyxYaBCHeE=;
        b=cPJCa6tNCcjvWh7koxwlWX4Syu+8WpOC3iew/QYK1SJoQ8QNrFa+leIF+zs/gNqur8
         8kLuuodAwqY+lUZx22qkkUFwSPl0Bw9u1aFWL9IBvHOgJIDkz5rm6nn7vnObxxttzLZ+
         XZPE70m0PZeVI7TXVY/OLDbtbU3Gq87djkMx64fNILa1pJJH+0pB83hulcr6iafl+UvL
         4fisocujDXej98KMTO2nFe8sX2DXRRF26nc7DQJvW4axwvZ0Ld+w36yoGC115zCfzHXj
         1jPNwLQJ6TMvWT+tzD38DBXmF/IzqB9gQUYZ0XEUM975GYX/jTdHL+pxYEBpp62zre1J
         DTQA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:from:date:message-id:subject:to;
        bh=NiJb+qP6pDFBIsa23ymqNV/vUbc7drUzZYyxYaBCHeE=;
        b=UymvblxqZI56MFoz5HIqRN1/+Nt64p7KZsZULU0cnXhMiq9Hqg4UVrsIIM+ZY/2O8v
         66QQ+Zk8zB13YVrag7Gwjxp/jTKcU4fXkJau2wz6EYMUeS6s8VTWsRjH211feAqUm2nE
         9HRDZGAfDwKV/oRt7QwhEv+wzpQY++CGXRKuVTxR8BYEg1xvUZ1Vq3TtLjwsibgfPgJp
         TcIK4zZOyHhwiioStn6zx2GSrtwNzzejBu/PSR9H5y2t6Wnhu4l85FmVDKIzaVM4CgtT
         Mo9+ra6o0bXRsOs2J4+9t0SPUM638GdplVJchOhRgCFIdcxnRJAXAAp7I0ZkPj/9Ofp3
         lbAQ==
X-Gm-Message-State: APf1xPD5uguNJjRco96tR46MuyNqlC/KSrFG15Qy7G1iYmhqcaUQYCvf
	xP3GeLDnYoOBgUD3M1/ZQBn7ko/RCr+T5rqpG5WXkG7c
X-Google-Smtp-Source: AH8x224qVz6nW9+ICgg84PM5SMVV+A+GG7BS+tT4Ak9i3l+OkHwro7/G6rchAyhOJQfAC+Zi1JeAx491HXR6/Xtsglg=
X-Received: by 10.157.18.131 with SMTP id g3mr1036369otg.9.1519168163302; Tue,
 20 Feb 2018 15:09:23 -0800 (PST)
MIME-Version: 1.0
Received: by 10.157.29.186 with HTTP; Tue, 20 Feb 2018 15:09:22 -0800 (PST)
From: Tom <wirelessduck@gmail.com>
Date: Wed, 21 Feb 2018 10:09:22 +1100
Message-ID: <CA+1refRgwRp-hxcW93xKfSbho6dCCXKpUOODqWRJ-KJeSER0fQ@mail.gmail.com>
Subject: nut-server: package fails to install with udev error
To: submit@bugs.devuan.org
Content-Type: text/plain; charset="UTF-8"
X-Spam-Status: No, score=0.4 required=5.0 tests=DKIM_SIGNED,DKIM_VALID,
	DKIM_VALID_AU,FREEMAIL_FROM,RCVD_IN_DNSWL_NONE,RCVD_IN_MSPIKE_H3,
	RCVD_IN_MSPIKE_WL,RCVD_IN_SORBS_SPAM,SPF_PASS autolearn=disabled version=3.4.1
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on tupac3.dyne.org
Package: nut-server
Version: 2.7.4-5
Severity: important

Dear Maintainer,

   * What led up to the situation?

   Trying to install nut-server package.

   eudev=3.2.2-11 is installed from pkgmaster.
   udev transitional package is not installed but there exists
   a symlink from /etc/init.d/udev to /etc/init.d/eudev

   * What was the outcome of this action?

   Package fails to install with error message about udev service.


# apt-get install nut-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  nut-cgi nut-ipmi nut-snmp nut-xml
The following NEW packages will be installed:
  nut-server
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/851 kB of archives.
After this operation, 5,038 kB of additional disk space will be used.
Selecting previously unselected package nut-server.
(Reading database ... 125468 files and directories currently installed.)
Preparing to unpack .../nut-server_2.7.4-5_amd64.deb ...
Unpacking nut-server (2.7.4-5) ...
Setting up nut-server (2.7.4-5) ...
insserv: Service udev has to be enabled to start service nut-server
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package nut-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 nut-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

# service udev status
[ ok ] udevd is running.


-- System Information:
Distributor ID: Devuan
Description: Devuan GNU/Linux testing/unstable
Release: testing/unstable
Codename: n/a

Architecture: x86_64

Kernel: Linux 4.9.0-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages nut-server depends on:
ii  adduser              3.115
ii  init-system-helpers  1.48+devuan2.0
ii  libc6                2.24-11+deb9u1
ii  libnspr4             2:4.12-6
ii  libnss3              2:3.26.2-1.1+deb9u1
ii  libupsclient4        2.7.4-5
ii  libusb-0.1-4         2:0.1.12-30
ii  libwrap0             7.6.q-26
ii  lsb-base             4.1+devuan2
ii  nut-client           2.7.4-5
pn  udev                 <none>

nut-server recommends no packages.

Versions of packages nut-server suggests:
pn  nut-cgi   <none>
pn  nut-ipmi  <none>
pn  nut-snmp  <none>
pn  nut-xml   <none>

-- Configuration Files:
/etc/nut/ups.conf [Errno 13] Permission denied: '/etc/nut/ups.conf'
/etc/nut/upsd.conf [Errno 13] Permission denied: '/etc/nut/upsd.conf'
/etc/nut/upsd.users [Errno 13] Permission denied: '/etc/nut/upsd.users'

-- no debconf information


Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Mon Apr 6 06:28:04 2020;