Devuan bug report logs - #214
mouse_drv.so: undefined symbol: xf86GetOS

Package: xserver-xorg-core; Maintainer for xserver-xorg-core is (unknown);

Reported by: bugs@annaghvarn.com

Date: Mon, 28 May 2018 13:48:01 UTC

Severity: normal

Done: KatolaZ <katolaz@freaknet.org>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#214; Package xserver-xorg-core. (full text, mbox, link).


Acknowledgement sent to bugs@annaghvarn.com:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Steve Graham <bugs@annaghvarn.com>
To: submit@bugs.devuan.org
Subject: mouse_drv.so: undefined symbol: xf86GetOS
Date: Mon, 28 May 2018 14:35:20 +0100
Package: xserver-xorg-core
Version: 1:1.9.2-1+b1

I run a minimal Xorg with the following packages installed:

xserver-xorg
xserver-xorg-core
xserver-xorg-legacy
xserver-xorg-video-intel
xserver-xorg-input-kbd
xserver-xorg-input-mouse
xserver-xorg-input-evdev

(I have no udev, so evdev will not work. However Xorg input doesn't work with the legacy input 
drivers unless I have it installed. I don't know why.)

After an upgrade to the latest 'unstable' versions, Xorg failed to start because of a crash in the 
mouse driver --
/usr/lib/xorg/modules/input/mouse_drv.so: undefined symbol: xf86GetOS

I reverted:
xserver-xorg-core & -legacy from 2:1.20.0-2 to 2:1.19.3-2
xserver-xorg-video-intel from 2:2.99.917+git20171229-1+b1 to 2:2.99.917+git20161206-1

The following were re-installed at their current latest versions:
xserver-xorg-input-mouse 1:1.9.2-1+b1
xserver-xorg-input-kbd 1:1.9.0-1+b1
xserver-xorg-input-evdev 1:2.10.5-1

The graphical interface then started normally.


Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#214; Package xserver-xorg-core. (full text, mbox, link).


Acknowledgement sent to KatolaZ <katolaz@freaknet.org>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. (full text, mbox, link).


Message #10 received at 214@bugs.devuan.org (full text, mbox, reply):

From: KatolaZ <katolaz@freaknet.org>
To: 214@bugs.devuan.org
Subject: Where does it come from?
Date: Tue, 29 May 2018 13:42:19 +0200
[Message part 1 (text/plain, inline)]
Hi,

It seems that the version of xserver-xorg-core you are reporting about
is not available in Devuan Jessie (it has 2:1.16.4-1+deb8u2), not
available in Devuan ASCII (it has 2:1.19.2-1+deb9u2), and not
available in Devuan Ceres (it has 2:1.20.0-2).

Can you please clarify? Where did you get the package from? Are you
using other repositories than Devuan ones?

It would be useful to report the output of:

  $ apt-cache policy xserver-xorg-core




[signature.asc (application/pgp-signature, inline)]

bug closed, send any further explanations to bugs@annaghvarn.com Request was from KatolaZ <katolaz@freaknet.org> to control@bugs.devuan.org. (full text, mbox, link).


Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sat May 30 23:59:11 2020;