Devuan bug report logs - #220
libwebkit2gtk-4.0-37: Attempting to install atril or libwebkit2gtk-4.0-37 fails (same cause)

Package: libwebkit2gtk-4.0-37; Reported by: Stefan Baur <newsgroups.mail2@stefanbaur.de>;
Date: Sun, 10 Jun 2018 19:03:01 UTC;
Done: KatolaZ <katolaz@freaknet.org>;
Maintainer for libwebkit2gtk-4.0-37 is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#220; Package libwebkit2gtk-4.0-37. Full text available.



Acknowledgement sent to Stefan Baur <newsgroups.mail2@stefanbaur.de>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

To: submit@bugs.devuan.org
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
Subject: libwebkit2gtk-4.0-37: Attempting to install atril or
Date: Sun, 10 Jun 2018 20:41:24 +0200

Package: libwebkit2gtk-4.0-37
Severity: normal

Dear Maintainer,

   * What led up to the situation?

I tried to run an upgrade from Devuan Jessie to Devuan ASCII using "apt
update" and "apt dist-upgrade".

The latter tried to deinstall the package "atril".

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

I aborted the process and upgraded packages manually until I found the
package causing the problem.

   * What was the outcome of this action?

apt install libwebkit2gtk-4.0-37 -t ascii
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (<
 1.10.5) but 1:1.10.4-dmo2 is to be installed
 E: Unable to correct problems, you have held broken packages.

   * What outcome did you expect instead?

the possibility to install/upgrade atril.

I think it's weird that it lists a dependency "<1.10.5", then states it
is going to install 1.10.4, which is obviously "<1.10.5", so the
requirement would be fulfilled, yet it still claims the dependency is
not met.


-- System Information:
Distributor ID: Devuan
Description:    Devuan GNU/Linux 2.0 (ascii)
Release:        2.0
Codename:       ascii

Architecture: x86_64

Kernel: Linux 4.9.0-6-amd64 (SMP w/4 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)





Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#220; Package libwebkit2gtk-4.0-37. Full text available.



Acknowledgement sent to KatolaZ <katolaz@freaknet.org>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at 220@bugs.devuan.org:

Date: Sun, 10 Jun 2018 21:24:39 +0200
From: KatolaZ <katolaz@freaknet.org>
To: 220@bugs.devuan.org
Subject: mixing repos

[Message part 1 (text/plain, inline)]

Hi,

it looks like you are using the "debian multimedia" (dmo) repos. apt
is right in saying that the version of libgstreamer-plugins-bad1.0-0
available from dmo is higher than 1.10.5, since it has an epoch number
(1:1.10.4-dmo2). This will be confirmed by

  apt-cache policy libgstreamer-plugins-bad1.0-0

There should be no reason any more to use DMO these days. As soon as
you remove debian multimedia from your sources.list, the upgrade will
succeed.  I am closing this one :-)

[signature.asc (application/pgp-signature, inline)]






Reply sent to KatolaZ <katolaz@freaknet.org>:
You have taken responsibility. Full text available.



Notification sent to Stefan Baur <newsgroups.mail2@stefanbaur.de>:
bug acknowledged by developer. Full text available.



Message received at 220-done@bugs.devuan.org:

Date: Tue, 12 Jun 2018 11:12:38 +0200
From: KatolaZ <katolaz@freaknet.org>
To: 220-done@bugs.devuan.org
Subject: not a bug

[Message part 1 (text/plain, inline)]

This is due to internaction with non-devuan repos (DMO). Closing

[signature.asc (application/pgp-signature, inline)]






Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#220; Package libwebkit2gtk-4.0-37. Full text available.



Acknowledgement sent to Stefan Baur <newsgroups.mail2@stefanbaur.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at 220@bugs.devuan.org:

Subject: Re: bug#220 acknowledged by developer (not a bug)
To: 220@bugs.devuan.org
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
Date: Tue, 12 Jun 2018 11:40:12 +0200

Am 12.06.2018 um 11:33 schrieb Devuan bug Tracking System:
> This is due to internaction with non-devuan repos (DMO). Closing

The DMO repo was not enabled during the upgrade (it may have been
enabled previously, when the system still was a Debian jessie or wheezy,
rather than a Devuan jessie installation).

grep -r multi /etc/apt/sources.list* returns:

/etc/apt/sources.list.d/adobe.list:#deb http://www.deb-multimedia.org
stretch main non-free
/etc/apt/sources.list.d/adobe.list:#deb http://www.deb-multimedia.org
stretch-backports main

As you can tell from the leading "#" in front of "deb", both entries are
commented out.

apt-get update was executed before apt-get upgrade and apt-get dist-upgrade.

Any hints on how to resolve the issue?  Which packages should be removed
or downgraded?

Kind Regards,
Stefan Baur





Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#220; Package libwebkit2gtk-4.0-37. Full text available.



Acknowledgement sent to KatolaZ <katolaz@freaknet.org>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at 220@bugs.devuan.org:

Date: Tue, 12 Jun 2018 12:17:33 +0200
From: KatolaZ <katolaz@freaknet.org>
To: 220@bugs.devuan.org
Subject: ...

[Message part 1 (text/plain, inline)]

The fact that dmo was not enabled during upgrade does not mean that
you don't have dmo packages in your system...

You should try forcing the ASCII version of libgstreamer-plugins-bad1
using something like:

  apt-get install libgstreamer-plugins-bad1.0-0=1.10.4-1

You might need to do the same for other DMO packages you have in your
system.


[signature.asc (application/pgp-signature, inline)]






Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#220; Package libwebkit2gtk-4.0-37. Full text available.



Acknowledgement sent to Daniel Reurich <daniel@centurion.net.nz>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at 220@bugs.devuan.org:

Subject: Re: [Devuan-bugs] bug#220: ...
To: 220@bugs.devuan.org
From: Daniel Reurich <daniel@centurion.net.nz>
Date: Wed, 13 Jun 2018 11:48:29 +1200

[Message part 1 (text/plain, inline)]


I've found dmo have regularly (ab)used epoch in the package version
numbers to keep dmp packages installed.  So it's likely you'll have to
manually uninstall/replace the any existing dmo packages.

-- 
Daniel Reurich
Centurion Computer Technology (2005) Ltd.
021 797 722



[signature.asc (application/pgp-signature, attachment)]






Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 11 Dec 2018 08:53:59 UTC