Subject: bug#224: [Procps package] ["free" command] "Old" output is now the only one without notice

From: Stephane Ascoet <[email-masked]>
Date: Tue, 10 Jul 2018 15:51:24 +0200

Package: Procps
Version: 2:3.3.12-3+devuan2.1

I've got a script using the line "buffers/cache" that free used to 
output, in Devuan Jessie for example. In the manual page, a "-o"/"--old" 
option is said to delete this line.

And after upgrading to Devuan Ascii, the script doesn't work anymore: I 
then found that now free behave like if "-o" was always enabled. What's 
that??? If it's an old output, why should it be default now? And what 
about all scripts broke by that change that isn't notified in the 
release notes??? Moreover, the man page isn't up to date, still talking 
about the old behavior.

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Thu, 22 Oct 2020 15:18:07 +0000

This is an automatic notification regarding your bug report
which was filed against the procps package:

#224: [Procps package] ["free" command] "Old" output is now the only one without notice

It has been closed by Arne Wichmann <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Arne Wichmann <[email-masked]> by
replying to this email.

-- 
224: https://bugs.devuan.org/cgi/bugreport.cgi?bug=224
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [Procps package] ["free" command] "Old" output is now the only one without notice
From: Arne Wichmann <[email-masked]>
To: [email-masked]
Date: Thu, 22 Oct 2020 17:06:39 +0200

Version: 2:3.3.15-2+devuan1
Package: Procps

As far as I can see, the documentation of free does not talk about -o or
--old anymore. If I am blind, please reopen. ;)

cu

AW
-- 
[...] If you don't want to be restricted, don't agree to it. If you are
coerced, comply as much as you must to protect yourself, just don't support
it. Noone can free you but yourself. (crag, on Debian Planet)
Arne Wichmann ([email-masked])

Subject: [Procps package] ["free" command] "Old" output is now the only one without notice
From: Stephane Ascoet <[email-masked]>
To: [email-masked]
Date: Tue, 10 Jul 2018 15:51:24 +0200

Package: Procps

---

From: Stephane Ascoet <[email-masked]>
Date: Mon, 2 Nov 2020 10:54:13 +0100

Hi, If I'm not wrong, updating only the documentation doesn't solve the 
main concern of this bug witch is a brokening-scripts-change in "free" 
output
-- 
Sincerely, Stephane Ascoet

---

From: Trek <[email-masked]>
Date: Tue, 3 Nov 2020 10:31:29 +0100

On Mon, 2 Nov 2020 10:54:13 +0100
Stephane Ascoet <[email-masked]> wrote:

> Hi, If I'm not wrong, updating only the documentation doesn't solve
> the main concern of this bug witch is a brokening-scripts-change in
> "free" output

I think you should report this backward-incompatible change to the
upstream developers, as the devuan version of the free command comes
unmodified from the procps package

https://gitlab.com/procps-ng/procps/blob/master/Documentation/bugs.md

the change was made 6 years ago, in 3 commits, which removed the -o
option and renamed -a to -w, in addition to a different output format

https://gitlab.com/procps-ng/procps/-/commit/51cd57259aa752fd3b958f61d71e78b4ca7dbef6

as the procps backward-compatibility actually is not guaranteed, may be
it's better to read directly the /proc/meminfo file, as it would not
change in future releases

ciao!

---

From: Share Piont <[email-masked]>
Date: 9 Jul 2022 11:54:44 +0800

Hello 224

Thanks for your response . As a Research Assistant of the 
Research and Development Department working with Cimar Laboratory 
Ltd Cambodia, One of the leading Bio-Pharmaceutical Companies 
here in Cambodia. I'm looking for a reliable businessman/
individual in your region to represent my company in sourcing 
some of our basic raw material used in the manufacturing of high-
quality Anti-Viral Vaccines, Cancer treatment, and other life-
saving Pharmaceutical Products.

This may not be your area of specialization but it will be 
another income generating business out of your specialty. This is 
because Our company is yet to locate any seller to buy from. 
However, I have been able to discover a local dealer who can 
supply us with this product. He is selling at a cheap rate, which 
is far cheaper than our previous purchases.

My director is not yet aware that I have found a new seller. Now, 
THIS IS MY PROPOSAL TO YOU; I want you to stand in as a new local 
dealer from your country and I will introduce you to our company. 
The reason for this is because I don't want my company to have 
direct contact with the local agent that sells this herbal oil 
extract very cheaply.

This will enable us to work together as partners and make really 
cool profits. You as the local seller will supply our company at 
a good rate which I will inform you how to go about it later when 
we are in agreement. You will be amazed with what we can achieve 
together.

I will give you more specific profit details when I receive 
feedback from you if you are interested.

Regards .
Megan Elizabeth
Research Assistant
Research and Development Department
Cimar Laboratory Ltd
Email: [email-masked]

---

From: PCRF <[email-masked]>
Date: 18 Oct 2023 21:55:24 -0400

Help Provide Urgent Humanitarian Care for Gaza's Children

Amidst the Unfolding Crisis in Gaza, Over One Million Children Hang in the Balance

PCRF is the primary humanitarian organization in Palestine, delivering crucial and life-saving medical relief and humanitarian aid where it is needed most.  Access to essential resources like food, clean water, and healthcare is severely limited.  Urgent action  is needed. With your support, we can continue this vital work, ensuring that the over one million children of Gaza receive the urgent care they need and deserve.

Hundreds of thousands of people have been displaced from the northern Gaza Strip to the central and southern provinces, including PCRF social worker Reem Matar - photographed here - and her family, who have relocated to southern Gaza for their safety. She works here to distribute urgent medical relief to hospitals in Gaza.

Please donate now as PCRF responds to the urgent humanitarian crisis unfolding in Gaza. Your support shows children and families in Gaza that they are not alone.

Click Here To Donate Now