Devuan bug report logs - #243
libdbus-1-dev : Depends: libdbus-1-3 (= 1.10.8-1+devuan1) but 1.10.18-1+devuan2.3 is to be installed

Package: libdbus-1-dev; Reported by: =?UTF-8?B?Tmljb2xhIE9ycsO5?= <nigu.orru@gmail.com>;
Date: Mon, 17 Sep 2018 23:18:01 UTC;
Maintainer for libdbus-1-dev is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#243; Package libdbus-1-dev. Full text available.



Acknowledgement sent to =?UTF-8?B?Tmljb2xhIE9ycsO5?= <nigu.orru@gmail.com>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org.

Your message specified a Severity: in the pseudo-header, but the severity value important was not recognised. The default severity normal is being used instead. The recognised values are: critical, grave, normal, minor, wishlist.

Full text available.



Message received at submit@bugs.devuan.org:

From: =?UTF-8?B?Tmljb2xhIE9ycsO5?= <nigu.orru@gmail.com>
Date: Tue, 18 Sep 2018 00:02:36 +0100
Subject: libdbus-1-dev : Depends: libdbus-1-3 (= 1.10.8-1+devuan1) but
To: submit@bugs.devuan.org

Package: libdbus-1-dev
Version: 1.10.8-1+devuan1
Severity: important

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
    attempting to apt-get install libgtk-3-dev

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
    apt-get install libgtk-3-dev

   * What was the outcome of this action?
    nico@devuan-3xS:~/Projects/itadinanta/gfx-gtk$ sudo apt-get
install libgtk-3-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev : Depends: libatk-bridge2.0-dev but it is not going to
be installed
E: Unable to correct problems, you have held broken packages.
nico@devuan-3xS:~/Projects/itadinanta/gfx-gtk$ sudo apt-get install
libatk-bridge2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libatk-bridge2.0-dev : Depends: libatspi2.0-dev but it is not going
to be installed
E: Unable to correct problems, you have held broken packages.
nico@devuan-3xS:~/Projects/itadinanta/gfx-gtk$ sudo apt-get install
libatspi2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libatspi2.0-dev : Depends: libdbus-1-dev but it is not going to be installed

   * What outcome did you expect instead?

libgtk-3-dev and all dependencies are installed


Notes: the following combination of versions (manually installed with
dpkg) allows progression of installation:

> dbus_1.10.18-1+devuan2.2_amd64.deb
> dbus-1-dbg_1.10.18-1+devuan2.2_amd64.deb
> dbus-x11_1.10.18-1+devuan2.2_amd64.deb
> libdbus-1-3_1.10.18-1+devuan2.2_amd64.deb
> libdbus-1-dev_1.10.18-1+devuan2.2_amd64.deb



*** End of the template - remove these template lines ***


-- System Information:
Distributor ID:    Devuan
Description:    Devuan GNU/Linux unstable (ceres)
Release:    unstable
Codename:    ceres
Architecture: x86_64

Kernel: Linux 4.18.0-1-amd64 (SMP w/16 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8),
LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages libdbus-1-dev depends on:
ii  libdbus-1-3  1.10.18-1+devuan2.3
ii  pkg-config   0.29-4+b1

libdbus-1-dev recommends no packages.

libdbus-1-dev suggests no packages.

-- 
Cheers,
Nico





Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 11 Dec 2018 09:47:34 UTC