Subject: bug#252: debsecan: Uses debian release names, and debian data

From: Boruch Baum <[email-masked]>
Date: Tue, 23 Oct 2018 20:09:54 -0400

Subject: debsecan: Uses debian release names and data
Package: debsecan
Version: 0.4.19
Severity: important

Dear Maintainer,

This package, created by and for the debian project, bases its operation
on a particular release (eg. wheezy, squeeze, buster, sid). The devuan
version should be using devuan release names, and should use devuan data
(eg. package versions, patch availability)

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 2.0.0 (ascii)
Release:	2.0.0
Codename:	ascii
Architecture: x86_64

Kernel: Linux 4.14.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages debsecan depends on:
ii  ca-certificates        20180409
ii  debconf [debconf-2.0]  1.5.69
ii  python                 2.7.15-3
ii  python-apt             1.7.0

Versions of packages debsecan recommends:
ii  cron                                       3.0pl1-130
ii  exim4                                      4.91-8
ii  exim4-daemon-light [mail-transport-agent]  4.91-8

debsecan suggests no packages.

-- 
hkp://keys.gnupg.net
CA45 09B5 5351 7C11 A9D1  7286 0036 9E45 1595 8BC0

---

From: Mark Hindley <[email-masked]>
Date: Wed, 8 Feb 2023 15:35:25 +0000

Control: severity -1 wishlist

Boruch,

> (eg. package versions, patch availability)

Thanks for this. I have had a quick look at debsecan and it is very much tied to
https://security-tracker.debian.org/tracker/. Devuan doesn't provide an
equivalent service at the moment. Until we do, there is not much we can do. In
most cases, the Debian security information is still relevant to Devuan.

Mark