Devuan bug report logs - #284
e4defrag segfaults

Package: e2fsprogs; Reported by: Kristopher John Gamrat <gamrat.kristopher@gmail.com>;
Date: Sat, 26 Jan 2019 21:03:01 UTC;
Maintainer for e2fsprogs is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#284; Package e2fsprogs. Full text available.



Acknowledgement sent to Kristopher John Gamrat <gamrat.kristopher@gmail.com>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

From: Kristopher John Gamrat <gamrat.kristopher@gmail.com>
To: submit@bugs.devuan.org
Subject: e4defrag segfaults
Date: Sat, 26 Jan 2019 15:52:14 -0500

[Message part 1 (text/plain, inline)]

Package: e2fsprogs
Version: 1.44.5-1

When attempting to defrag with e4defrag, I see the following error message:

> [root@Printers ~]# e4defrag /
> e4defrag 1.44.5 (15-Dec-2018)
> ext4 defragmentation for directory(/)
> zsh: segmentation fault  e4defrag /

I have tried running e4defrag via bash, dash, and zsh, and I get the same 
result each time.

What should happen: e4defrag should defrag any ext4 partition. My system uses 
ext4 exclusively.

[signature.asc (application/pgp-signature, inline)]






Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Thu, 17 Oct 2019 13:30:41 UTC