Devuan bug report logs - #293
Image for Raspberry Pi 2 will not boot

Package: arm-sdk; Maintainer for arm-sdk is (unknown);

Reported by: Paul Bryan Roberts <>

Date: Thu, 14 Feb 2019 15:18:01 UTC

Severity: normal

Full log

🔗 View this message in rfc822 format

Subject: bug#293: Image for Raspberry Pi 2 will not boot
Reply-To: Paul Bryan Roberts <>,
Resent-From: Paul Bryan Roberts <>
Resent-Date: Thu, 14 Feb 2019 15:18:01 UTC
Resent-Message-ID: <>
X-Devuan-PR-Message: report 293
X-Devuan-PR-Package: armhf_raspi2
Received: via spool by id=B.155015700226717
          (code B ref -1); Thu, 14 Feb 2019 15:18:01 UTC
Received: (at submit) by; 14 Feb 2019 15:10:02 +0000
Received: from []
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Thu, 14 Feb 2019 16:10:02 +0100 (CET)
Received: from ( [])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by (Postfix) with ESMTPS id 05979F608D2
	for <>; Thu, 14 Feb 2019 16:04:09 +0100 (CET)
Received: from [] ( [])
	(Authenticated sender:
	by (Postfix) with ESMTPSA id 288E72003C
	for <>; Thu, 14 Feb 2019 15:04:08 +0000 (UTC)
From: Paul Bryan Roberts <>
Message-ID: <>
Date: Thu, 14 Feb 2019 15:03:30 +0000
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101
MIME-Version: 1.0
Content-Type: multipart/alternative;
Content-Language: en-GB
X-Spam-Status: No, score=-0.7 required=5.0 tests=HTML_MESSAGE,
	RCVD_IN_DNSWL_LOW,SPF_PASS autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
[Message part 1 (text/plain, inline)]
Package: armhf_raspi2
Version: ascii_2.0.0

"You need to supply a correct |Package| line in the pseudo-header in 
order for the bug tracking system to deliver the message to the 
package's maintainer."

Can't get as far a dpkg -S

 * The /exact/ and /complete/ text of any error messages printed or
   logged. This is very important!

NO ERROR MESSAGES just a blank screen - the colour spectrum of the 
Raspberry PI boot rom is replaced by a blank screen, nothing logged on 
the screen, no log-in prompt.

 * Exactly what you typed or did to demonstrate the problem.

NOTHING TYPED - I inserted the microSD card, then the HDMI cable, then 
the power supply.

 * A description of the incorrect behaviour: exactly what behaviour you
   were expecting, and what you observed. A transcript of an example
   session is a good way of showing this.

I was expecting lots of logging to the console and finally a log-in 
prompt.  See Details below.

 * A suggested fix, or even a patch, if you have one.

Sadly I have none, else I probably would not be wasting your/our time.

 * Details of the configuration of the program with the problem.
   Include the complete text of its configuration files.

Um ... I am not sure what would be relevant here.  I looks to me like 
that the boot-rom does not recognise the micro-SD card.  It is just as 
if it were not there.

Include any detail that seems relevant - you are in very little danger 
of making your report too long by including too much information.

OK. *Details* ...

I have an RPi 2 and an RPi 3 and three microSD cards.

Card 1 has 2018-11-13-raspbian-stretch as a sanity check.  It will boot 
all the way through to X-11 in both the RPi 2 and RPi 3, as expected.  
Ergo nothing obviously wrong with the kit.

Card 2 has devuan_ascii_2.0.0_arm64_raspi3.img, which I have been using 
for several weeks in the RPi 3.  When in the RPi 2, there is some boot 
console output before the Linux kernel crashes and halts, as expected.

Card 3 is devuan_ascii_2.0.0_armhf_raspi2.img, which I expect to boot in 
the RPi 3 and well as in the RPi 2.  It does not boot in either.

I installed devuan_ascii_2.0.0_arm64_raspi3.img on Card 3 and, in the 
RPi 3, it boots through to the log-in prompt, as expected. Ergo nothing 
obviously wrong with the microSD card.

I downloaded devuan_ascii_2.0.0_armhf_raspi2.img again and verified the 
MD5SUM (f33aa344956f1a75dab54a51312ba9af) was the same as last time and 
copied the new image to the microSD card using the instructions in

Still no joy but I infer there is/was nothing obviously wrong with my 
download plus copy to SD card methodology.

I tried the gpg notes in and I got:

pbr:devuan$ gpg --verify SHA256SUMS.asc && sha256sum -c SHA256SUMS
gpg: directory `/home/pbr/.gnupg' created
gpg: new configuration file `/home/pbr/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/pbr/.gnupg/gpg.conf' are not yet active 
during this run
gpg: keyring `/home/pbr/.gnupg/pubring.gpg' created
gpg: Signature made Wed 06 Jun 2018 12:25:01 BST using RSA key ID F78637DE
gpg: Can't check signature: public key not found

This suggests to me there is something 'intuitive' about this that 
wasn't common knowledge at the time I was born.  I cannot see how it is 

I have inserted the 'not working image/card' into the running Raspbian 
image and both partition are mounted.  I have unmounted them and run 
fsck -f on each partition and neither is reported as corrupt.  I have 
had a quick peek in /var/log of the mounted image and there is nothing 
there more recent than 06 Jun 2018.

This is not the kind of thing I can work around or debug so, as 
recommended in, I am trying 
to raise a bug report but, sadly, without knowing either the package 
name or the maintainer's name.

Here's hoping your hair is having a better day than mine ...

   P-B Roberts

[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <>.
Last modified: Tue Oct 4 02:51:02 2022;