Subject: bug#326: firmware [non-free] uninstallable.

From: Bruno <[email-masked]>
Date: Fri, 24 May 2019 19:41:32 +0200

Package: firmware-amd-graphics
Version: 20161130-4

 From the boot log :

   # dmesg | grep R300
   [    7.697361] [drm] Loading R300 Microcode
   [    7.718273] radeon 0000:01:05.0: firmware: failed to load 
radeon/R300_cp.bin (-2)
   [    7.718334] radeon 0000:01:05.0: Direct firmware load for 
radeon/R300_cp.bin failed with error -2

As root, I do :

  # apt update && apt upgrade && apt autoremove
Trovato:1 http://deb.devuan.org//merged ascii InRelease
Trovato:2 http://deb.devuan.org//merged ascii-security InRelease
Scaricamento di:3 http://deb.devuan.org//merged ascii-updates InRelease 
[25,6 kB]
Scaricamento di:4 http://deb.devuan.org//merged ascii-backports 
InRelease [25,6 kB]
Scaricamento di:5 http://deb.devuan.org//merged ascii-backports/main 
i386 Packages [594 kB]
Recuperati 645 kB in 2s (271 kB/s)
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati.
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

  # apt install firmware-amd-graphics
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti NUOVI saranno installati:
     firmware-amd-graphics
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 1.566 kB di archivi.
Dopo quest'operazione, verranno occupati 15,3 MB di spazio su disco.
Err:1 http://deb.devuan.org//merged ascii/non-free i386 
firmware-amd-graphics all 20161130-4      ( ndr: must be 20161130-5 or 
20190114-1 )
   404  Not Found [IP: 141.84.43.22 80]
E: Impossibile recuperare 
http://debian.bio.lmu.de/debian/pool/non-free/f/firmware-nonfree/firmware-amd-graphics_20161130-4_all.deb 
404  Not Found [IP: 141.84.43.22 80]
E: Impossibile scaricare alcuni pacchetti. Potrebbe essere utile 
eseguire "apt-get update" o provare l'opzione "--fix-missing".

On Debian site, for info :

https://packages.debian.org/search?keywords=firmware-amd-graphics

   Package firmware-amd-graphics
     jessie (oldstable) (kernel): Binary firmware for AMD/ATI graphics 
chips [non-free]
     20161130-5~deb8u1 [security]: all
     stretch (stable) (kernel): Binary firmware for AMD/ATI graphics 
chips [non-free]
     20161130-5: all
     stretch-backports (kernel): Binary firmware for AMD/ATI graphics 
chips [non-free]
     20190114-1~bpo9+2: all
     buster (testing) (kernel): Binary firmware for AMD/ATI graphics 
chips [non-free]
     20190114-1: all
     sid (unstable) (kernel): Binary firmware for AMD/ATI graphics chips 
[non-free]
     20190502-1: all

N.B. 20161130-4 not exist !
Ciao.

I am using :

  # lsb_release -a
  No LSB modules are available.
  Distributor ID:    Devuan
  Description:    Devuan GNU/Linux 2.0 (ascii)
  Release:    2.0
  Codename:    ascii

  # uname -a
  Linux Acer 4.9.0-9-686-pae #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) 
i686 GNU/Linux

  # dpkg --get-selections | grep linux-image
  linux-image-4.9.0-6-686-pae            deinstall
  linux-image-4.9.0-9-686-pae            install
  linux-image-686-pae                        install

  # ls -l /lib/modules
  totale 8
  drwxr-xr-x 2 root root 4096 apr 28 08:26 4.9.0-6-686-pae
  drwxr-xr-x 3 root root 4096 mag 24 16:52 4.9.0-9-686-pae

---

From: [email-masked] (Devuan bug Tracking System)

Thank you for the problem report you have sent regarding Devuan.
This is an automatically generated reply, to let you know your message has
been received.  It is being forwarded to the developers (but not the mailing
list, as you requested) for their attention; they will reply in due course.

Your message has been sent to the package maintainer(s):
 [email-masked]

If you wish to submit further information on your problem, please send
it to [email-masked] (and *not*
to [email-masked]).

Please do not reply to the address at the top of this message,
unless you wish to report a problem with the bug-tracking system.

Devuan Bugs Owner
(administrator, Devuan bugs database)

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Wed, 08 Feb 2023 16:20:02 +0000

This is an automatic notification regarding your bug report
which was filed against the firmware-amd-graphics package:

#326: firmware [non-free] uninstallable.

It has been closed by Mark Hindley <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mark Hindley <[email-masked]> by
replying to this email.

-- 
326: https://bugs.devuan.org/cgi/bugreport.cgi?bug=326
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: Re: bug#326: firmware [non-free] uninstallable.
From: Mark Hindley <[email-masked]>
To: Bruno <[email-masked]>, [email-masked]
Date: Wed, 8 Feb 2023 16:17:16 +0000

> firmware-amd-graphics all 20161130-4      ( ndr: must be 20161130-5 or

This is an amprolla mismerge, long gone. Currently, ascii has

 20161130-5
  http://deb.devuan.org/merged ascii/non-free amd64
  http://deb.devuan.org/merged ascii/non-free i386
  http://deb.devuan.org/merged ascii/non-free arm64
  http://deb.devuan.org/merged ascii/non-free ppc64el

Closing

Mark

Subject: firmware [non-free] uninstallable.
From: Bruno <[email-masked]>
To: [email-masked]
Date: Fri, 24 May 2019 19:41:32 +0200

 From the boot log :

   # dmesg | grep R300

As root, I do :

I am using :

  # lsb_release -a

  # uname -a

  # ls -l /lib/modules
  totale 8