Devuan bug report logs - #327
mikutter: 3.8.8 crashes when trying to create a twitter account

Package: mikutter; Reported by: Arthur Marsh <arthur.marsh@internode.on.net>;
Date: Sun, 26 May 2019 11:03:01 UTC;
Maintainer for mikutter is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#327; Package mikutter. Full text available.



Acknowledgement sent to Arthur Marsh <arthur.marsh@internode.on.net>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.



Message received at submit@bugs.devuan.org:

From: Arthur Marsh <arthur.marsh@internode.on.net>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: mikutter: 3.8.8 crashes when trying to create a twitter account
Date: Sun, 26 May 2019 20:19:12 +0930

Package: mikutter
Version: 3.8.8+dfsg-1
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

Updated mikutter, started it, as no account came up, attempted to add my twitter account.

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

Tried again from the command line.

   * What was the outcome of this action?

$ mikutter
Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
        from /usr/share/mikutter/core/mui/gtk_crud.rb:15:in `initialize'
        from /usr/share/mikutter/core/mui/gtk_tree_view_pretty_scroll.rb:15:in `initialize'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:42:in `initialize'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:135:in `new'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:135:in `block in <top (required)>'
        from /usr/lib/ruby/vendor_ruby/pluggaloid/plugin.rb:36:in `instance_eval'
        from /usr/lib/ruby/vendor_ruby/pluggaloid/plugin.rb:36:in `create'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:27:in `<top (required)>'
        from /usr/share/mikutter/core/miquire_plugin.rb:158:in `load'
        from /usr/share/mikutter/core/miquire_plugin.rb:158:in `block in load'
        from /usr/share/mikutter/core/utils.rb:278:in `block in atomic'
        from /usr/lib/ruby/2.5.0/monitor.rb:226:in `mon_synchronize'
        from /usr/share/mikutter/core/utils.rb:278:in `atomic'
        from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
        from /usr/share/mikutter/core/miquire_plugin.rb:149:in `block (2 levels) in load'
        from /usr/share/mikutter/core/miquire_plugin.rb:147:in `each'
        from /usr/share/mikutter/core/miquire_plugin.rb:147:in `block in load'
        from /usr/share/mikutter/core/utils.rb:278:in `block in atomic'
        from /usr/lib/ruby/2.5.0/monitor.rb:226:in `mon_synchronize'
        from /usr/share/mikutter/core/utils.rb:278:in `atomic'
        from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
        from /usr/share/mikutter/core/miquire_plugin.rb:98:in `block in load_all'
        from /usr/share/mikutter/core/miquire_plugin.rb:38:in `block in each_spec'
        from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
        from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
        from /usr/share/mikutter/core/miquire_plugin.rb:36:in `each_spec'
        from /usr/share/mikutter/core/miquire_plugin.rb:96:in `load_all'
        from /usr/share/mikutter/core/boot/load_plugin.rb:10:in `<top (required)>'
        from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
        from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
        from /usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
        from /usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
        from /usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
        from /usr/share/mikutter/core/miquire.rb:75:in `each'
        from /usr/share/mikutter/core/miquire.rb:75:in `miquire'
        from /usr/share/mikutter/core/miquire.rb:18:in `miquire'
        from /usr/share/mikutter/mikutter.rb:43:in `<main>'
Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
        from /usr/share/mikutter/core/mui/gtk_crud.rb:15:in `initialize'
        from /usr/share/mikutter/core/mui/gtk_tree_view_pretty_scroll.rb:15:in `initialize'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:42:in `initialize'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:135:in `new'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:135:in `block in <top (required)>'
        from /usr/lib/ruby/vendor_ruby/pluggaloid/plugin.rb:36:in `instance_eval'
        from /usr/lib/ruby/vendor_ruby/pluggaloid/plugin.rb:36:in `create'
        from /usr/share/mikutter/core/plugin/activity/activity.rb:27:in `<top (required)>'
        from /usr/share/mikutter/core/miquire_plugin.rb:158:in `load'
        from /usr/share/mikutter/core/miquire_plugin.rb:158:in `block in load'
        from /usr/share/mikutter/core/utils.rb:278:in `block in atomic'
        from /usr/lib/ruby/2.5.0/monitor.rb:226:in `mon_synchronize'
        from /usr/share/mikutter/core/utils.rb:278:in `atomic'
        from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
        from /usr/share/mikutter/core/miquire_plugin.rb:149:in `block (2 levels) in load'
        from /usr/share/mikutter/core/miquire_plugin.rb:147:in `each'
        from /usr/share/mikutter/core/miquire_plugin.rb:147:in `block in load'
        from /usr/share/mikutter/core/utils.rb:278:in `block in atomic'
        from /usr/lib/ruby/2.5.0/monitor.rb:226:in `mon_synchronize'
        from /usr/share/mikutter/core/utils.rb:278:in `atomic'
        from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
        from /usr/share/mikutter/core/miquire_plugin.rb:98:in `block in load_all'
        from /usr/share/mikutter/core/miquire_plugin.rb:38:in `block in each_spec'
        from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
        from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
        from /usr/share/mikutter/core/miquire_plugin.rb:36:in `each_spec'
        from /usr/share/mikutter/core/miquire_plugin.rb:96:in `load_all'
        from /usr/share/mikutter/core/boot/load_plugin.rb:10:in `<top (required)>'
        from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
        from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
        from /usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
        from /usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
        from /usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
        from /usr/share/mikutter/core/miquire.rb:75:in `each'
        from /usr/share/mikutter/core/miquire.rb:75:in `miquire'
        from /usr/share/mikutter/core/miquire.rb:18:in `miquire'
        from /usr/share/mikutter/mikutter.rb:43:in `<main>'

   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux beowulf/ceres
Release:	10
Codename:	n/a
Architecture: x86_64

Kernel: Linux 5.2.0-rc1+ (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: sysvinit (via /sbin/init)

Versions of packages mikutter depends on:
ii  ruby                   1:2.5.1
ii  ruby-addressable       2.5.2-1
ii  ruby-cairo             1.16.4-1
ii  ruby-delayer           0.0.2-5
ii  ruby-delayer-deferred  2.0.0-3
ii  ruby-diva              0.3.2-1
ii  ruby-gettext           3.2.9-1
ii  ruby-gtk2              3.3.6-1
ii  ruby-hmac              0.4.0-5
ii  ruby-httpclient        2.8.3-2
ii  ruby-instance-storage  1.0.0-3
ii  ruby-json              2.1.0+dfsg-2+b1
ii  ruby-locale            2.1.2-1
ii  ruby-memoist           0.16.0-2
ii  ruby-moneta            1.0.0-5
ii  ruby-nokogiri          1.10.0+dfsg1-2
ii  ruby-oauth             0.5.4-1
ii  ruby-pluggaloid        1.1.2-1
ii  ruby-text              1.3.0-1
ii  ruby-twitter-text      1.14.7+conformance-1
ii  ruby-typed-array       0.1.2-6

Versions of packages mikutter recommends:
ii  alsa-utils     1.1.8-2
ii  libnotify-bin  0.7.7-4

mikutter suggests no packages.

-- no debconf information





Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 20 Aug 2019 01:47:47 UTC