Devuan bug report logs - #336
prelink: running prelink on systemsettings5 causes segfault when running application

Package: prelink; Maintainer for prelink is (unknown);

Reported by: Arthur Marsh <arthur.marsh@internode.on.net>

Date: Tue, 25 Jun 2019 11:03:01 UTC

Severity: normal

Tags: debian

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#336; Package prelink. (full text, mbox, link).


Acknowledgement sent to Arthur Marsh <arthur.marsh@internode.on.net>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Arthur Marsh <arthur.marsh@internode.on.net>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: prelink: running prelink on systemsettings5 causes segfault when running application
Date: Tue, 25 Jun 2019 20:23:27 +0930
Package: prelink
Version: 0.0.20131005-1+b10
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

running prelink on systemsettings5 from package 
systemsettings version 4:5.14.5-1.1

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

reinstalling systemsettings package and not running prelink on systemsettings5
allowed systemsettings to run fine.

   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux beowulf/ceres
Release:	10
Codename:	n/a
Architecture: x86_64

Kernel: Linux 5.2.0-rc6+ (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE= (charmap=UTF-8), LANGUAGE=en_GB (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: sysvinit (via /sbin/init)

Versions of packages prelink depends on:
ii  execstack  0.0.20131005-1+b10

prelink recommends no packages.

prelink suggests no packages.

-- Configuration Files:
/etc/prelink.conf changed:
-b *.la
-b *.png
-b *.py
-b *.pl
-b *.pm
-b *.sh
-b *.xml
-b *.xslt
-b *.a
-b *.js
-b /lib/modules
-b /usr/lib/locale
-l /usr/local/sbin
-l /sbin
-l /usr/sbin
-l /usr/local/bin
-l /bin
-l /usr/bin
-l /usr/games
-l /usr/local/lib
-l /lib
-l /usr/lib


-- no debconf information


Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#336; Package prelink. (Mon, 03 Feb 2020 14:18:02 GMT) (full text, mbox, link).


Message #8 received at 336@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 336@bugs.devuan.org, 337@bugs.devuan.org
Subject: Re: prelink: running prelink on systemsettings5 causes segfault when running application
Date: Mon, 3 Feb 2020 14:07:46 +0000
Control: tags -1 debian

Arthur,

Thanks for this. 

prelink is not a forked package. You would be better reporting this issue
directly to Debian's BTS.

Thanks.

Mark

Added tag(s) debian. Request was from Mark Hindley <mark@hindley.org.uk> to 336-submit@bugs.devuan.org. (Mon, 03 Feb 2020 14:18:04 GMT) (full text, mbox, link).


Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#336; Package prelink. (Mon, 03 Feb 2020 14:18:08 GMT) (full text, mbox, link).


Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue Sep 29 03:02:55 2020;