Devuan bug report logs - #340
quassel-core: no permission to open certificate file, cannot write quasselcore configuration

Package: quassel-core; Reported by: Martin <Martin@Lichtvoll.de>;
Date: Mon, 8 Jul 2019 20:03:01 UTC;
Maintainer for quassel-core is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#340; Package quassel-core. Full text available.



Acknowledgement sent to Martin <Martin@Lichtvoll.de>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org.

Your message specified a Severity: in the pseudo-header, but the severity value important was not recognised. The default severity normal is being used instead. The recognised values are: critical, grave, normal, minor, wishlist.

Full text available.



Message received at submit@bugs.devuan.org:

From: Martin <Martin@Lichtvoll.de>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: quassel-core: no permission to open certificate file, cannot write quasselcore configuration
Date: Mon, 08 Jul 2019 21:56:11 +0200

Package: quassel-core
Version: 1:0.13.1-1
Severity: important

I am using Quasselcore on Devuan. I just upgraded from Devuan Ascii
(based on Debian Stretch) to Devuan Beowulf (based on Debian Buster).

After rebooting into the 4.19.0-5 kernel with apparmor installed I got
the following in /var/log/quassel/core.log:

2019-07-08 21:41:15 [Warn ] SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2019-07-08 21:41:15 [Warn ] SslServer: Unable to set certificate file
           Quassel Core will still work, but cannot provide SSL for client connections.
           Please see https://quassel-irc.org/faq/cert to learn how to enable SSL support.
2019-07-08 21:41:15 [Warn ] SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2019-07-08 21:41:15 [Warn ] PostgreSQL driver plugin not available for Qt. Installed drivers: QSQLITE
2019-07-08 21:41:15 [Warn ] No storage backend selected!
2019-07-08 21:41:15 [Error] Cannot write quasselcore configuration; probably a permission problem.


After using 'aa-disable quasselcore', it works:

2019-07-08 21:44:58 [Warn ] PostgreSQL driver plugin not available for Qt. Installed drivers: QSQLITE
2019-07-08 21:44:58 [Info ] SQLite storage backend is ready. Schema version: 31
2019-07-08 21:44:58 [Info ] Database authenticator is ready.
2019-07-08 21:44:58 [Info ] Listening for GUI clients on IPv6 :: port 4242 using protocol version 10
2019-07-08 21:44:58 [Info ] Listening for GUI clients on IPv4 0.0.0.0 port 4242 using protocol version 10
2019-07-08 21:44:58 [Info ] Restoring previous core state...
2019-07-08 21:44:59 [Warn ] Type conversion already registered from type QSharedPointer<QNetworkSession> to type QObject*
2019-07-08 21:44:59 [Warn ] Could not connect to Debian (The remote host closed the connection)
2019-07-08 21:44:59 [Warn ] Could not connect to Debian (The remote host closed the connection)


AFAIK the packages for the kernel, AppArmor and Quassel Core are just
taken verbatim from Debian. So unless the issue is related to using
SysVInit instead of Systemd I see no connection to Devuan. The
'quassel-core' package does seem to contain both a systemd
service and an init script.

Thus I believe it may make sense to forward this issue to the Debian
bugtracker.

Thanks,
Martin 


-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux beowulf/ceres
Release:	10
Codename:	n/a
Architecture: x86_64

Kernel: Linux 4.19.0-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages quassel-core depends on:
ii  adduser            3.118
ii  libc6              2.28-10
ii  libgcc1            1:8.3.0-6
ii  libqca-qt5-2       2.1.3-2
ii  libqt5core5a       5.11.3+dfsg1-1
ii  libqt5network5     5.11.3+dfsg1-1
ii  libqt5script5      5.11.3+dfsg-3
ii  libqt5sql5         5.11.3+dfsg1-1
ii  libqt5sql5-sqlite  5.11.3+dfsg1-1
ii  libstdc++6         8.3.0-6
ii  lsb-base           10.2019051400
ii  openssl            1.1.1c-1
ii  zlib1g             1:1.2.11.dfsg-1

quassel-core recommends no packages.

Versions of packages quassel-core suggests:
pn  libqt5sql5-psql  <none>

-- no debconf information





Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Mon, 16 Dec 2019 07:10:23 UTC