Devuan bug report logs - #349
redmine: Postinstallation script fails

Package: redmine; Maintainer for redmine is (unknown);

Reported by: "Alvaro G. M." <alvaro.gamez@hazent.com>

Date: Tue, 3 Sep 2019 07:33:02 UTC

Severity: grave

Done: Mark Hindley <mark@hindley.org.uk>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#349; Package redmine. (full text, mbox, link).


Acknowledgement sent to "Alvaro G. M." <alvaro.gamez@hazent.com>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: "Alvaro G. M." <alvaro.gamez@hazent.com>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: redmine: Postinstallation script fails
Date: Tue, 3 Sep 2019 09:11:57 +0200
Package: redmine
Version: 4.0.4-1
Severity: grave

Dear Maintainer,

This version seems uninstallable because post script script fails:

Setting up redmine (4.0.4-1) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/redmine/instances/default.conf
redmine/instance already exists and has privileges on redmine_default.
creating database redmine_default: already exists.
dbconfig-common: flushing administrative password
rake aborted!
NameError: uninitialized constant Rake::TestTask
/usr/share/redmine/plugins/redmine_ldap_sync/lib/tasks/testing.rake:37:in `block (4 levels) in <top (required)>'
/usr/share/redmine/plugins/redmine_ldap_sync/lib/tasks/testing.rake:35:in `block (3 levels) in <top (required)>'
/usr/share/redmine/plugins/redmine_ldap_sync/lib/tasks/testing.rake:20:in `block (2 levels) in <top (required)>'
/usr/share/redmine/plugins/redmine_ldap_sync/lib/tasks/testing.rake:19:in `block in <top (required)>'
/usr/share/redmine/plugins/redmine_ldap_sync/lib/tasks/testing.rake:18:in `<top (required)>'
/usr/share/redmine/lib/tasks/redmine.rake:190:in `load'
/usr/share/redmine/lib/tasks/redmine.rake:190:in `block in <top (required)>'
/usr/share/redmine/lib/tasks/redmine.rake:190:in `each'
/usr/share/redmine/lib/tasks/redmine.rake:190:in `<top (required)>'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/engine.rb:650:in `load'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/engine.rb:650:in `block in run_tasks_blocks'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/engine.rb:650:in `each'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/engine.rb:650:in `run_tasks_blocks'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/application.rb:515:in `run_tasks_blocks'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/engine.rb:459:in `load_tasks'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/railtie.rb:190:in `public_send'
/usr/share/rubygems-integration/all/gems/railties-5.2.3/lib/rails/railtie.rb:190:in `method_missing'
/usr/share/redmine/Rakefile:6:in `<top (required)>'
(See full trace by running task with --trace)
dpkg: error processing package redmine (--configure):
 installed redmine package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 redmine
E: Sub-process /usr/bin/dpkg returned an error code (1)


-- System Information:
Debian Release: 10.0
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages redmine depends on:
ii  dbconfig-common                 2.0.12
ii  debconf [debconf-2.0]           1.5.73
ii  libjs-jquery                    3.3.1~dfsg-3
ii  libjs-jquery-ui                 1.12.1+dfsg-5
ii  libjs-raphael                   2.1.0-1
ii  redmine-mysql                   4.0.4-1
ii  ruby                            1:2.5.1
ii  ruby-actionpack-action-caching  1.2.0-2
ii  ruby-actionpack-xml-parser      2.0.1-3
ii  ruby-bundler                    1.17.3-3
ii  ruby-coderay                    1.1.2-2
ii  ruby-csv                        3.0.2-1
ii  ruby-i18n                       1.5.3-1
ii  ruby-jquery-rails               4.3.3-1
ii  ruby-mail                       2.7.1+dfsg1-1
ii  ruby-mime-types                 3.2.2-1
ii  ruby-mimemagic                  0.3.2+dfsg-1
ii  ruby-mini-mime                  1.0.1-1
ii  ruby-net-ldap                   0.16.1-1
ii  ruby-nokogiri                   1.10.4+dfsg1-1
ii  ruby-openid                     2.7.0debian-1
ii  ruby-rack                       2.0.6-3
ii  ruby-rack-openid                1.4.2-1
ii  ruby-rack-test                  0.7.0-1
ii  ruby-rails                      2:5.2.3+dfsg-1
ii  ruby-rails-dom-testing          2.0.3-3
ii  ruby-rails-observers            0.1.5-1
ii  ruby-rbpdf                      1.19.5+ds.1-1
ii  ruby-redcarpet                  3.4.0-4+b1
ii  ruby-request-store              1.3.0-1
ii  ruby-rmagick                    2.16.0-6
ii  ruby-roadie                     3.5.0-1
ii  ruby-roadie-rails               1.3.0-1
ii  ruby-rouge                      3.8.0-1

Versions of packages redmine recommends:
ii  passenger  5.0.30-1.1

Versions of packages redmine suggests:
pn  bzr         <none>
pn  cvs         <none>
pn  darcs       <none>
ii  git         1:2.23.0-1
pn  mercurial   <none>
pn  ruby-fcgi   <none>
ii  subversion  1.10.6-1

-- debconf information:
  redmine/current-instances: default
  redmine/instances/default/pgsql/method: TCP/IP
  redmine/instances/default/db/dbname: redmine_default
  redmine/instances/default/remote/host: localhost
  redmine/instances/default/install-error: abort
  redmine/instances/default/internal/reconfiguring: false
  redmine/instances/default/upgrade-backup: true
  redmine/instances/default/dbconfig-remove: true
  redmine/instances/default/remote/newhost:
  redmine/instances/default/mysql/method: Unix socket
* redmine/instances/default/dbconfig-install: true
  redmine/instances/default/pgsql/manualconf:
  redmine/instances/default/pgsql/changeconf: false
  redmine/instances/default/internal/skip-preseed: false
  redmine/instances/default/db/app-user: redmine/instance@localhost
  redmine/instances/default/upgrade-error: abort
  redmine/instances/default/default-language: en
  redmine/default-language: en
* redmine/instances/default/database-type: mysql
  redmine/instances/default/missing-db-package-error: abort
  redmine/instances/default/mysql/authplugin: default
* redmine/instances/default/mysql/admin-user: debian-sys-maint
  redmine/instances/default/passwords-do-not-match:
  redmine/instances/default/pgsql/admin-user: postgres
  redmine/instances/default/pgsql/no-empty-passwords:
  redmine/instances/default/purge: false
  redmine/instances/default/remote/port:
  redmine/instances/default/dbconfig-upgrade: true
  redmine/instances/default/remove-error: abort
  redmine/instances/default/dbconfig-reinstall: false
  redmine/instances/default/db/basepath:
  redmine/instances/default/pgsql/authmethod-admin: ident
  redmine/instances/default/pgsql/authmethod-user: password

-- 
Alvaro G. M.


Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#349; Package redmine. (full text, mbox, link).


Acknowledgement sent to Alvaro Gamez <alvaro.gamez@hazent.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. (full text, mbox, link).


Message #10 received at 349@bugs.devuan.org (full text, mbox, reply):

From: Alvaro Gamez <alvaro.gamez@hazent.com>
To: 349@bugs.devuan.org
Subject: Solved
Date: Tue, 3 Sep 2019 09:57:13 +0200
[Message part 1 (text/plain, inline)]
Please, close this bug, as I've already found what was the issue.

This system had a very old and deprecated version of redmine that was
manually installed and it was conflicting with the new package.

Sorry for the inconvenience, I was way too fast on reporting this!

-- 
Álvaro Gámez Machado
[Message part 2 (text/html, inline)]

Reply sent to Mark Hindley <mark@hindley.org.uk>:
You have taken responsibility. (Tue, 14 Jan 2020 15:03:09 GMT) (full text, mbox, link).


Notification sent to "Alvaro G. M." <alvaro.gamez@hazent.com>:
bug acknowledged by developer. (Tue, 14 Jan 2020 15:03:10 GMT) (full text, mbox, link).


Message #15 received at 349-done@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 349-done@bugs.devuan.org
Subject: Re: Solved
Date: Tue, 14 Jan 2020 14:50:48 +0000
Closing, as requested

Mark

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Wed May 27 08:31:52 2020;