Subject: libsqlite3-0 3.31.0-1 causes firefox/firefox esr to crash

From: Arthur Marsh <[email-masked]>
Date: Thu, 23 Jan 2020 21:24:03 +1030

Package: libsqlite3-0

Version: 3.30.1+fossil191229-1

Severity: important

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

[UPGRADE] libsqlite3-0:amd64 3.30.1+fossil191229-1 -> 3.31.0-1

After this upgrade, firefox crashed immediately on startup.

   * What exactly did you do (or not do) that was effective (or ineffective)?

downgrading libsqlite3-0 to 3.30.1+fossil191229-1 resolved the issue, but I first had to start firefox in safe mode, wait for it to fully load, quit, then restart firefox.

   * What was the outcome of this action?

   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 10.0
 APT prefers experimental
 APT policy: (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 5.5.0-rc7+ (SMP w/4 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB (
charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: sysvinit (via /sbin/init)

Versions of packages libsqlite3-0 depends on:
ii  libc6  2.29-9

libsqlite3-0 recommends no packages.

libsqlite3-0 suggests no packages

-- no debconf information

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Mark Hindley <[email-masked]>
Date: Thu, 23 Jan 2020 14:47:14 +0000

Control: tags -1 debian 
Control: notfound -1 3.30.1+fossil191229-1
Control: found -1 3.31.0-1

Arthur,

This looks like https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949644

This is not a forked package, so I suggest you add your voice to the Debian
BTS to get it fixed.

Thanks

Mark

---

From: Mark Hindley <[email-masked]>
Date: Sun, 2 Feb 2020 17:40:42 +0000

Version: 3.31.0+really3.30.1+fossil191229-1

Fixed in Debian #949644.

Closing.

Mark