Subject: [Devuan-bugs] bug#383: eudev: Probably incorrect installation error about missing kernel sumbols.

From: Svante Signell <[email-masked]>
Date: Wed, 29 Jan 2020 19:01:27 +0100

Package: eudev
Version: 3.2.2-13
tags 383 moreinfo

Hello,

Seems like you are hitting some problems not seen before.

Can you please give us the following information:

 - Which release do you use?
   (from the package eudev-3.2.2-13 you seem to use ascii)
 - Which kernels do you have installed?
 - You can easily check which kernel features you have by e.g.:
   cat /boot/config-4.19.0-6-amd64 | grep CONFIG_INOTIFY_USER;

 - alternately, and that is what the eudev.postinst script does:
   cat /proc/kallsyms| grep "inotify_init" etc.

Please check if the problems remains with eudev-3.2.9-4.

Thanks!

---

From: Arne Wichmann <[email-masked]>
Date: Wed, 1 Apr 2020 16:51:31 +0200

Package: eudev
Version: 3.2.2-13
tags 383 -moreinfo
severity 383 normal

Hi!

For some reason this did not reach me. It did not even reach my spam box.

>    (from the package eudev-3.2.2-13 you seem to use ascii)

Primarily ascii.

>  - Which kernels do you have installed?

And this is probably the reason why this has not been seen before - I
compile my own kernel (for educational reasons primarily) from the ceres
sources.

(515) aw@anhrefn $ cat /proc/version 
Linux version 5.5.13 (aw@anhrefn) (gcc version 8.3.0 (Debian 8.3.0-6)) #2.0
SMP PREEMPT Tue Mar 31 12:20:33 CEST 2020

> Please check if the problems remains with eudev-3.2.9-4.

The upgrade went smoothly. I presume the problem is only of interest for
people using a new kernel on an ascii system. I downgrade to normal - feel
free to downgrade even more. ;)

cu

AW
-- 
[...] If you don't want to be restricted, don't agree to it. If you are
coerced, comply as much as you must to protect yourself, just don't support
it. Noone can free you but yourself. (crag, on Debian Planet)
Arne Wichmann ([email-masked])

---

From: Arne Wichmann <[email-masked]>
Date: Thu, 22 Oct 2020 14:31:44 +0200

Package: eudev
Version: 3.2.2-13
tags 383 -moreinfo
severity 383 normal

Hi!

Primarily ascii.

cu

AW