Subject: bug#383: eudev: Probably incorrect installation error about missing kernel sumbols.

From: Arne Wichmann <[email-masked]>
Date: Tue, 28 Jan 2020 13:17:07 +0100

Package: eudev
Version: 3.2.2-13
Severity: grave

Dear Maintainer,

When installing eudev I get:

Since release 198, udev requires support for the following features in
the running kernel:

- inotify(2)            (CONFIG_INOTIFY_USER)
- signalfd(2)           (CONFIG_SIGNALFD)
- accept4(2)
- open_by_handle_at(2)  (CONFIG_FHANDLE)
- timerfd_create(2)     (CONFIG_TIMERFD)
- epoll_create(2)       (CONFIG_EPOLL)

Grepping through /proc/kallsyms gives me:
0000000000000000 t do_inotify_init
0000000000000000 T __x64_sys_inotify_init1
0000000000000000 T __ia32_sys_inotify_init1
0000000000000000 T __ia32_sys_inotify_init
0000000000000000 T __x64_sys_inotify_init

Do I miss something or did some interfaces change?

-- Package-specific info:

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 9 (n/a)
Release:	9
Codename:	n/a
Architecture: x86_64

Kernel: Linux 5.4.0-3-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_CRAP
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages eudev depends on:
ii  adduser      3.115
ii  debconf      1.5.61
ii  libblkid1    2.33.1-0.1+devuan1
ii  libc6        2.29-9
ii  libeudev1    3.2.2-13
ii  libkmod2     23-2
ii  libselinux1  3.0-1
ii  lsb-base     9.20161125
ii  procps       2:3.3.12-3+devuan2.1
ii  util-linux   2.29.2-1+devuan2.1

eudev recommends no packages.

eudev suggests no packages.

-- no debconf information

---

From: Svante Signell <[email-masked]>
Date: Wed, 29 Jan 2020 19:01:27 +0100

Package: eudev
Version: 3.2.2-13
tags 383 moreinfo

Hello,

Seems like you are hitting some problems not seen before.

Can you please give us the following information:

 - Which release do you use?
   (from the package eudev-3.2.2-13 you seem to use ascii)
 - Which kernels do you have installed?
 - You can easily check which kernel features you have by e.g.:
   cat /boot/config-4.19.0-6-amd64 | grep CONFIG_INOTIFY_USER;

 - alternately, and that is what the eudev.postinst script does:
   cat /proc/kallsyms| grep "inotify_init" etc.

Please check if the problems remains with eudev-3.2.9-4.

Thanks!

---

From: Arne Wichmann <[email-masked]>
Date: Wed, 1 Apr 2020 16:51:31 +0200

Package: eudev
Version: 3.2.2-13
tags 383 -moreinfo
severity 383 normal

Hi!

For some reason this did not reach me. It did not even reach my spam box.

>    (from the package eudev-3.2.2-13 you seem to use ascii)

Primarily ascii.

>  - Which kernels do you have installed?

And this is probably the reason why this has not been seen before - I
compile my own kernel (for educational reasons primarily) from the ceres
sources.

(515) aw@anhrefn $ cat /proc/version 
Linux version 5.5.13 (aw@anhrefn) (gcc version 8.3.0 (Debian 8.3.0-6)) #2.0
SMP PREEMPT Tue Mar 31 12:20:33 CEST 2020

> Please check if the problems remains with eudev-3.2.9-4.

The upgrade went smoothly. I presume the problem is only of interest for
people using a new kernel on an ascii system. I downgrade to normal - feel
free to downgrade even more. ;)

cu

AW
-- 
[...] If you don't want to be restricted, don't agree to it. If you are
coerced, comply as much as you must to protect yourself, just don't support
it. Noone can free you but yourself. (crag, on Debian Planet)
Arne Wichmann ([email-masked])

---

From: Arne Wichmann <[email-masked]>
Date: Thu, 22 Oct 2020 14:31:44 +0200

Package: eudev
Version: 3.2.2-13
tags 383 -moreinfo
severity 383 normal

Hi!

Primarily ascii.

cu

AW

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Mon, 26 Apr 2021 12:48:08 +0000

This is an automatic notification regarding your bug report
which was filed against the eudev package:

#383: eudev: Probably incorrect installation error about missing kernel sumbols.

It has been closed by Arne Wichmann <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Arne Wichmann <[email-masked]> by
replying to this email.

-- 
383: https://bugs.devuan.org/cgi/bugreport.cgi?bug=383
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: Fixed in 3.2.5-1 AFAICS
From: Arne Wichmann <[email-masked]>
To: [email-masked]
Date: Mon, 26 Apr 2021 14:29:05 +0200

As subject says - This bug has been gone for a while. I only affected ascii
anyway.

cu

AW

Subject: eudev: Probably incorrect installation error about missing kernel sumbols.
From: Arne Wichmann <[email-masked]>
To: Devuan Bug Tracking System <[email-masked]>
Date: Tue, 28 Jan 2020 13:17:07 +0100

Package: eudev
Version: 3.2.2-13
Severity: grave

Dear Maintainer,

-- System Information:
Distributor ID:	Devuan