Devuan bug report logs - #395
lightdm cannot be installed/is removed by apt-get dist-upgrade

version graph

Package: lightdm; Maintainer for lightdm is Ben Stack <bgstack15@gmail.com>;

Reported by: Nicola Orrù <nigu.orru@gmail.com>

Date: Sun, 16 Feb 2020 16:03:01 UTC

Severity: normal

Found in version 1.26.0-6

Done: Mark Hindley <mark@hindley.org.uk>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Sun, 16 Feb 2020 16:03:01 GMT) (full text, mbox, link).


Acknowledgement sent to Nicola Orrù <nigu.orru@gmail.com>:
New bug report received and forwarded. Copy sent to devuan-dev@lists.dyne.org. (Sun, 16 Feb 2020 16:03:03 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Nicola Orrù <nigu.orru@gmail.com>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Sun, 16 Feb 2020 15:54:05 +0000
Package: lightdm
Version: 1.26.0-6
Severity: normal

Dear Maintainer,

lightdm cannot be installed because of unmet dependencies:

$ sudo apt install lightdm
[sudo] password for nico:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lightdm : Depends: libpam-systemd or
                     logind
                     E: Unable to correct problems, you have held
broken packages.


-- System Information:
Distributor ID: Debian
Description:    Devuan GNU/Linux 4 (chimaera/ceres)
Release:        testing/unstable
Codename:       n/a
Architecture: x86_64

Kernel: Linux 5.4.0-4-amd64 (SMP w/16 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE,
TAINT_UNSIGNED_MODULE
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8),
LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages lightdm depends on:
ii  adduser                                3.118
ii  dbus                                   1.12.16-1+devuan2
ii  debconf [debconf-2.0]                  1.5.73
ii  libaudit1                              1:2.8.5-2+b1
ii  libc6                                  2.29-10
ii  libgcrypt20                            1.8.5-3
ii  libglib2.0-0                           2.62.4-2
pn  libpam-systemd | logind                <none>
ii  libpam0g                               1.3.1-5
ii  libxcb1                                1.13.1-5
ii  libxdmcp6                              1:1.1.2-3
ii  lightdm-gtk-greeter [lightdm-greeter]  2.0.7-1
ii  lsb-base                               11.1.0

Versions of packages lightdm recommends:
pn  xserver-xorg  <none>

Versions of packages lightdm suggests:
pn  accountsservice  <none>
ii  upower           1:0.9.23-2+devuan1.3
pn  xserver-xephyr   <none>



-- 
Cheers,
Nico

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Sun, 16 Feb 2020 17:33:02 GMT) (full text, mbox, link).


Message #8 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Sun, 16 Feb 2020 17:13:06 +0000
On Sun, 16 Feb 2020 15:54:05 +0000 =?UTF-8?B?Tmljb2xhIE9ycsO5?= <nigu.orru@gmail.com> wrote:
> Package: lightdm
> Version: 1.26.0-6
> Severity: normal
> 
> Dear Maintainer,
> 
> lightdm cannot be installed because of unmet dependencies:
> 
> $ sudo apt install lightdm
> [sudo] password for nico:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  lightdm : Depends: libpam-systemd or
>                      logind
>                      E: Unable to correct problems, you have held
> broken packages.
> 
> 
> -- System Information:
> Distributor ID: Debian
> Description:    Devuan GNU/Linux 4 (chimaera/ceres)
> Release:        testing/unstable
> Codename:       n/a
> Architecture: x86_64
> 
> Kernel: Linux 5.4.0-4-amd64 (SMP w/16 CPU cores)
> Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE,
> TAINT_UNSIGNED_MODULE
> Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8),
> LANGUAGE=en_GB:en (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: sysvinit (via /sbin/init)
> LSM: AppArmor: enabled
> 
> Versions of packages lightdm depends on:
> ii  adduser                                3.118
> ii  dbus                                   1.12.16-1+devuan2
> ii  debconf [debconf-2.0]                  1.5.73
> ii  libaudit1                              1:2.8.5-2+b1
> ii  libc6                                  2.29-10
> ii  libgcrypt20                            1.8.5-3
> ii  libglib2.0-0                           2.62.4-2
> pn  libpam-systemd | logind                <none>
> ii  libpam0g                               1.3.1-5
> ii  libxcb1                                1.13.1-5
> ii  libxdmcp6                              1:1.1.2-3
> ii  lightdm-gtk-greeter [lightdm-greeter]  2.0.7-1
> ii  lsb-base                               11.1.0
> 
> Versions of packages lightdm recommends:
> pn  xserver-xorg  <none>
> 

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Sun, 16 Feb 2020 17:33:04 GMT) (full text, mbox, link).


Acknowledgement sent to Mark Hindley <mark@hindley.org.uk>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Sun, 16 Feb 2020 17:33:07 GMT) (full text, mbox, link).


Message #13 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: Nicola Orrù <nigu.orru@gmail.com>
Cc: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Sun, 16 Feb 2020 17:19:16 +0000
Nicola,

Thanks.

I think you have an APT configuration issue.  libpam-elogind provides the logind
dependency that lightdm requires.

On Sun, Feb 16, 2020 at 03:54:05PM +0000, Nicola Orrù wrote:
> LANGUAGE=en_GB:en (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: sysvinit (via /sbin/init)
> LSM: AppArmor: enabled
> 
> Versions of packages lightdm depends on:
> ii  adduser                                3.118
> ii  dbus                                   1.12.16-1+devuan2
> ii  debconf [debconf-2.0]                  1.5.73
> ii  libaudit1                              1:2.8.5-2+b1
> ii  libc6                                  2.29-10
> ii  libgcrypt20                            1.8.5-3
> ii  libglib2.0-0                           2.62.4-2
> pn  libpam-systemd | logind                <none>

Do you have apt pinning of libpam-systemd? If so, that is what is preventing the
installation. libpam-elogind also provides libpam-systemd.

Mark

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Sun, 16 Feb 2020 20:33:02 GMT) (full text, mbox, link).


Acknowledgement sent to Nicola Orrù <nigu.orru@gmail.com>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Sun, 16 Feb 2020 20:33:04 GMT) (full text, mbox, link).


Message #18 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Nicola Orrù <nigu.orru@gmail.com>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Sun, 16 Feb 2020 20:22:46 +0000
Hi,

thanks for the help

apt-mark showhold doesn't show any pinned packages.

On Sun, 16 Feb 2020 at 17:19, Mark Hindley <mark@hindley.org.uk> wrote:
>
> Nicola,
>
> Thanks.
>
> I think you have an APT configuration issue.  libpam-elogind provides the logind
> dependency that lightdm requires.
>
> On Sun, Feb 16, 2020 at 03:54:05PM +0000, Nicola Orrů wrote:
> > LANGUAGE=en_GB:en (charmap=UTF-8)
> > Shell: /bin/sh linked to /bin/dash
> > Init: sysvinit (via /sbin/init)
> > LSM: AppArmor: enabled
> >
> > Versions of packages lightdm depends on:
> > ii  adduser                                3.118
> > ii  dbus                                   1.12.16-1+devuan2
> > ii  debconf [debconf-2.0]                  1.5.73
> > ii  libaudit1                              1:2.8.5-2+b1
> > ii  libc6                                  2.29-10
> > ii  libgcrypt20                            1.8.5-3
> > ii  libglib2.0-0                           2.62.4-2
> > pn  libpam-systemd | logind                <none>
>
> Do you have apt pinning of libpam-systemd? If so, that is what is preventing the
> installation. libpam-elogind also provides libpam-systemd.
>
> Mark



-- 
Cheers,
Nico

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Sun, 16 Feb 2020 20:33:06 GMT) (full text, mbox, link).


Acknowledgement sent to Nicola Orrù <nigu.orru@gmail.com>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Sun, 16 Feb 2020 20:33:08 GMT) (full text, mbox, link).


Message #23 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Nicola Orrù <nigu.orru@gmail.com>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Sun, 16 Feb 2020 20:24:37 +0000
I have installed

libpam-systemd,

as a result I got this:

The following packages will be REMOVED:
  consolekit libpam-ck-connector libpolkit-backend-consolekit-1-0
libpolkit-gobject-consolekit-1-0 libsystemd0

Is it expected?

On Sun, 16 Feb 2020 at 20:22, Nicola Orrù <nigu.orru@gmail.com> wrote:
>
> Hi,
>
> thanks for the help
>
> apt-mark showhold doesn't show any pinned packages.
>
> On Sun, 16 Feb 2020 at 17:19, Mark Hindley <mark@hindley.org.uk> wrote:
> >
> > Nicola,
> >
> > Thanks.
> >
> > I think you have an APT configuration issue.  libpam-elogind provides the logind
> > dependency that lightdm requires.
> >
> > On Sun, Feb 16, 2020 at 03:54:05PM +0000, Nicola Orrů wrote:
> > > LANGUAGE=en_GB:en (charmap=UTF-8)
> > > Shell: /bin/sh linked to /bin/dash
> > > Init: sysvinit (via /sbin/init)
> > > LSM: AppArmor: enabled
> > >
> > > Versions of packages lightdm depends on:
> > > ii  adduser                                3.118
> > > ii  dbus                                   1.12.16-1+devuan2
> > > ii  debconf [debconf-2.0]                  1.5.73
> > > ii  libaudit1                              1:2.8.5-2+b1
> > > ii  libc6                                  2.29-10
> > > ii  libgcrypt20                            1.8.5-3
> > > ii  libglib2.0-0                           2.62.4-2
> > > pn  libpam-systemd | logind                <none>
> >
> > Do you have apt pinning of libpam-systemd? If so, that is what is preventing the
> > installation. libpam-elogind also provides libpam-systemd.
> >
> > Mark
>
>
>
> --
> Cheers,
> Nico



-- 
Cheers,
Nico

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Sun, 16 Feb 2020 21:03:02 GMT) (full text, mbox, link).


Acknowledgement sent to Nicola Orrù <nigu.orru@gmail.com>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Sun, 16 Feb 2020 21:03:04 GMT) (full text, mbox, link).


Message #28 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Nicola Orrù <nigu.orru@gmail.com>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Sun, 16 Feb 2020 20:40:45 +0000
This is the only bit configuration I've got that could be held
responsible for pinning, AFAIK:

$ cat /etc/apt/preferences.d/avoid-systemd
Package: systemd-sysv
Pin: release o=Debian
Pin-Priority: -1

On Sun, 16 Feb 2020 at 20:24, Nicola Orrù <nigu.orru@gmail.com> wrote:
>
> I have installed
>
> libpam-systemd,
>
> as a result I got this:
>
> The following packages will be REMOVED:
>   consolekit libpam-ck-connector libpolkit-backend-consolekit-1-0
> libpolkit-gobject-consolekit-1-0 libsystemd0
>
> Is it expected?
>
> On Sun, 16 Feb 2020 at 20:22, Nicola Orrù <nigu.orru@gmail.com> wrote:
> >
> > Hi,
> >
> > thanks for the help
> >
> > apt-mark showhold doesn't show any pinned packages.
> >
> > On Sun, 16 Feb 2020 at 17:19, Mark Hindley <mark@hindley.org.uk> wrote:
> > >
> > > Nicola,
> > >
> > > Thanks.
> > >
> > > I think you have an APT configuration issue.  libpam-elogind provides the logind
> > > dependency that lightdm requires.
> > >
> > > On Sun, Feb 16, 2020 at 03:54:05PM +0000, Nicola Orrů wrote:
> > > > LANGUAGE=en_GB:en (charmap=UTF-8)
> > > > Shell: /bin/sh linked to /bin/dash
> > > > Init: sysvinit (via /sbin/init)
> > > > LSM: AppArmor: enabled
> > > >
> > > > Versions of packages lightdm depends on:
> > > > ii  adduser                                3.118
> > > > ii  dbus                                   1.12.16-1+devuan2
> > > > ii  debconf [debconf-2.0]                  1.5.73
> > > > ii  libaudit1                              1:2.8.5-2+b1
> > > > ii  libc6                                  2.29-10
> > > > ii  libgcrypt20                            1.8.5-3
> > > > ii  libglib2.0-0                           2.62.4-2
> > > > pn  libpam-systemd | logind                <none>
> > >
> > > Do you have apt pinning of libpam-systemd? If so, that is what is preventing the
> > > installation. libpam-elogind also provides libpam-systemd.
> > >
> > > Mark
> >
> >
> >
> > --
> > Cheers,
> > Nico
>
>
>
> --
> Cheers,
> Nico



-- 
Cheers,
Nico

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Mon, 17 Feb 2020 09:48:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mark Hindley <mark@hindley.org.uk>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Mon, 17 Feb 2020 09:48:04 GMT) (full text, mbox, link).


Message #33 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: Nicola Orrù <nigu.orru@gmail.com>
Cc: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Mon, 17 Feb 2020 09:33:46 +0000
On Sun, Feb 16, 2020 at 08:24:37PM +0000, Nicola Orrù wrote:
> I have installed
> 
> libpam-systemd,
> 
> as a result I got this:
> 
> The following packages will be REMOVED:
>   consolekit libpam-ck-connector libpolkit-backend-consolekit-1-0
> libpolkit-gobject-consolekit-1-0 libsystemd0
> 
> Is it expected?

Yes, libpam-elogind and consolekit are mutually exclusive and conflict.

Mark

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#395; Package lightdm. (Mon, 17 Feb 2020 10:03:01 GMT) (full text, mbox, link).


Acknowledgement sent to Nicola Orrù <nigu.orru@gmail.com>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Mon, 17 Feb 2020 10:03:06 GMT) (full text, mbox, link).


Message #38 received at 395@bugs.devuan.org (full text, mbox, reply):

From: Nicola Orrù <nigu.orru@gmail.com>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 395@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Mon, 17 Feb 2020 09:44:44 +0000
[Message part 1 (text/plain, inline)]
Ok, thanks. So far removing Consolekit seems to be doing the trick.

You can close the issue :) Thanks again!

On Mon, 17 Feb 2020, 09:33 Mark Hindley, <mark@hindley.org.uk> wrote:

> On Sun, Feb 16, 2020 at 08:24:37PM +0000, Nicola Orrů wrote:
> > I have installed
> >
> > libpam-systemd,
> >
> > as a result I got this:
> >
> > The following packages will be REMOVED:
> >   consolekit libpam-ck-connector libpolkit-backend-consolekit-1-0
> > libpolkit-gobject-consolekit-1-0 libsystemd0
> >
> > Is it expected?
>
> Yes, libpam-elogind and consolekit are mutually exclusive and conflict.
>
> Mark
>
[Message part 2 (text/html, inline)]

Reply sent to Mark Hindley <mark@hindley.org.uk>:
You have taken responsibility. (Mon, 17 Feb 2020 10:03:10 GMT) (full text, mbox, link).


Notification sent to Nicola Orrù <nigu.orru@gmail.com>:
bug acknowledged by developer. (Mon, 17 Feb 2020 10:03:12 GMT) (full text, mbox, link).


Message #43 received at 395-done@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: Nicola Orrù <nigu.orru@gmail.com>
Cc: 395-done@bugs.devuan.org
Subject: Re: lightdm cannot be installed/is removed by apt-get dist-upgrade
Date: Mon, 17 Feb 2020 09:55:16 +0000
On Mon, Feb 17, 2020 at 09:44:44AM +0000, Nicola Orrù wrote:
>    Ok, thanks. So far removing Consolekit seems to be doing the trick.
>    You can close the issue :) Thanks again!

Thanks

Mark

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Thu Oct 29 10:32:00 2020;