Devuan bug report logs - #397
cups-filters: Cups filters has hard depends on imagemagick makes unnistallable

version graph

Packages: imagemagick, cups-filters; Maintainer for imagemagick is (unknown); Maintainer for cups-filters is (unknown);

Reported by: PICCORO McKAY Lenz <mckaygerhard@gmail.com>

Date: Tue, 18 Feb 2020 16:03:01 UTC

Severity: grave

Found in version 2.2.1-8+deb9u4

Done: Mark Hindley <mark@hindley.org.uk>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#397; Package cups-filters,imagemagick. (Tue, 18 Feb 2020 16:03:01 GMT) (full text, mbox, link).


Acknowledgement sent to PICCORO McKAY Lenz <mckaygerhard@gmail.com>:
New bug report received and forwarded. Copy sent to devuan-dev@lists.dyne.org. (Tue, 18 Feb 2020 16:03:04 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: PICCORO McKAY Lenz <mckaygerhard@gmail.com>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: cups-filters: Cups filters has hard depends on imagemagick makes unnistallable
Date: Tue, 18 Feb 2020 11:10:02 -0430
Package: cups-filters,imagemagick
Version: 2.2.1-8+deb9u4
Severity: grave

Dear Maintainer,

   * What led up to the situation?

try to install several times in several machines graphicmagicks event
imagemagick (graphicsmagick-imagemagick-compat)m but it's impossible..
cups-filters package has a hard depends on imagemagick.. and this
cupsfilters are required by lsb-printin and hp cups modules

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

apt-get install graphicsmagick-imagemagick-compat

This len in that state:

Following packages will be erased:
  ayatana-indicator-printers cups cups-filters cups-pdf hplip
imagemagick imagemagick-6.q16 printer-driver-cups-pdf
printer-driver-gutenprint printer-driver-hpcups printer-driver-pxljr
printer-driver-splix task-print-server

   * What was the outcome of this action?

uninstalable due removes my cups system as i have running perfectly,
after command performs, cups hp printers does not work!

   * What outcome did you expect instead?

alternate depends on cups-filters to be able to install
graphicsmagick-imagemagick-compat



-- System Information:
Distributor ID: Debian
Description: Debian GNU/Linux 9.10 (strecht)
Release: 9.10
Codename: strecht

Architecture: x86_64

Kernel: Linux 4.9.0-11-amd64 (SMP w/2 CPU cores)
Locale: LANG=es_VE.UTF-8, LC_CTYPE= (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages cups-filters depends on:
ii  bc                               1.06.95-9+b3
ii  cups-filters-core-drivers        1.11.6-3+deb9u1
ii  ghostscript                      9.26a~dfsg-0+deb9u6
ii  imagemagick                      8:6.9.7.4+dfsg-11+deb9u7
ii  imagemagick-6.q16 [imagemagick]  8:6.9.7.4+dfsg-11+deb9u7
ii  libc6                            2.24-11+deb9u4
ii  libcups2                         2.2.1-8+deb9u4
ii  libcupsfilters1                  1.11.6-3+deb9u1
ii  libcupsimage2                    2.2.1-8+deb9u4
ii  libfontconfig1                   1:2.13.0-5
ii  libfontembed1                    1.11.6-3+deb9u1
ii  libgcc1                          1:6.3.0-18+deb9u1
ii  libijs-0.35                      0.35-12
ii  libpoppler64                     0.48.0-2+deb9u2
ii  libqpdf17                        6.0.0-2
ii  libstdc++6                       6.3.0-18+deb9u1
ii  poppler-utils                    0.48.0-2+deb9u2

Versions of packages cups-filters recommends:
ii  liblouisutdml-bin  2.6.0-3+b2

Versions of packages cups-filters suggests:
pn  antiword                                   <none>
pn  docx2txt                                   <none>
ii  foomatic-db-compressed-ppds [foomatic-db]  20161201-1

-- no debconf information


Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

Reply sent to Mark Hindley <mark@hindley.org.uk>:
You have taken responsibility. (Wed, 19 Feb 2020 10:33:01 GMT) (full text, mbox, link).


Notification sent to PICCORO McKAY Lenz <mckaygerhard@gmail.com>:
bug acknowledged by developer. (Wed, 19 Feb 2020 10:33:04 GMT) (full text, mbox, link).


Message #10 received at 397-done@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 397-done@bugs.devuan.org
Subject: Re: cups-filters: Cups filters has hard depends on imagemagick makes unnistallable
Date: Wed, 19 Feb 2020 10:09:42 +0000
Piccoro,

This is a Debian bug. See https://bugs.debian.org/844049 which has been open and
unfixed since 2016. As it involves unforked packages that Devuan uses directly
from Debian, I suggest you add your voice to teh Debian BTS to get it fixed.


On Tue, Feb 18, 2020 at 11:10:02AM -0430, PICCORO McKAY Lenz wrote:
> -- System Information:
> Distributor ID: Debian
> Description: Debian GNU/Linux 9.10 (strecht)
> Release: 9.10
> Codename: strecht

In addition, this doesn't appear to be a Devuan system at all, so closing.

Mark

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue Aug 4 14:09:45 2020;