Devuan bug report logs - #422
libreoffice: Does not start, Signal 11

Package: minimal-live; Maintainer for minimal-live is fsmithred <fsmithred@gmail.com>;

Reported by: Mike <mike9@posteo.nl>

Date: Sat, 11 Apr 2020 14:03:02 UTC

Severity: grave

Tags: debian

Done: fsmithred <fsmithred@gmail.com>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#422; Package libreoffice. (Sat, 11 Apr 2020 14:03:02 GMT) (full text, mbox, link).


Acknowledgement sent to Mike <mike9@posteo.nl>:
New bug report received and forwarded. Copy sent to devuan-dev@lists.dyne.org. (Sat, 11 Apr 2020 14:03:04 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Mike <mike9@posteo.nl>
To: submit@bugs.devuan.org
Subject: libreoffice: Does not start, Signal 11
Date: Sat, 11 Apr 2020 15:42:52 +0200
Package: libreoffice
Version: 1:6.1.5-3+deb10u5
Severity: grave
Justification: renders package unusable

I'm using
2020-03-10 16:22 devuan_beowulf_3.0.0_beta_amd64_desktop-live.iso
from a USB stick.

Calling libreoffice from the applications menu or at the shell prompt
does not start it. Calling it from the shell prompt leads to:

devuan@devuan:~$ libreoffice


Fatal exception: Signal 11
Stack:
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3d523)[0x7fa34c134523]
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3d733)[0x7fa34c134733]
/lib/x86_64-linux-gnu/libc.so.6(+0x37840)[0x7fa34bf59840]
/usr/lib/libreoffice/program/libuno_cppu.so.3(+0x14b32)[0x7fa34936db32]
/usr/lib/libreoffice/program/libuno_cppu.so.3(uno_type_any_assign+0x97)[0x7fa34936cf27]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2aac888)[0x7fa34ec01888]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2aad565)[0x7fa34ec02565]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x7b)[0x7fa34ebf77db]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2b02028)[0x7fa34ec57028]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x11f)[0x7fa34ec5851f]
/usr/lib/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x1a0)[0x7fa34efac4f0]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2e58a8d)[0x7fa34efada8d]
/usr/lib/libreoffice/program/libmergedlo.so(_Z6SVMainv+0x30)[0x7fa34efadae0]
/usr/lib/libreoffice/program/libmergedlo.so(soffice_main+0x91)[0x7fa34e07fde1]
/usr/lib/libreoffice/program/soffice.bin(+0x107b)[0x558b610ac07b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xeb)[0x7fa34bf4609b]
/usr/lib/libreoffice/program/soffice.bin(+0x10ba)[0x558b610ac0ba]


-- System Information:
Distributor ID:	Debian
Description:	Devuan GNU/Linux 3 (beowulf)
Release:	3
Codename:	beowulf
Architecture: x86_64

Kernel: Linux 4.19.0-8-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages libreoffice depends on:
ii  libreoffice-avmedia-backend-gstreamer  1:6.1.5-3+deb10u5
ii  libreoffice-base                       1:6.1.5-3+deb10u5
ii  libreoffice-calc                       1:6.1.5-3+deb10u5
ii  libreoffice-core                       1:6.1.5-3+deb10u5
ii  libreoffice-draw                       1:6.1.5-3+deb10u5
ii  libreoffice-impress                    1:6.1.5-3+deb10u5
ii  libreoffice-math                       1:6.1.5-3+deb10u5
ii  libreoffice-report-builder-bin         1:6.1.5-3+deb10u5
ii  libreoffice-writer                     1:6.1.5-3+deb10u5
ii  python3-uno                            1:6.1.5-3+deb10u5

Versions of packages libreoffice recommends:
ii  fonts-crosextra-caladea             20130214-2
ii  fonts-crosextra-carlito             20130920-1
ii  fonts-dejavu                        2.37-1
ii  fonts-liberation                    1:1.07.4-9
ii  fonts-liberation2                   2.00.5-1
ii  fonts-linuxlibertine                5.3.0-4
ii  fonts-noto-core                     20181227-1
ii  fonts-noto-mono                     20181227-1
ii  fonts-noto-ui-core                  20181227-1
ii  fonts-sil-gentium-basic             1.102-1
ii  libreoffice-java-common             1:6.1.5-3+deb10u5
ii  libreoffice-librelogo               1:6.1.5-3+deb10u5
ii  libreoffice-nlpsolver               0.9+LibO6.1.5-3+deb10u5
ii  libreoffice-report-builder          1:6.1.5-3+deb10u5
ii  libreoffice-script-provider-bsh     1:6.1.5-3+deb10u5
ii  libreoffice-script-provider-js      1:6.1.5-3+deb10u5
ii  libreoffice-script-provider-python  1:6.1.5-3+deb10u5
ii  libreoffice-sdbc-postgresql         1:6.1.5-3+deb10u5
ii  libreoffice-wiki-publisher          1.2.0+LibO6.1.5-3+deb10u5

Versions of packages libreoffice suggests:
pn  cups-bsd                                    <none>
ii  default-jre [java6-runtime]                 2:1.11-71
ii  firefox-esr                                 68.5.0esr-1~deb10u1
ii  ghostscript                                 9.27~dfsg-2+deb10u3
ii  gnupg                                       2.2.12-1+deb10u1
pn  gpa                                         <none>
ii  gstreamer1.0-libav                          1.15.0.1+git20180723+db823502-2
ii  gstreamer1.0-plugins-bad                    1.14.4-1+b1
ii  gstreamer1.0-plugins-base                   1.14.4-2
ii  gstreamer1.0-plugins-good                   1.14.4-1
ii  gstreamer1.0-plugins-ugly                   1.14.4-1
ii  hunspell-en-us [hunspell-dictionary]        1:2018.04.16-1
ii  hyphen-en-us [hyphen-hyphenation-patterns]  2.8.8-7
pn  imagemagick | graphicsmagick-imagemagick-c  <none>
ii  libgl1                                      1.1.0-1
pn  libreoffice-gnome | libreoffice-kde5        <none>
pn  libreoffice-grammarcheck                    <none>
ii  libreoffice-help-en-us [libreoffice-help]   1:6.1.5-3+deb10u5
pn  libreoffice-l10n                            <none>
pn  libreoffice-officebean                      <none>
ii  libsane                                     1.0.27-3.2
ii  libxrender1                                 1:0.9.10-1
pn  myspell-dictionary                          <none>
ii  mythes-en-us [mythes-thesaurus]             1:6.2.0-1
pn  openclipart2-libreoffice | openclipart-lib  <none>
ii  openjdk-11-jre [java6-runtime]              11.0.6+10-1~deb10u1
pn  pstoedit                                    <none>
pn  unixodbc                                    <none>

Versions of packages libreoffice-core depends on:
ii  fontconfig                2.13.1-2
ii  fonts-opensymbol          2:102.10+LibO6.1.5-3+deb10u5
ii  libboost-date-time1.67.0  1.67.0-13+deb10u1
ii  libboost-locale1.67.0     1.67.0-13+deb10u1
ii  libc6                     2.28-10
ii  libcairo2                 1.16.0-4
ii  libclucene-contribs1v5    2.3.3.4+dfsg-1
ii  libclucene-core1v5        2.3.3.4+dfsg-1
ii  libcmis-0.5-5v5           0.5.2-1
ii  libcups2                  2.2.10-6+deb10u2
ii  libcurl3-gnutls           7.64.0-4+deb10u1
ii  libdbus-1-3               1.12.16-1+devuan2
ii  libdbus-glib-1-2          0.110-4
ii  libdconf1                 0.30.1-2
ii  libeot0                   0.01-5
ii  libepoxy0                 1.5.3-0.1
ii  libexpat1                 2.2.6-2+deb10u1
ii  libexttextcat-2.0-0       3.4.5-1
ii  libfontconfig1            2.13.1-2
ii  libfreetype6              2.9.1-3+deb10u1
ii  libgcc1                   1:8.3.0-6
ii  libglib2.0-0              2.58.3-2+deb10u2
ii  libgpgmepp6               1.12.0-6
ii  libgraphite2-3            1.3.13-7
ii  libharfbuzz-icu0          2.3.1-1
ii  libharfbuzz0b             2.3.1-1
ii  libhunspell-1.7-0         1.7.0-2
ii  libhyphen0                2.8.8-7
ii  libice6                   2:1.0.9-2
ii  libicu63                  63.1-6
ii  libjpeg62-turbo           1:1.5.2-2+b1
ii  liblcms2-2                2.9-3
ii  libldap-2.4-2             2.4.47+dfsg-3+deb10u1
ii  libmythes-1.2-0           2:1.2.4-3
ii  libneon27-gnutls          0.30.2-3
ii  libnspr4                  2:4.20-1
ii  libnss3                   2:3.42.1-1+deb10u2
ii  libnumbertext-1.0-0       1.0.5-1
ii  libodfgen-0.1-1           0.1.7-1
ii  liborcus-0.14-0           0.14.1-6
ii  libpng16-16               1.6.36-6
ii  libpoppler82              0.71.0-5
ii  librdf0                   1.0.17-1.1+b1
ii  libreoffice-common        1:6.1.5-3+deb10u5
ii  librevenge-0.0-0          0.0.4-6
ii  libsm6                    2:1.2.3-1
ii  libstdc++6                8.3.0-6
ii  libx11-6                  2:1.6.7-1
ii  libxext6                  2:1.3.3-1+b2
ii  libxinerama1              2:1.1.4-2
ii  libxml2                   2.9.4+dfsg1-7+b3
ii  libxmlsec1                1.2.27-2
ii  libxmlsec1-nss            1.2.27-2
ii  libxrandr2                2:1.5.1-1
ii  libxrender1               1:0.9.10-1
ii  libxslt1.1                1.1.32-2.2~deb10u1
ii  uno-libs3                 6.1.5-3+deb10u5
ii  ure                       6.1.5-3+deb10u5
ii  zlib1g                    1:1.2.11.dfsg-1

Versions of packages libreoffice-core recommends:
ii  libpaper-utils  1.1.28

Versions of packages libreoffice-writer depends on:
ii  libabw-0.1-1           0.1.2-1
ii  libc6                  2.28-10
ii  libe-book-0.1-1        0.1.3-1+b2
ii  libepubgen-0.1-1       0.1.1-1
ii  libetonyek-0.1-1       0.1.9-1
ii  libgcc1                1:8.3.0-6
ii  libicu63               63.1-6
ii  liblangtag1            0.6.2-1
ii  libmwaw-0.3-3          0.3.14-1
ii  libodfgen-0.1-1        0.1.7-1
ii  libreoffice-base-core  1:6.1.5-3+deb10u5
ii  libreoffice-core       1:6.1.5-3+deb10u5
ii  librevenge-0.0-0       0.0.4-6
ii  libstaroffice-0.0-0    0.0.6-1
ii  libstdc++6             8.3.0-6
ii  libwpd-0.10-10         0.10.3-1
ii  libwpg-0.3-3           0.3.3-1
ii  libwps-0.4-4           0.4.10-1
ii  libxml2                2.9.4+dfsg1-7+b3
ii  uno-libs3              6.1.5-3+deb10u5
ii  ure                    6.1.5-3+deb10u5
ii  zlib1g                 1:1.2.11.dfsg-1

Versions of packages libreoffice-writer recommends:
ii  libreoffice-math  1:6.1.5-3+deb10u5

Versions of packages libreoffice-writer suggests:
ii  default-jre [java6-runtime]     2:1.11-71
ii  fonts-crosextra-caladea         20130214-2
ii  fonts-crosextra-carlito         20130920-1
ii  libreoffice-base                1:6.1.5-3+deb10u5
ii  libreoffice-java-common         1:6.1.5-3+deb10u5
ii  openjdk-11-jre [java6-runtime]  11.0.6+10-1~deb10u1

Versions of packages libreoffice-calc depends on:
ii  coinor-libcbc3               2.9.9+repack1-1
ii  coinor-libcoinmp1v5          1.8.3-2+b11
ii  coinor-libcoinutils3v5       2.10.14+repack1-1
ii  libblas3 [libblas.so.3]      3.8.0-2
ii  libboost-filesystem1.67.0    1.67.0-13+deb10u1
ii  libboost-iostreams1.67.0     1.67.0-13+deb10u1
ii  libbz2-1.0                   1.0.6-9.2~deb10u1
ii  libc6                        2.28-10
ii  libetonyek-0.1-1             0.1.9-1
ii  libgcc1                      1:8.3.0-6
ii  libicu63                     63.1-6
ii  liblapack3 [liblapack.so.3]  3.8.0-2
ii  liblcms2-2                   2.9-3
ii  libmwaw-0.3-3                0.3.14-1
ii  libodfgen-0.1-1              0.1.7-1
ii  liborcus-0.14-0              0.14.1-6
ii  libreoffice-base-core        1:6.1.5-3+deb10u5
ii  libreoffice-core             1:6.1.5-3+deb10u5
ii  librevenge-0.0-0             0.0.4-6
ii  libstaroffice-0.0-0          0.0.6-1
ii  libstdc++6                   8.3.0-6
ii  libwps-0.4-4                 0.4.10-1
ii  libxml2                      2.9.4+dfsg1-7+b3
ii  lp-solve                     5.5.0.15-4+b1
ii  uno-libs3                    6.1.5-3+deb10u5
ii  ure                          6.1.5-3+deb10u5
ii  zlib1g                       1:1.2.11.dfsg-1

Versions of packages libreoffice-calc suggests:
pn  ocl-icd-libopencl1 | mesa-opencl-icd | beignet-opencl-icd  <none>

Versions of packages libreoffice-base depends on:
ii  libc6                     2.28-10
ii  libgcc1                   1:8.3.0-6
ii  libreoffice-base-core     1:6.1.5-3+deb10u5
ii  libreoffice-base-drivers  1:6.1.5-3+deb10u5
ii  libreoffice-core          1:6.1.5-3+deb10u5
ii  libstdc++6                8.3.0-6
ii  uno-libs3                 6.1.5-3+deb10u5
ii  ure                       6.1.5-3+deb10u5

Versions of packages libreoffice-base recommends:
ii  default-jre [java6-runtime]     2:1.11-71
ii  libreoffice-java-common         1:6.1.5-3+deb10u5
ii  libreoffice-writer              1:6.1.5-3+deb10u5
ii  openjdk-11-jre [java6-runtime]  11.0.6+10-1~deb10u1

Versions of packages libreoffice-base suggests:
ii  libreoffice-report-builder  1:6.1.5-3+deb10u5
pn  unixodbc                    <none>

Versions of packages libreoffice-draw depends on:
ii  libavahi-client3     0.7-4+b1
ii  libavahi-common3     0.7-4+b1
ii  libc6                2.28-10
ii  libcdr-0.1-1         0.1.5-1
ii  libdbus-1-3          1.12.16-1+devuan2
ii  libdbus-glib-1-2     0.110-4
ii  libfreehand-0.1-1    0.1.2-2
ii  libgcc1              1:8.3.0-6
ii  libglib2.0-0         2.58.3-2+deb10u2
ii  libicu63             63.1-6
ii  liblcms2-2           2.9-3
ii  libmspub-0.1-1       0.1.4-1+b2
ii  libmwaw-0.3-3        0.3.14-1
ii  libodfgen-0.1-1      0.1.7-1
ii  libpagemaker-0.0-0   0.0.4-1
ii  libpng16-16          1.6.36-6
ii  libqxp-0.0-0         0.0.2-1
ii  libreoffice-core     1:6.1.5-3+deb10u5
ii  librevenge-0.0-0     0.0.4-6
ii  libstaroffice-0.0-0  0.0.6-1
ii  libstdc++6           8.3.0-6
ii  libvisio-0.1-1       0.1.6-1+b2
ii  libwpd-0.10-10       0.10.3-1
ii  libwpg-0.3-3         0.3.3-1
ii  libxml2              2.9.4+dfsg1-7+b3
ii  libzmf-0.0-0         0.0.2-1+b2
ii  uno-libs3            6.1.5-3+deb10u5
ii  ure                  6.1.5-3+deb10u5
ii  zlib1g               1:1.2.11.dfsg-1

Versions of packages libreoffice-impress depends on:
ii  libc6                2.28-10
ii  libepoxy0            1.5.3-0.1
ii  libetonyek-0.1-1     0.1.9-1
ii  libgcc1              1:8.3.0-6
ii  libmwaw-0.3-3        0.3.14-1
ii  libodfgen-0.1-1      0.1.7-1
ii  libreoffice-core     1:6.1.5-3+deb10u5
ii  libreoffice-draw     1:6.1.5-3+deb10u5
ii  librevenge-0.0-0     0.0.4-6
ii  libstaroffice-0.0-0  0.0.6-1
ii  libstdc++6           8.3.0-6
ii  libxml2              2.9.4+dfsg1-7+b3
ii  uno-libs3            6.1.5-3+deb10u5
ii  ure                  6.1.5-3+deb10u5
ii  zlib1g               1:1.2.11.dfsg-1

Versions of packages libreoffice-impress recommends:
ii  libreoffice-avmedia-backend-gstreamer  1:6.1.5-3+deb10u5

Versions of packages libreoffice-impress suggests:
ii  bluez  5.50-1

Versions of packages libreoffice-math depends on:
ii  fonts-opensymbol  2:102.10+LibO6.1.5-3+deb10u5
ii  libc6             2.28-10
ii  libgcc1           1:8.3.0-6
ii  libreoffice-core  1:6.1.5-3+deb10u5
ii  libstdc++6        8.3.0-6
ii  uno-libs3         6.1.5-3+deb10u5
ii  ure               6.1.5-3+deb10u5

-- no debconf information

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#422; Package libreoffice. (Sun, 12 Apr 2020 09:48:01 GMT) (full text, mbox, link).


Message #8 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: Mike <mike9@posteo.nl>, 422@bugs.devuan.org
Cc: fsmithred@gmail.com
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Sun, 12 Apr 2020 10:36:25 +0100
Control: tags -1 debian

Mike,

Thanks for this.

On Sat, Apr 11, 2020 at 03:42:52PM +0200, Mike wrote:
> Package: libreoffice
> Version: 1:6.1.5-3+deb10u5
> Severity: grave
> Justification: renders package unusable
> 
> I'm using
> 2020-03-10 16:22 devuan_beowulf_3.0.0_beta_amd64_desktop-live.iso
> from a USB stick.
> 
> Calling libreoffice from the applications menu or at the shell prompt
> does not start it. Calling it from the shell prompt leads to:

Devuan uses Debian's packages of libreoffice directly. So, unless this is
related to the desktop-live iso (and I see no particular evidence it is;
fsmithred, do you agree?), you would be better reporting this directly to
Debian's BTS.

A quick search reveals various similar reports, in particular
https://bugs.documentfoundation.org/show_bug.cgi?id=122116 which is only fixed
upstream in 6.2.0.2.

Possible workarounds might be to mv .config/libreoffice out of the way try
running from the commandline with the --norestore option.

Hope that helps.

Mark

Added tag(s) debian. Request was from Mark Hindley <mark@hindley.org.uk> to 422-submit@bugs.devuan.org. (Sun, 12 Apr 2020 09:48:04 GMT) (full text, mbox, link).


Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#422; Package libreoffice. (Sun, 12 Apr 2020 16:48:02 GMT) (full text, mbox, link).


Acknowledgement sent to Mike <mike9@posteo.nl>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Sun, 12 Apr 2020 16:48:04 GMT) (full text, mbox, link).


Message #15 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mike <mike9@posteo.nl>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 422@bugs.devuan.org
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Sun, 12 Apr 2020 18:32:57 +0200
Mark,

on 12.04. you wrote:

> Devuan uses Debian's packages of libreoffice directly. So, unless this is
> related to the desktop-live iso (and I see no particular evidence it is;
> fsmithred, do you agree?), you would be better reporting this directly to
> Debian's BTS.
> 
> A quick search reveals various similar reports, in particular
> https://bugs.documentfoundation.org/show_bug.cgi?id=122116 which is only fixed
> upstream in 6.2.0.2.

libreoffice 6.1.5-3+deb10u5 in debian-live-10.3.0-amd64-xfce.iso
runs smoothly. So why should I report a bug with Debian's BTS? I
cannot report "your package is broken when using with Devuan",
can I?

> Possible workarounds might be to mv .config/libreoffice out of the way

.config/libreoffice doesn't exist in a fresh live.iso so can't be
removed/mv'd prior to the first run.

> try
> running from the commandline with the --norestore option.

Has no effect.

Can the issue be related to an other package instead of libreoffice?

Mike

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#422; Package libreoffice. (Sun, 12 Apr 2020 18:33:01 GMT) (full text, mbox, link).


Message #18 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 422@bugs.devuan.org
Cc: mike9@posteo.nl, fsmithred@gmail.com
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Sun, 12 Apr 2020 19:21:46 +0100
On Sun, Apr 12, 2020 at 06:32:57PM +0200, Mike wrote:
> libreoffice 6.1.5-3+deb10u5 in debian-live-10.3.0-amd64-xfce.iso
> runs smoothly. So why should I report a bug with Debian's BTS? I
> cannot report "your package is broken when using with Devuan",
> can I?

Well, you didn't include that information in your original report!

> Can the issue be related to an other package instead of libreoffice?

Yes, possibly. I suspect something is missing in the live session.

Could you install strace and gdb and post the output of `strace libreoffice` and also
the backtrace from `gdb libreoffice'?

Thanks

Mark

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#422; Package libreoffice. (Sun, 12 Apr 2020 20:03:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mike <mike9@posteo.nl>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. (Sun, 12 Apr 2020 20:03:05 GMT) (full text, mbox, link).


Message #23 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mike <mike9@posteo.nl>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 422@bugs.devuan.org, fsmithred@gmail.com
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Sun, 12 Apr 2020 21:51:01 +0200
[Message part 1 (text/plain, inline)]
On 12.04. Mark wrote:

> Could you install strace and gdb and post the output of `strace libreoffice` and also
> the backtrace from `gdb libreoffice'?

Find attached.

Mike
[libreoffice.trace (text/plain, attachment)]
[gdbtrace.log (text/plain, attachment)]

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#422; Package libreoffice. (Mon, 13 Apr 2020 14:33:02 GMT) (full text, mbox, link).


Message #26 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 422@bugs.devuan.org, fsmithred@gmail.com
Cc: mike9@posteo.nl
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Mon, 13 Apr 2020 15:25:18 +0100
Control: reassign -1 minimal-live

On Sun, Apr 12, 2020 at 09:51:01PM +0200, Mike wrote:
> On 12.04. Mark wrote:
> 
> > Could you install strace and gdb and post the output of `strace libreoffice` and also
> > the backtrace from `gdb libreoffice'?
> 
> Find attached.

Thanks

> socket(AF_UNIX, SOCK_STREAM, 0)         = 3
> fcntl(3, F_SETFD, FD_CLOEXEC)           = 0
> connect(3, {sa_family=AF_UNIX, sun_path="/tmp/OSL_PIPE_1000_SingleOfficeIPC_a9d9dadd6d74b14dd9a2338f7484560"}, 110) = -1 ECONNREFUSED (Connection refused)

This line is suspicious to me.

I have managed to fix it in a VM by disabling apparmor profiles: `sudo
aa-teardown' should do it.

Can you verify that then allows libreoffice to start normally?

Thanks.

Mark

bug reassigned from package 'libreoffice' to 'minimal-live'. Request was from Mark Hindley <mark@hindley.org.uk> to 422-submit@bugs.devuan.org. (Mon, 13 Apr 2020 14:33:04 GMT) (full text, mbox, link).


No longer marked as found in versions 1:6.1.5-3+deb10u5. Request was from Mark Hindley <mark@hindley.org.uk> to 422-submit@bugs.devuan.org. (Mon, 13 Apr 2020 14:33:04 GMT) (full text, mbox, link).


Information forwarded to devuan-bugs@lists.dyne.org, fsmithred <fsmithred@gmail.com>:
bug#422; Package minimal-live. (Mon, 13 Apr 2020 15:33:01 GMT) (full text, mbox, link).


Message #33 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: 422@bugs.devuan.org, fsmithred@gmail.com
Cc: mike9@posteo.nl
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Mon, 13 Apr 2020 16:13:25 +0100
Just to finish documenting the story.

This is Debian bug #922378. It is fixed in apparmor version 2.13.2-10, but only
in the systemd service file.

We will need an alternative workaround. Passing apparmor=0 on the kernel command
line for the live iso or removing it completely.

Mark

Information forwarded to devuan-bugs@lists.dyne.org, fsmithred <fsmithred@gmail.com>:
bug#422; Package minimal-live. (Mon, 13 Apr 2020 16:18:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mike <mike9@posteo.nl>:
Extra info received and forwarded to list. Copy sent to fsmithred <fsmithred@gmail.com>. (Mon, 13 Apr 2020 16:18:04 GMT) (full text, mbox, link).


Message #38 received at 422@bugs.devuan.org (full text, mbox, reply):

From: Mike <mike9@posteo.nl>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 422@bugs.devuan.org, fsmithred@gmail.com
Subject: Re: [devuan-dev] bug#422: libreoffice: Does not start, Signal 11
Date: Mon, 13 Apr 2020 18:02:16 +0200
On 13.04. Mark wrote:
> I have managed to fix it in a VM by disabling apparmor profiles: `sudo
> aa-teardown' should do it.
> 
> Can you verify that then allows libreoffice to start normally?

Yes, it does.

| We will need an alternative workaround. Passing apparmor=0 on the kernel command

Also works.

> Thanks.

Thank you.

Mike

Reply sent to fsmithred <fsmithred@gmail.com>:
You have taken responsibility. (Sun, 03 May 2020 10:18:01 GMT) (full text, mbox, link).


Notification sent to Mike <mike9@posteo.nl>:
bug acknowledged by developer. (Sun, 03 May 2020 10:18:05 GMT) (full text, mbox, link).


Message #43 received at 422-done@bugs.devuan.org (full text, mbox, reply):

From: fsmithred <fsmithred@gmail.com>
To: 422-done@bugs.devuan.org
Subject: libreoffice: Does not start, Signal 11
Date: Sun, 3 May 2020 05:57:27 -0400
close

Fixed in beta2 desktop-live by adding apparmor=0 to boot command.

fsmithred

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Wed Oct 21 21:36:49 2020;