Devuan bug report logs - #542
wicd-gtk: Package can't be installed because of missing deps

Package: wicd-gtk; Maintainer for wicd-gtk is Vincenzo (KatolaZ) Nicosia <katolaz@freaknet.org>;

Reported by: Nico Orru <nigu.orru@gmail.com>

Date: Tue, 2 Feb 2021 21:33:02 UTC

Severity: grave

Done: Mark Hindley <mark@hindley.org.uk>

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, Vincenzo (KatolaZ) Nicosia <katolaz@freaknet.org>:
bug#542; Package wicd-gtk. (Tue, 02 Feb 2021 21:33:02 GMT) (full text, mbox, link).


Acknowledgement sent to Nico Orru <nigu.orru@gmail.com>:
New bug report received and forwarded. Copy sent to Vincenzo (KatolaZ) Nicosia <katolaz@freaknet.org>.

Your message had a Version: pseudo-header with an invalid package version:

wicd-gtk_1.7.4+tb2-6+devuan1.1_all.deb

please either use found or fixed to the control server with a correct version, or reply to this report indicating the correct version so the maintainer (or someone else) can correct it for you.

(Tue, 02 Feb 2021 21:33:06 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Nico Orru <nigu.orru@gmail.com>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: wicd-gtk: Package can't be installed because of missing deps
Date: Tue, 02 Feb 2021 21:22:22 +0000
Package: wicd-gtk
Version: wicd-gtk_1.7.4+tb2-6+devuan1.1_all.deb
Severity: grave
Tags: d-i
Justification: renders package unusable

Dear Maintainer,

- On Devuan Ceres
- after apt-get dist-upgrade

- Network applet disappear
- No network at boot
- No app to configure network
- wicd-gtk is now missing

Attempting to reinstall the app produces the following

nico@lenovo-devuan:~$ sudo apt install wicd-gtk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wicd-gtk : Depends: python-glade2 but it is not installable
            Depends: python-gtk2 but it is not installable
            Recommends: python-notify but it is not installable
E: Unable to correct problems, you have held broken packages.

Dependencies are not available in repository

nico@lenovo-devuan:~$ apt-cache show python-glade2
N: Can't select versions from package 'python-glade2' as it is purely virtual
N: No packages found
nico@lenovo-devuan:~$ sudo apt-get install python-glade2
[sudo] password for nico: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-glade2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-glade2' has no installation candidate




wicd-gtk_1.7.4+tb2-6+devuan1.1_all.deb

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 4 (chimaera/ceres)
Release:	testing/unstable
Codename:	n/a
Architecture: x86_64

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU threads)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=ANSI_X3.4-1968) (ignored: LC_ALL set to C), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages wicd-gtk depends on:
pn  python-glade2               <none>
pn  python-gtk2                 <none>
ii  python-is-python2 [python]  2.7.18-8
ii  wicd-daemon                 1.7.4+tb2-6+devuan1.1

Versions of packages wicd-gtk recommends:
ii  policykit-1    0.105-29+devuan1
pn  python-notify  <none>

wicd-gtk suggests no packages.

Reply sent to Mark Hindley <mark@hindley.org.uk>:
You have taken responsibility. (Fri, 05 Feb 2021 14:33:02 GMT) (full text, mbox, link).


Notification sent to Nico Orru <nigu.orru@gmail.com>:
bug acknowledged by developer. (Fri, 05 Feb 2021 14:33:05 GMT) (full text, mbox, link).


Message #10 received at 542-done@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: Nico Orru <nigu.orru@gmail.com>, 542-done@bugs.devuan.org
Subject: Re: wicd-gtk: Package can't be installed because of missing deps
Date: Fri, 5 Feb 2021 14:18:35 +0000
Nico,

Thanks for this.

On Tue, Feb 02, 2021 at 09:22:22PM +0000, Nico Orru wrote:
> Package: wicd-gtk
> Version: wicd-gtk_1.7.4+tb2-6+devuan1.1_all.deb
> Severity: grave
> Tags: d-i
> Justification: renders package unusable
> 
> Dear Maintainer,
> 
> - On Devuan Ceres

As you have discovered, wicd has not been updated to python3 and is therefore
not available in chimaera or ceres. It has already been removed from chimaera. I
will remove it from ceres to fix this bug.

> - after apt-get dist-upgrade
> 
> - Network applet disappear
> - No network at boot
> - No app to configure network

You will need to use a different application: network-manager or conman are
options.

HTH.

Mark

Message #11 received at 542-done@bugs.devuan.org (full text, mbox, reply):

From: Nicola OrrĂ¹ <nigu.orru@gmail.com>
To: Mark Hindley <mark@hindley.org.uk>
Cc: 542-done@bugs.devuan.org
Subject: Re: wicd-gtk: Package can't be installed because of missing deps
Date: Fri, 5 Feb 2021 17:34:15 +0000
Alright, thanks for the tips. I will try the replacements then (in
older versions of Ceres, I couldn't get network-manager to work)

Cheers,
Nico

On Fri, 5 Feb 2021 at 14:18, Mark Hindley <mark@hindley.org.uk> wrote:
>
> Nico,
>
> Thanks for this.
>
> On Tue, Feb 02, 2021 at 09:22:22PM +0000, Nico Orru wrote:
> > Package: wicd-gtk
> > Version: wicd-gtk_1.7.4+tb2-6+devuan1.1_all.deb
> > Severity: grave
> > Tags: d-i
> > Justification: renders package unusable
> >
> > Dear Maintainer,
> >
> > - On Devuan Ceres
>
> As you have discovered, wicd has not been updated to python3 and is therefore
> not available in chimaera or ceres. It has already been removed from chimaera. I
> will remove it from ceres to fix this bug.
>
> > - after apt-get dist-upgrade
> >
> > - Network applet disappear
> > - No network at boot
> > - No app to configure network
>
> You will need to use a different application: network-manager or conman are
> options.
>
> HTH.
>
> Mark



-- 
Cheers,
Nico

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue Aug 9 10:09:58 2022;