Devuan bug report logs - #547
git: cloning a https repo gets stuck in an infinite loop

version graph

Package: git; Maintainer for git is (unknown);

Reported by: Kalle Sandström <ksandstr@lakka.kapsi.fi>

Date: Fri, 12 Feb 2021 20:33:01 UTC

Severity: normal

Tags: debian, moreinfo

Found in version 1:2.30.0-1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#547; Package git. (Fri, 12 Feb 2021 20:33:01 GMT) (full text, mbox, link).


Acknowledgement sent to Kalle Sandström <ksandstr@lakka.kapsi.fi>:
New bug report received and forwarded. Copy sent to devuan-dev@lists.dyne.org.

Your message specified a Severity: in the pseudo-header, but the severity value important was not recognised. The default severity normal is being used instead. The recognised values are: critical, grave, normal, minor, wishlist.

(Fri, 12 Feb 2021 20:33:07 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Kalle Sandström <ksandstr@lakka.kapsi.fi>
To: submit@bugs.devuan.org
Subject: git: cloning a https repo gets stuck in an infinite loop
Date: Fri, 12 Feb 2021 22:26:02 +0200
Package: git
Version: 1:2.30.0-1
Severity: important

Dear Maintainer,

Attempting

    git clone https://tildegit.org/solene/vger.git

... puts "git-remote-https" into a perpetual spin and never proceeds.

Cloning the repo on a different computer on the same network (amd64, running an
earlier version of git) works immediately.

Causing a coredump and reading the backtrace indicates that execution is stuck
in `_nettle_chacha_core' of libnettle.so.8, and upgrading the `libnettle8'
package to 3.7-2 does not solve the problem.

This problem has existed for more than a year now, i.e. from before the
pandemic.

Regards,
  -KS


-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 1.0.0 (jessie)
Release:	1.0.0
Codename:	jessie
Architecture: i686

Kernel: Linux 5.2.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=fi_FI.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages git depends on:
ii  git-man          1:2.30.0-1
ii  libc6            2.31-9
ii  libcurl3-gnutls  7.74.0-1
ii  liberror-perl    0.17-1.1
ii  libexpat1        2.2.10-1
ii  libpcre2-8-0     10.32-5+b1
ii  perl             5.30.3-4
ii  zlib1g           1:1.2.11.dfsg-2

Versions of packages git recommends:
ii  ca-certificates              20210119
ii  less                         481-2.1
ii  openssh-client [ssh-client]  1:8.4p1-3
ii  patch                        2.7.6-6

Versions of packages git suggests:
ii  gettext-base                          0.19.3-2
pn  git-cvs                               <none>
pn  git-daemon-run | git-daemon-sysvinit  <none>
ii  git-doc                               1:2.23.0-1
pn  git-el                                <none>
pn  git-email                             <none>
pn  git-gui                               <none>
pn  git-mediawiki                         <none>
pn  git-svn                               <none>
ii  gitk                                  1:2.30.0-1
pn  gitweb                                <none>

-- no debconf information

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#547; Package git. (Mon, 15 Feb 2021 20:18:01 GMT) (full text, mbox, link).


Message #8 received at 547@bugs.devuan.org (full text, mbox, reply):

From: Mark Hindley <mark@hindley.org.uk>
To: Kalle Sandström <ksandstr@lakka.kapsi.fi>, 547@bugs.devuan.org
Subject: Re: bug#547: git: cloning a https repo gets stuck in an infinite loop
Date: Mon, 15 Feb 2021 20:03:09 +0000
Control: tags -1 moreinfo debian

Kalle,

Thanks for this.

Firstly, git is not a forked package and Devuan uses Debian's packages directly
without recompilation. So in principle this issue should be reported to Debian's
BTS.

However, I cannot reproduce this behaviour and I am confused about your setup.

On Fri, Feb 12, 2021 at 10:26:02PM +0200, Kalle Sandström wrote:
> 
> Package: git
> Version: 1:2.30.0-1

This is the testing/unstable version, however

> -- System Information:
> Distributor ID:	Devuan
> Description:	Devuan GNU/Linux 1.0.0 (jessie)
> Release:	1.0.0
> Codename:	jessie
> Architecture: i686

this implies you are running Jessie.

Jessie has been end of life and archived since July 2020.

What suite are you running?

Can you ensure your system is fully up to date, and then try to reproduce the
issue?

Thanks

Mark

Added tag(s) debian and moreinfo. Request was from Mark Hindley <mark@hindley.org.uk> to 547-submit@bugs.devuan.org. (Mon, 15 Feb 2021 20:18:08 GMT) (full text, mbox, link).


Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Mon Sep 20 19:31:03 2021;