Devuan bug report logs - #551
GRUB config not loaded because of hardcoded debian reference in GRUB EFI binary

version graph

Package: grub-efi-amd64-bin; Maintainer for grub-efi-amd64-bin is (unknown);

Reported by: Benjamin Boudoir <benjamin@boudoir.name>

Date: Thu, 18 Feb 2021 10:33:02 UTC

Severity: normal

Found in version 2.02+dfsg1-20+deb10u3

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#551; Package grub-efi-amd64-bin. (Thu, 18 Feb 2021 10:33:02 GMT) (full text, mbox, link).


Acknowledgement sent to Benjamin Boudoir <benjamin@boudoir.name>:
New bug report received and forwarded. Copy sent to devuan-dev@lists.dyne.org. (Thu, 18 Feb 2021 10:33:11 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Benjamin Boudoir <benjamin@boudoir.name>
To: submit@bugs.devuan.org
Subject: GRUB config not loaded because of hardcoded debian reference in GRUB EFI binary
Date: Thu, 18 Feb 2021 11:13:36 +0100
Package: grub-efi-amd64-bin
Version: 2.02+dfsg1-20+deb10u3

Hi,

I had to switch to GRUB EFI and after reboot, I was prompted with a GRUB 
shell.

It seems to be because grub-install install the grub.cfg in EFI/devuan 
while the grub binary explicitly search in EFI/debian :
# strings /boot/efi/EFI/devuan/grubx64.efi |grep EFI/
/EFI/debian

Copying the grub.cfg in EFI/debian/ fixed the issue, so maybe we should 
recompile the GRUB binary with devuan paths ?

Regards,

-- 
Benjamin Boudoir

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sat Sep 18 13:52:14 2021;