Subject: bug#642: jwm: Wrong fonts in jwm_2.4.1 after upgrade.

From: amc252 <[email-masked]>
Date: Sun, 5 Dec 2021 09:54:08 -0800

Package: jwm
Version: 2.4.1
Severity: minor
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   After upgrading from Chimaera to Daedalus, jwm_2.4.1 ceased to display the right fonts.
   I tried several configuratins in .jwmrc to no effect. 
   Downgrading to jwm_2.3.7-5 solved the issue.

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 5 (daedalus/ceres)
Release:	5
Codename:	daedalus ceres
Architecture: x86_64

Kernel: Linux 5.15.0-2-amd64 (SMP w/4 CPU threads)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: OpenRC (via /run/openrc), PID 1: init
LSM: AppArmor: enabled

Versions of packages jwm depends on:
ii  libc6                         2.32-4
ii  libcairo2                     1.16.0-5
ii  libfribidi0                   1.0.8-2
ii  libglib2.0-0                  2.70.1-1
ii  libjpeg62-turbo               1:2.1.2-1
ii  libpng16-16                   1.6.37-3
ii  librsvg2-2                    2.50.7+dfsg-2
ii  libx11-6                      2:1.7.2-2+b1
ii  libxext6                      2:1.3.4-1
ii  libxft2                       2.3.2-2
ii  libxinerama1                  2:1.1.4-2
ii  libxmu6                       2:1.1.2-2+b3
ii  libxpm4                       1:3.5.12-1
ii  libxrender1                   1:0.9.10-1
ii  sakura [x-terminal-emulator]  3.8.4-1

---

From: Mark Hindley <[email-masked]>
Date: Mon, 6 Dec 2021 08:04:59 +0000

Control: tags -1 debian

Hi,

>    Downgrading to jwm_2.3.7-5 solved the issue.

Thanks for this. However, jwm is not a forked package in Devuan and we use
Debian's packages directly without recompilation. Please report this directly to
Debian's BTS. Also, please check the version numbers, 2.4.1 doesn't appear to be
a current version. Did you mean 2.4.0-1?

Mark

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Wed, 11 Jan 2023 10:56:06 +0000

This is an automatic notification regarding your bug report
which was filed against the jwm package:

#642: jwm: Wrong fonts in jwm_2.4.1 after upgrade.

It has been closed by Mark Hindley <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mark Hindley <[email-masked]> by
replying to this email.

-- 
642: https://bugs.devuan.org/cgi/bugreport.cgi?bug=642
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: Fixed in Debian #1001272
From: Mark Hindley <[email-masked]>
To: [email-masked]
Date: Wed, 11 Jan 2023 10:54:56 +0000

Version: 2.4.0-2

Subject: jwm: Wrong fonts in jwm_2.4.1 after upgrade.
From: amc252 <[email-masked]>
To: [email-masked]
Date: Sun, 5 Dec 2021 09:54:08 -0800

Package: jwm
Version: 2.4.1
Severity: minor

Dear Maintainer,

-- System Information:
Distributor ID:	Devuan