Devuan bug report logs - #652
devuan-installer: Keyboard layout not configured on console

Package: devuan-installer; Maintainer for devuan-installer is Ralph Ronnquist <ralph.ronnquist@gmail.com>;

Reported by: Olaf Meeuwissen <paddy-hack@member.fsf.org>

Date: Fri, 7 Jan 2022 09:12:01 UTC

Severity: normal

Found in version 5.0.preview-20211220

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to devuan-bugs@lists.dyne.org, paddy-hack@member.fsf.org, Ralph Ronnquist <ralph.ronnquist@gmail.com>:
bug#652; Package devuan-installer. (Fri, 07 Jan 2022 09:12:01 GMT) (full text, mbox, link).


Acknowledgement sent to Olaf Meeuwissen <paddy-hack@member.fsf.org>:
New bug report received and forwarded. Copy sent to paddy-hack@member.fsf.org, Ralph Ronnquist <ralph.ronnquist@gmail.com>. (Fri, 07 Jan 2022 09:12:04 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.devuan.org (full text, mbox, reply):

From: Olaf Meeuwissen <paddy-hack@member.fsf.org>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: devuan-installer: Keyboard layout not configured on console
Date: Fri, 07 Jan 2022 17:12:41 +0900
[Message part 1 (text/plain, inline)]
Package: devuan-installer
Version: 5.0.preview-20211220
Severity: normal
X-Debbugs-Cc: Olaf Meeuwissen <paddy-hack@member.fsf.org>

Dear Maintainer,

Doing a number of test installs with the above installer's netinstall
ISO, I noticed that the selected keyboard layout is not persisted on the
console post-install.  That is, the selection is only active during the
installation itself.  After finishing the installation, the layout on
the console is US-ASCII.  On the Xfce desktop, the selected layout is
configured correctly.  This issue only manifests itself on the console,
i.e. on systems without a GUI or after you switch to a VT.

Excerpts from the attached installation/syslog show:

  apt-install: Queueing package console-setup for later installation

  in-target: Package console-setup is not available, but is referred to by another package.
  in-target: This may mean that the package is missing, has been obsoleted, or
  in-target: is only available from another source
  in-target:
  in-target: E: Package 'console-setup' has no installation candidate
  base-installer: warning: Failed to install console-setup into /target/: 100

I checked the ISO image and it only contains console-setup-udeb.

I had no trouble installing console-setup afterwards (although the
debconf question may be a bit intimidating for inexperienced users).

It seems that only the base-system installation step tries to install
console-setup and that no additional attempt is made to do this after
APT has been configured.

Adding the console-setup package (and any missing Depends:!) to the
installer's package pool should fix this.

Hope this helps.

BTW, US-ASCII keybindings on a Japanese keyboard seriously suck.
-- System Information:
Architecture: x86_64

Kernel: Linux 5.15.0-2-amd64 (SMP w/16 CPU threads)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: runit (via /run/runit.stopit)
LSM: AppArmor: enabled
[syslog.gz (application/gzip, attachment)]

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Fri Aug 19 08:54:51 2022;