Subject: bug#689: openvpn: fatal error during installation

From: "Dimitris T." <[email-masked]>
Date: Thu, 14 Jul 2022 00:38:00 +0300

Package: openvpn
Version: 2.6.0~git20220518+dco-1devuan1
Severity: normal

Hey,

tried to install openvpn and got the following message during installation : 

Selecting previously unselected package openvpn.
Preparing to unpack .../openvpn_2.6.0~git20220518+dco-1devuan1_amd64.deb ...
Unpacking openvpn (2.6.0~git20220518+dco-1devuan1) ...
Installing openvpn (2.6.0~git20220518+dco-1devuan1) ...
Fatal! 2. Unable to understand action preset. Aborted.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on openvpn.service: No such file or directory

openvpn seems to install ok and vpn connection works as expected afaik, no issues seen. just this installation error.

thanks,
d.

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 5 (daedalus/ceres)
Release:	5
Codename:	daedalus ceres
Architecture: x86_64

Kernel: Linux 5.18.0-2-amd64 (SMP w/4 CPU threads; PREEMPT)
Kernel taint flags: TAINT_FIRMWARE_WORKAROUND
Locale: LANG=el_GR.UTF-8, LC_CTYPE=el_GR.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: runit (via /run/runit.stopit)

Versions of packages openvpn depends on:
ii  debconf [debconf-2.0]  1.5.79
ii  libc6                  2.33-8
ii  liblz4-1               1.9.3-2
ii  liblzo2-2              2.10-2
ii  libnl-3-200            3.5.0-0.1
ii  libnl-genl-3-200       3.5.0-0.1
ii  libpam0g               1.4.0-13
ii  libpkcs11-helper1      1.29.0-1
ii  libssl3                3.0.4-2
ii  lsb-base               11.2

Versions of packages openvpn recommends:
ii  easy-rsa  3.1.0-0.1

Versions of packages openvpn suggests:
ii  openssl           3.0.4-2
pn  openvpn-dco-dkms  <none>
pn  resolvconf        <none>

-- debconf information:
  openvpn/create_tun: false

---

From: Mark Hindley <[email-masked]>
Date: Thu, 14 Jul 2022 07:21:40 +0100

Dimitris,

Thanks.

> Fatal! 2. Unable to understand action preset. Aborted.

Do you have either systemctl or systemctl-service-shim installed?

Thanks

Mark
> _______________________________________________
> devuan-dev internal mailing list
> [email-masked]
> https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/devuan-dev

---

From: Dimitris <[email-masked]>
Date: Thu, 14 Jul 2022 12:56:41 +0300

> Do you have either systemctl or systemctl-service-shim installed?

yes,
systemctl-service-shim/unstable,now 0.0.3-1 all is installed.
don't know why it's there, but it seems that it'll remove lvm2 if i try 
to purge it..

thx,
d.

---

From: Mark Hindley <[email-masked]>
Date: Thu, 14 Jul 2022 12:46:49 +0100

Control: reassign -1 systemctl-service-shim
Control: found -1 0.0.3-1

On Thu, Jul 14, 2022 at 12:56:41PM +0300, Dimitris wrote:
> don't know why it's there, but it seems that it'll remove lvm2 if i try to
> purge it..

I think this is caused by the new version of systemctl-service-shim. Reassigning.

Ben,

Now you have added the /bin/systemctl symlink, /usr/bin/deb-systemd-helper tries
to use it and the preset command is not suported.

I think you will need to support the full systemctl API, even if they are noop.

Mark

---

From: Dimitris <[email-masked]>
Date: Fri, 15 Jul 2022 17:09:35 +0300

Hey,

just installed latest systemctl-service-shim (0.0.4-1) and then purged + 
reinstalled openvpn, and error is no longer there...

so it looks fixed (really fast!!), and i think can be closed as well :)

thanks,
d.

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Wed, 17 Apr 2024 12:10:02 +0000

This is an automatic notification regarding your bug report
which was filed against the systemctl-service-shim package:

#689: openvpn: fatal error during installation

It has been closed by B Stack <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact B Stack <[email-masked]> by
replying to this email.

-- 
689: https://bugs.devuan.org/cgi/bugreport.cgi?bug=689
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: fixed in 0.0.5
From: B Stack <[email-masked]>
To: [email-masked]
Date: Wed, 17 Apr 2024 08:08:36 -0400

Please find that verb "preset" operates without error in
systemctl-service-shim 0.0.5 which is in Devuan Ceres.

B. Stack

Subject: openvpn: fatal error during installation
From: "Dimitris T." <[email-masked]>
To: Devuan Bug Tracking System <[email-masked]>
Date: Thu, 14 Jul 2022 00:38:00 +0300

Package: openvpn

Hey,

thanks,
d.

-- System Information:
Distributor ID:	Devuan

-- debconf information: