Subject: bug#753: gdb: Package gdb-doc is unavailable, but is suggested when installing gdb

From: Fredrik Nyqvist <[email-masked]>
Date: Mon, 27 Mar 2023 21:25:51 +0200

Package: gdb
Version: 10.1-1.7
Severity: minor
Tags: a11y

Dear Maintainer,

   * What led up to the situation?
1. Installing gdb via apt
 sudo apt install gdb

2. gdb-doc is suggested by apt

3. Trying to install gdb-doc
 sudo apt install gdb-doc

4. An error message is shown saying that the package gdb-doc is not
available.

-- System Information:
Distributor ID: Devuan
Description: Devuan GNU/Linux 4 (chimaera)
Release: 4
Codename: chimaera
Architecture: x86_64

Kernel: Linux 5.10.0-20-amd64 (SMP w/2 CPU threads)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8), LANGUAGE
not set
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages gdb depends on:
pn  libbabeltrace1          <none>
ii  libc6                   2.31-13+deb11u5
pn  libdebuginfod1          <none>
ii  libexpat1               2.2.10-2+deb11u5
ii  libgcc-s1               10.2.1-6
pn  libipt2                 <none>
ii  liblzma5                5.2.5-2.1~deb11u1
ii  libmpfr6                4.1.0-3
ii  libncursesw6            6.2+20201114-2
ii  libpython3.9            3.9.2-1
ii  libreadline8            8.1-1
pn  libsource-highlight4v5  <none>
ii  libstdc++6              10.2.1-6
ii  libtinfo6               6.2+20201114-2
ii  libxxhash0              0.8.0-2
nii  zlib1g                  1:1.2.11.dfsg-2+deb11u2

Versions of packages gdb recommends:
pn  libc-dbg  <none>

Versions of packages gdb suggests:
pn  gdb-doc    <none>
pn  gdbserver  <none>

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Tue, 28 Mar 2023 09:44:07 +0000

This is an automatic notification regarding your bug report
which was filed against the gdb package:

#753: gdb: Package gdb-doc is unavailable, but is suggested when installing gdb

It has been closed by Mark Hindley <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mark Hindley <[email-masked]> by
replying to this email.

-- 
753: https://bugs.devuan.org/cgi/bugreport.cgi?bug=753
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: Re: bug#753: gdb: Package gdb-doc is unavailable, but is suggested when installing gdb
From: Mark Hindley <[email-masked]>
To: Fredrik Nyqvist <[email-masked]>, [email-masked]
Date: Tue, 28 Mar 2023 10:42:03 +0100

Control: tags -1 debian

Fredrik,

>    4. An error message is shown saying that the package gdb-doc is not

Unexpectedly and for lengthy historical reasons[1], gdb-doc is part of
non-free. If you add non-free to your sources.list you will be able to install
it[2].

Closing.

Mark

[1]  https://lists.debian.org/debian-user/2009/11/msg00400.html

[2]  https://pkginfo.devuan.org/gdb-doc

Subject: gdb: Package gdb-doc is unavailable, but is suggested when installing gdb
From: Fredrik Nyqvist <[email-masked]>
To: Devuan Bug Tracking System <[email-masked]>
Date: Mon, 27 Mar 2023 21:25:51 +0200

Package: gdb
Version: 10.1-1.7
Severity: minor
Tags: a11y

Dear Maintainer,

-- System Information:
Distributor ID: Devuan