Subject: lag in exiting xsession using experimental xserver-xorg-core

From: "50r3n.2023" <[email-masked]>
Date: Tue, 12 Sep 2023 10:46:53 +0000

Package: xserver-xorg-core
Version: 2:21.1.7-3devuan2~exp1
Severity: normal
X-Debbugs-Cc: [email-masked]

Dear Maintainer,
installed xserver-xorg-core from devuan experimental repo to test on a virtualbox virtual machine as per dev1galaxy.org forum post.
http://www.dev1galaxy.org/viewtopic.php?pid=44226#p44226
issue is lag in loging out of an xsession started using startx for icewm and jwm. Elogind not installed or used, testing seatd for multiple vt switching.

*** Reporter, please consider answering these questions, where appropriate ***

* What led up to the situation?
* What exactly did you do (or not do) that was effective (or
ineffective)?
* What was the outcome of this action?
* What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- Package-specific info:
/etc/X11/X does not exist.
/etc/X11/X is not a symlink.
/etc/X11/X is not executable.

VGA-compatible devices on PCI bus:
----------------------------------
00:02.0 VGA compatible controller [0300]: VMware SVGA II Adapter [15ad:0405]

/etc/X11/xorg.conf does not exist.

Contents of /etc/X11/xorg.conf.d:
---------------------------------
total 0

/etc/modprobe.d contains no KMS configuration files.

Kernel version (/proc/version):
-------------------------------
Linux version 6.1.0-12-amd64 ([email-masked]) (gcc-12 (Debian 12.2.0-14) 12.2.0, GNU ld (GNU Binutils for Debian) 2.40) #1 SMP PREEMPT_DYNAMIC Debian 6.1.52-1 (2023-09-07)

Xorg X server log files on system:
----------------------------------
-rw-r--r-- 1 root root 23848 Sep 12 17:34 /var/log/Xorg.0.log
-rw-r--r-- 1 soren soren 22669 Sep 12 17:52 /home/soren/.local/share/xorg/Xorg.4.log
-rw-r--r-- 1 soren soren 25614 Sep 12 17:57 /home/soren/.local/share/xorg/Xorg.6.log
-rw-r--r-- 1 soren soren 28486 Sep 12 17:57 /home/soren/.local/share/xorg/Xorg.5.log
-rw-r--r-- 1 soren soren 22742 Sep 12 17:59 /home/soren/.local/share/xorg/Xorg.7.log
-rw-r--r-- 1 soren soren 23846 Sep 12 18:17 /home/soren/.local/share/xorg/Xorg.8.log
-rw-r--r-- 1 soren soren 23094 Sep 12 18:17 /home/soren/.local/share/xorg/Xorg.0.log
-rw-r--r-- 1 soren soren 29272 Sep 12 18:19 /home/soren/.local/share/xorg/Xorg.2.log
-rw-r--r-- 1 soren soren 26400 Sep 12 18:22 /home/soren/.local/share/xorg/Xorg.3.log
-rw-r--r-- 1 soren soren 31110 Sep 12 18:22 /home/soren/.local/share/xorg/Xorg.1.log

Contents of most recent Xorg X server log file (/home/soren/.local/share/xorg/Xorg.1.log):
------------------------------------------------------------------------------------------
[ 46.384]
X.Org X Server 1.21.1.7
X Protocol Version 11, Revision 0
[ 46.385] Current Operating System: Linux devuan5 6.1.0-12-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.52-1 (2023-09-07) x86_64
[ 46.385] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.1.0-12-amd64 root=UUID=f3aa871a-87fa-4176-9207-25f7c5b1df79 ro quiet
[ 46.385] xorg-server 2:21.1.7-3devuan2~exp1 (https://www.devuan.org/os/community)
[ 46.385] Current version of pixman: 0.42.2
[ 46.386] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 46.386] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 46.387] (==) Log file: "/home/soren/.local/share/xorg/Xorg.1.log", Time: Tue Sep 12 18:18:02 2023
[ 46.387] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 46.387] (==) No Layout section. Using the first Screen section.
[ 46.387] (==) No screen section available. Using defaults.
[ 46.387] (**) |-->Screen "Default Screen Section" (0)
[ 46.387] (**) | |-->Monitor "<default monitor>"
[ 46.387] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 46.387] (==) Automatically adding devices
[ 46.387] (==) Automatically enabling devices
[ 46.387] (==) Automatically adding GPU devices
[ 46.387] (==) Automatically binding GPU devices
[ 46.387] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 46.387] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 46.387] Entry deleted from font path.
[ 46.387] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 46.387] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 46.387] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 46.387] (II) Loader magic: 0x560dc6638ea0
[ 46.387] (II) Module ABI versions:
[ 46.387] X.Org ANSI C Emulation: 0.4
[ 46.387] X.Org Video Driver: 25.2
[ 46.387] X.Org XInput driver : 24.4
[ 46.387] X.Org Server Extension : 10.0
[ 46.387] (++) using VT number 1

[ 46.387] (II) seatd_libseat init
[ 46.387] (II) [libseat/libseat.c:73] Seat opened with backend 'seatd'
[ 46.387] (II) [libseat/backend/seatd.c:212] Enabling seat
[ 46.387] (II) seatd_libseat enable
[ 46.387] (II) seatd_libseat handled 2 events
[ 46.487] (II) seatd_libseat client activated
[ 46.488] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 46.488] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[ 46.488] (II) seatd_libseat try open graphics /dev/dri/card0
[ 46.488] (II) seatd_libseat opened graphics: /dev/dri/card0 (1:12)
[ 46.489] (--) PCI:*(0@0:2:0) 15ad:0405:15ad:0405 rev 0, Mem @ 0xe0000000/16777216, 0xf0000000/2097152, I/O @ 0x0000d010/16, BIOS @ 0x????????/131072
[ 46.489] (II) LoadModule: "glx"
[ 46.489] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 46.490] (II) Module glx: vendor="X.Org Foundation"
[ 46.490] compiled for 1.21.1.7, module version = 1.0.0
[ 46.490] ABI class: X.Org Server Extension, version 10.0
[ 46.490] (==) Matched vmware as autoconfigured driver 0
[ 46.490] (==) Matched modesetting as autoconfigured driver 1
[ 46.490] (==) Matched fbdev as autoconfigured driver 2
[ 46.490] (==) Matched vesa as autoconfigured driver 3
[ 46.490] (==) Assigned the driver to the xf86ConfigLayout
[ 46.490] (II) LoadModule: "vmware"
[ 46.490] (WW) Warning, couldn't open module vmware
[ 46.490] (EE) Failed to load module "vmware" (module does not exist, 0)
[ 46.490] (II) LoadModule: "modesetting"
[ 46.490] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 46.490] (II) Module modesetting: vendor="X.Org Foundation"
[ 46.490] compiled for 1.21.1.7, module version = 1.21.1
[ 46.490] Module class: X.Org Video Driver
[ 46.490] ABI class: X.Org Video Driver, version 25.2
[ 46.490] (II) LoadModule: "fbdev"
[ 46.490] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 46.490] (II) Module fbdev: vendor="X.Org Foundation"
[ 46.490] compiled for 1.21.1.3, module version = 0.5.0
[ 46.490] Module class: X.Org Video Driver
[ 46.490] ABI class: X.Org Video Driver, version 25.2
[ 46.490] (II) LoadModule: "vesa"
[ 46.490] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 46.490] (II) Module vesa: vendor="X.Org Foundation"
[ 46.490] compiled for 1.21.1.3, module version = 2.5.0
[ 46.490] Module class: X.Org Video Driver
[ 46.490] ABI class: X.Org Video Driver, version 25.2
[ 46.490] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 46.490] (II) FBDEV: driver for framebuffer: fbdev
[ 46.490] (II) VESA: driver for VESA chipsets: vesa
[ 46.491] xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)
[ 46.491] (II) modeset(0): using drv /dev/dri/card0
[ 46.491] (WW) Falling back to old probe method for fbdev
[ 46.491] (II) Loading sub module "fbdevhw"
[ 46.491] (II) LoadModule: "fbdevhw"
[ 46.491] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 46.491] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 46.491] compiled for 1.21.1.7, module version = 0.0.2
[ 46.491] ABI class: X.Org Video Driver, version 25.2
[ 46.491] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 46.491] (II) modeset(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 46.491] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[ 46.491] (==) modeset(0): RGB weight 888
[ 46.491] (==) modeset(0): Default visual is TrueColor
[ 46.491] (II) Loading sub module "glamoregl"
[ 46.491] (II) LoadModule: "glamoregl"
[ 46.491] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[ 46.493] (II) Module glamoregl: vendor="X.Org Foundation"
[ 46.493] compiled for 1.21.1.7, module version = 1.0.1
[ 46.493] ABI class: X.Org ANSI C Emulation, version 0.4
[ 46.519] (II) modeset(0): Refusing to try glamor on llvmpipe
[ 46.519] (II) modeset(0): glamor initialization failed
[ 46.519] (II) modeset(0): ShadowFB: preferred NO, enabled NO
[ 46.519] (II) modeset(0): Output Virtual-1 has no monitor section
[ 46.519] (II) modeset(0): Output Virtual-2 has no monitor section
[ 46.519] (II) modeset(0): Output Virtual-3 has no monitor section
[ 46.520] (II) modeset(0): Output Virtual-4 has no monitor section
[ 46.520] (II) modeset(0): Output Virtual-5 has no monitor section
[ 46.520] (II) modeset(0): Output Virtual-6 has no monitor section
[ 46.520] (II) modeset(0): Output Virtual-7 has no monitor section
[ 46.520] (II) modeset(0): Output Virtual-8 has no monitor section
[ 46.520] (II) modeset(0): EDID for output Virtual-1
[ 46.520] (II) modeset(0): Printing probed modes for output Virtual-1
[ 46.520] (II) modeset(0): Modeline "800x600"x60.0 42.75 800 850 900 950 600 650 700 750 -hsync +vsync (45.0 kHz eP)
[ 46.520] (II) modeset(0): Modeline "2560x1600"x60.0 348.50 2560 2752 3032 3504 1600 1603 1609 1658 -hsync +vsync (99.5 kHz e)
[ 46.520] (II) modeset(0): Modeline "2560x1440"x60.0 241.50 2560 2608 2640 2720 1440 1443 1448 1481 +hsync -vsync (88.8 kHz e)
[ 46.520] (II) modeset(0): Modeline "1920x1440"x60.0 234.00 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync (90.0 kHz e)
[ 46.520] (II) modeset(0): Modeline "1856x1392"x60.0 218.25 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync (86.3 kHz e)
[ 46.520] (II) modeset(0): Modeline "1792x1344"x60.0 204.75 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync (83.6 kHz e)
[ 46.520] (II) modeset(0): Modeline "1920x1200"x59.9 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync (74.6 kHz e)
[ 46.520] (II) modeset(0): Modeline "1920x1080"x60.0 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync (67.2 kHz e)
[ 46.520] (II) modeset(0): Modeline "1600x1200"x60.0 162.00 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
[ 46.520] (II) modeset(0): Modeline "1680x1050"x60.0 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
[ 46.520] (II) modeset(0): Modeline "1400x1050"x60.0 121.75 1400 1488 1632 1864 1050 1053 1057 1089 -hsync +vsync (65.3 kHz e)
[ 46.520] (II) modeset(0): Modeline "1280x1024"x60.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[ 46.520] (II) modeset(0): Modeline "1440x900"x59.9 106.50 1440 1520 1672 1904 900 903 909 934 -hsync +vsync (55.9 kHz e)
[ 46.520] (II) modeset(0): Modeline "1280x960"x60.0 108.00 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync (60.0 kHz e)
[ 46.520] (II) modeset(0): Modeline "1360x768"x60.0 85.50 1360 1424 1536 1792 768 771 777 795 +hsync +vsync (47.7 kHz e)
[ 46.520] (II) modeset(0): Modeline "1280x800"x59.8 83.50 1280 1352 1480 1680 800 803 809 831 +hsync -vsync (49.7 kHz e)
[ 46.520] (II) modeset(0): Modeline "1152x864"x75.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz e)
[ 46.520] (II) modeset(0): Modeline "1280x768"x59.9 79.50 1280 1344 1472 1664 768 771 778 798 -hsync +vsync (47.8 kHz e)
[ 46.520] (II) modeset(0): Modeline "1280x720"x59.9 74.50 1280 1344 1472 1664 720 723 728 748 -hsync +vsync (44.8 kHz e)
[ 46.520] (II) modeset(0): Modeline "1024x768"x60.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 46.520] (II) modeset(0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 46.520] (II) modeset(0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 489 492 525 -hsync -vsync (31.5 kHz e)
[ 46.520] (II) modeset(0): EDID for output Virtual-2
[ 46.520] (II) modeset(0): EDID for output Virtual-3
[ 46.520] (II) modeset(0): EDID for output Virtual-4
[ 46.520] (II) modeset(0): EDID for output Virtual-5
[ 46.520] (II) modeset(0): EDID for output Virtual-6
[ 46.520] (II) modeset(0): EDID for output Virtual-7
[ 46.520] (II) modeset(0): EDID for output Virtual-8
[ 46.520] (II) modeset(0): Output Virtual-1 connected
[ 46.520] (II) modeset(0): Output Virtual-2 disconnected
[ 46.520] (II) modeset(0): Output Virtual-3 disconnected
[ 46.520] (II) modeset(0): Output Virtual-4 disconnected
[ 46.520] (II) modeset(0): Output Virtual-5 disconnected
[ 46.520] (II) modeset(0): Output Virtual-6 disconnected
[ 46.520] (II) modeset(0): Output Virtual-7 disconnected
[ 46.520] (II) modeset(0): Output Virtual-8 disconnected
[ 46.520] (II) modeset(0): Using exact sizes for initial modes
[ 46.520] (II) modeset(0): Output Virtual-1 using initial mode 800x600 +0+0
[ 46.520] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[ 46.520] (==) modeset(0): DPI set to (96, 96)
[ 46.520] (II) Loading sub module "fb"
[ 46.520] (II) LoadModule: "fb"
[ 46.520] (II) Module "fb" already built-in
[ 46.520] (II) UnloadModule: "fbdev"
[ 46.520] (II) Unloading fbdev
[ 46.520] (II) UnloadSubModule: "fbdevhw"
[ 46.520] (II) Unloading fbdevhw
[ 46.520] (II) UnloadModule: "vesa"
[ 46.520] (II) Unloading vesa
[ 46.520] (==) modeset(0): Backing store enabled
[ 46.520] (==) modeset(0): Silken mouse enabled
[ 46.520] (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
[ 46.520] (==) modeset(0): DPMS enabled
[ 46.520] (II) Initializing extension Generic Event Extension
[ 46.520] (II) Initializing extension SHAPE
[ 46.521] (II) Initializing extension MIT-SHM
[ 46.521] (II) Initializing extension XInputExtension
[ 46.521] (II) Initializing extension XTEST
[ 46.521] (II) Initializing extension BIG-REQUESTS
[ 46.521] (II) Initializing extension SYNC
[ 46.521] (II) Initializing extension XKEYBOARD
[ 46.521] (II) Initializing extension XC-MISC
[ 46.521] (II) Initializing extension SECURITY
[ 46.521] (II) Initializing extension XFIXES
[ 46.521] (II) Initializing extension RENDER
[ 46.521] (II) Initializing extension RANDR
[ 46.521] (II) Initializing extension COMPOSITE
[ 46.521] (II) Initializing extension DAMAGE
[ 46.521] (II) Initializing extension MIT-SCREEN-SAVER
[ 46.521] (II) Initializing extension DOUBLE-BUFFER
[ 46.522] (II) Initializing extension RECORD
[ 46.522] (II) Initializing extension DPMS
[ 46.522] (II) Initializing extension Present
[ 46.522] (II) Initializing extension DRI3
[ 46.522] (II) Initializing extension X-Resource
[ 46.522] (II) Initializing extension XVideo
[ 46.522] (II) Initializing extension XVideo-MotionCompensation
[ 46.522] (II) Initializing extension SELinux
[ 46.522] (II) SELinux: Disabled on system
[ 46.522] (II) Initializing extension GLX
[ 46.522] (II) AIGLX: Screen 0 is not DRI2 capable
[ 46.524] (II) IGLX: Loaded and initialized swrast
[ 46.524] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 46.524] (II) Initializing extension XFree86-VidModeExtension
[ 46.524] (II) Initializing extension XFree86-DGA
[ 46.524] (II) Initializing extension XFree86-DRI
[ 46.524] (II) Initializing extension DRI2
[ 46.524] (II) modeset(0): Damage tracking initialized
[ 46.524] (II) modeset(0): Setting screen physical size to 211 x 158
[ 46.540] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[ 46.540] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[ 46.540] (II) LoadModule: "libinput"
[ 46.540] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[ 46.541] (II) Module libinput: vendor="X.Org Foundation"
[ 46.541] compiled for 1.21.1.3, module version = 1.2.1
[ 46.541] Module class: X.Org XInput Driver
[ 46.541] ABI class: X.Org XInput driver, version 24.4
[ 46.541] (II) Using input driver 'libinput' for 'Power Button'
[ 46.541] (II) seatd_libseat try open /dev/input/event3
[ 46.541] (II) seatd_libseat opened /dev/input/event3 (2:20)
[ 46.541] (**) Power Button: always reports core events
[ 46.541] (**) Option "Device" "/dev/input/event3"
[ 46.542] (II) event3 - Power Button: is tagged by udev as: Keyboard
[ 46.542] (II) event3 - Power Button: device is a keyboard
[ 46.542] (II) event3 - Power Button: device removed
[ 46.542] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event3"
[ 46.542] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 46.542] (**) Option "xkb_model" "pc105"
[ 46.542] (**) Option "xkb_layout" "us"
[ 46.543] (II) event3 - Power Button: is tagged by udev as: Keyboard
[ 46.543] (II) event3 - Power Button: device is a keyboard
[ 46.543] (II) config/udev: Adding input device Sleep Button (/dev/input/event5)
[ 46.543] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[ 46.543] (II) Using input driver 'libinput' for 'Sleep Button'
[ 46.543] (II) seatd_libseat try open /dev/input/event5
[ 46.543] (II) seatd_libseat opened /dev/input/event5 (3:23)
[ 46.543] (**) Sleep Button: always reports core events
[ 46.543] (**) Option "Device" "/dev/input/event5"
[ 46.543] (II) event5 - Sleep Button: is tagged by udev as: Keyboard
[ 46.543] (II) event5 - Sleep Button: device is a keyboard
[ 46.543] (II) event5 - Sleep Button: device removed
[ 46.543] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSLPBN:00/input/input6/event5"
[ 46.543] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 7)
[ 46.543] (**) Option "xkb_model" "pc105"
[ 46.543] (**) Option "xkb_layout" "us"
[ 46.543] (II) event5 - Sleep Button: is tagged by udev as: Keyboard
[ 46.543] (II) event5 - Sleep Button: device is a keyboard
[ 46.544] (II) config/udev: Adding input device Video Bus (/dev/input/event1)
[ 46.544] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[ 46.544] (II) Using input driver 'libinput' for 'Video Bus'
[ 46.544] (II) seatd_libseat try open /dev/input/event1
[ 46.544] (II) seatd_libseat opened /dev/input/event1 (4:24)
[ 46.544] (**) Video Bus: always reports core events
[ 46.544] (**) Option "Device" "/dev/input/event1"
[ 46.544] (II) event1 - Video Bus: is tagged by udev as: Keyboard
[ 46.544] (II) event1 - Video Bus: device is a keyboard
[ 46.544] (II) event1 - Video Bus: device removed
[ 46.544] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1"
[ 46.544] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[ 46.544] (**) Option "xkb_model" "pc105"
[ 46.544] (**) Option "xkb_layout" "us"
[ 46.544] (II) event1 - Video Bus: is tagged by udev as: Keyboard
[ 46.544] (II) event1 - Video Bus: device is a keyboard
[ 46.545] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/event4)
[ 46.545] (**) VirtualBox mouse integration: Applying InputClass "libinput pointer catchall"
[ 46.545] (II) Using input driver 'libinput' for 'VirtualBox mouse integration'
[ 46.545] (II) seatd_libseat try open /dev/input/event4
[ 46.545] (II) seatd_libseat opened /dev/input/event4 (5:25)
[ 46.545] (**) VirtualBox mouse integration: always reports core events
[ 46.545] (**) Option "Device" "/dev/input/event4"
[ 46.545] (II) event4 - VirtualBox mouse integration: is tagged by udev as: Mouse
[ 46.545] (II) event4 - VirtualBox mouse integration: device is a pointer
[ 46.545] (II) event4 - VirtualBox mouse integration: device removed
[ 46.545] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.0/input/input5/event4"
[ 46.545] (II) XINPUT: Adding extended input device "VirtualBox mouse integration" (type: MOUSE, id 9)
[ 46.545] (**) Option "AccelerationScheme" "none"
[ 46.545] (**) VirtualBox mouse integration: (accel) selected scheme none/0
[ 46.545] (**) VirtualBox mouse integration: (accel) acceleration factor: 2.000
[ 46.545] (**) VirtualBox mouse integration: (accel) acceleration threshold: 4
[ 46.546] (II) event4 - VirtualBox mouse integration: is tagged by udev as: Mouse
[ 46.546] (II) event4 - VirtualBox mouse integration: device is a pointer
[ 46.546] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/js0)
[ 46.546] (II) No input driver specified, ignoring this device.
[ 46.546] (II) This device may have been added with another device file.
[ 46.546] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/mouse1)
[ 46.546] (II) No input driver specified, ignoring this device.
[ 46.546] (II) This device may have been added with another device file.
[ 46.546] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[ 46.546] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[ 46.546] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[ 46.546] (II) seatd_libseat try open /dev/input/event0
[ 46.546] (II) seatd_libseat opened /dev/input/event0 (6:26)
[ 46.546] (**) AT Translated Set 2 keyboard: always reports core events
[ 46.546] (**) Option "Device" "/dev/input/event0"
[ 46.546] (II) event0 - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[ 46.546] (II) event0 - AT Translated Set 2 keyboard: device is a keyboard
[ 46.547] (II) event0 - AT Translated Set 2 keyboard: device removed
[ 46.547] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[ 46.547] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[ 46.547] (**) Option "xkb_model" "pc105"
[ 46.547] (**) Option "xkb_layout" "us"
[ 46.547] (II) event0 - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[ 46.547] (II) event0 - AT Translated Set 2 keyboard: device is a keyboard
[ 46.547] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event2)
[ 46.547] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "libinput pointer catchall"
[ 46.547] (II) Using input driver 'libinput' for 'ImExPS/2 Generic Explorer Mouse'
[ 46.547] (II) seatd_libseat try open /dev/input/event2
[ 46.547] (II) seatd_libseat opened /dev/input/event2 (7:27)
[ 46.547] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[ 46.547] (**) Option "Device" "/dev/input/event2"
[ 46.547] (II) event2 - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[ 46.547] (II) event2 - ImExPS/2 Generic Explorer Mouse: device is a pointer
[ 46.547] (II) event2 - ImExPS/2 Generic Explorer Mouse: device removed
[ 46.548] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input3/event2"
[ 46.548] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE, id 11)
[ 46.548] (**) Option "AccelerationScheme" "none"
[ 46.548] (**) ImExPS/2 Generic Explorer Mouse: (accel) selected scheme none/0
[ 46.548] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[ 46.548] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[ 46.548] (II) event2 - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[ 46.548] (II) event2 - ImExPS/2 Generic Explorer Mouse: device is a pointer
[ 46.548] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[ 46.548] (II) No input driver specified, ignoring this device.
[ 46.548] (II) This device may have been added with another device file.
[ 46.548] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
[ 46.548] (II) No input driver specified, ignoring this device.
[ 46.548] (II) This device may have been added with another device file.
[ 46.556] (II) modeset(0): Allocate new frame buffer 1920x1200 stride
[ 83.788] (II) seatd_libseat switch VT 2
[ 83.789] (II) event2 - ImExPS/2 Generic Explorer Mouse: device removed
[ 83.789] (II) event0 - AT Translated Set 2 keyboard: device removed
[ 83.789] (II) event4 - VirtualBox mouse integration: device removed
[ 83.789] (II) event1 - Video Bus: device removed
[ 83.789] (II) event5 - Sleep Button: device removed
[ 83.789] (II) event3 - Power Button: device removed
[ 83.789] (II) seatd_libseat event handler
[ 83.791] (II) [libseat/backend/seatd.c:207] Disabling seat
[ 83.791] (II) seatd_libseat disable
[ 83.791] (II) seatd_libseat try close /dev/input/event3 (2:20)
[ 83.812] (II) seatd_libseat try close /dev/input/event5 (3:23)
[ 83.836] (II) seatd_libseat try close /dev/input/event1 (4:24)
[ 83.860] (II) seatd_libseat try close /dev/input/event4 (5:25)
[ 83.884] (II) seatd_libseat try close /dev/input/event0 (6:26)
[ 83.908] (II) seatd_libseat try close /dev/input/event2 (7:27)
[ 83.932] (II) seatd_libseat handled 2 events
[ 108.316] (II) seatd_libseat event handler
[ 108.316] (II) [libseat/backend/seatd.c:212] Enabling seat
[ 108.316] (II) seatd_libseat enable
[ 108.326] (II) seatd_libseat try open /dev/input/event3
[ 108.327] (II) seatd_libseat opened /dev/input/event3 (2:20)
[ 108.327] (II) event3 - Power Button: is tagged by udev as: Keyboard
[ 108.327] (II) event3 - Power Button: device is a keyboard
[ 108.327] (II) seatd_libseat try open /dev/input/event5
[ 108.327] (II) seatd_libseat opened /dev/input/event5 (3:23)
[ 108.328] (II) event5 - Sleep Button: is tagged by udev as: Keyboard
[ 108.328] (II) event5 - Sleep Button: device is a keyboard
[ 108.328] (II) seatd_libseat try open /dev/input/event1
[ 108.328] (II) seatd_libseat opened /dev/input/event1 (4:24)
[ 108.328] (II) event1 - Video Bus: is tagged by udev as: Keyboard
[ 108.328] (II) event1 - Video Bus: device is a keyboard
[ 108.328] (II) seatd_libseat try open /dev/input/event4
[ 108.328] (II) seatd_libseat opened /dev/input/event4 (5:25)
[ 108.329] (II) event4 - VirtualBox mouse integration: is tagged by udev as: Mouse
[ 108.329] (II) event4 - VirtualBox mouse integration: device is a pointer
[ 108.329] (II) seatd_libseat try open /dev/input/event0
[ 108.329] (II) seatd_libseat opened /dev/input/event0 (6:26)
[ 108.329] (II) event0 - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[ 108.329] (II) event0 - AT Translated Set 2 keyboard: device is a keyboard
[ 108.329] (II) seatd_libseat try open /dev/input/event2
[ 108.329] (II) seatd_libseat opened /dev/input/event2 (7:27)
[ 108.329] (II) event2 - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[ 108.330] (II) event2 - ImExPS/2 Generic Explorer Mouse: device is a pointer
[ 108.330] (II) seatd_libseat handled 2 events
[ 109.956] (II) seatd_libseat switch VT 2
[ 109.956] (II) event2 - ImExPS/2 Generic Explorer Mouse: device removed
[ 109.956] (II) event0 - AT Translated Set 2 keyboard: device removed
[ 109.956] (II) event4 - VirtualBox mouse integration: device removed
[ 109.956] (II) event1 - Video Bus: device removed
[ 109.956] (II) event5 - Sleep Button: device removed
[ 109.957] (II) event3 - Power Button: device removed
[ 109.957] (II) seatd_libseat event handler
[ 109.957] (II) [libseat/backend/seatd.c:207] Disabling seat
[ 109.957] (II) seatd_libseat disable
[ 109.957] (II) seatd_libseat try close /dev/input/event3 (2:20)
[ 109.980] (II) seatd_libseat try close /dev/input/event5 (3:23)
[ 110.007] (II) seatd_libseat try close /dev/input/event1 (4:24)
[ 110.028] (II) seatd_libseat try close /dev/input/event4 (5:25)
[ 110.052] (II) seatd_libseat try close /dev/input/event0 (6:26)
[ 110.076] (II) seatd_libseat try close /dev/input/event2 (7:27)
[ 110.105] (II) seatd_libseat handled 2 events
[ 124.832] (II) seatd_libseat event handler
[ 124.832] (II) [libseat/backend/seatd.c:212] Enabling seat
[ 124.832] (II) seatd_libseat enable
[ 124.842] (II) seatd_libseat try open /dev/input/event3
[ 124.842] (II) seatd_libseat opened /dev/input/event3 (2:20)
[ 124.842] (II) event3 - Power Button: is tagged by udev as: Keyboard
[ 124.842] (II) event3 - Power Button: device is a keyboard
[ 124.843] (II) seatd_libseat try open /dev/input/event5
[ 124.843] (II) seatd_libseat opened /dev/input/event5 (3:23)
[ 124.843] (II) event5 - Sleep Button: is tagged by udev as: Keyboard
[ 124.843] (II) event5 - Sleep Button: device is a keyboard
[ 124.843] (II) seatd_libseat try open /dev/input/event1
[ 124.843] (II) seatd_libseat opened /dev/input/event1 (4:24)
[ 124.844] (II) event1 - Video Bus: is tagged by udev as: Keyboard
[ 124.844] (II) event1 - Video Bus: device is a keyboard
[ 124.844] (II) seatd_libseat try open /dev/input/event4
[ 124.844] (II) seatd_libseat opened /dev/input/event4 (5:25)
[ 124.844] (II) event4 - VirtualBox mouse integration: is tagged by udev as: Mouse
[ 124.845] (II) event4 - VirtualBox mouse integration: device is a pointer
[ 124.845] (II) seatd_libseat try open /dev/input/event0
[ 124.845] (II) seatd_libseat opened /dev/input/event0 (6:26)
[ 124.845] (II) event0 - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[ 124.845] (II) event0 - AT Translated Set 2 keyboard: device is a keyboard
[ 124.845] (II) seatd_libseat try open /dev/input/event2
[ 124.845] (II) seatd_libseat opened /dev/input/event2 (7:27)
[ 124.846] (II) event2 - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[ 124.846] (II) event2 - ImExPS/2 Generic Explorer Mouse: device is a pointer
[ 124.846] (II) seatd_libseat handled 2 events
[ 126.130] (II) seatd_libseat switch VT 3
[ 126.130] (II) event2 - ImExPS/2 Generic Explorer Mouse: device removed
[ 126.130] (II) event0 - AT Translated Set 2 keyboard: device removed
[ 126.130] (II) event4 - VirtualBox mouse integration: device removed
[ 126.130] (II) event1 - Video Bus: device removed
[ 126.130] (II) event5 - Sleep Button: device removed
[ 126.130] (II) event3 - Power Button: device removed
[ 126.130] (II) seatd_libseat event handler
[ 126.130] (II) [libseat/backend/seatd.c:207] Disabling seat
[ 126.130] (II) seatd_libseat disable
[ 126.130] (II) seatd_libseat try close /dev/input/event3 (2:20)
[ 126.152] (II) seatd_libseat try close /dev/input/event5 (3:23)
[ 126.176] (II) seatd_libseat try close /dev/input/event1 (4:24)
[ 126.200] (II) seatd_libseat try close /dev/input/event4 (5:25)
[ 126.224] (II) seatd_libseat try close /dev/input/event0 (6:26)
[ 126.248] (II) seatd_libseat try close /dev/input/event2 (7:27)
[ 126.277] (II) seatd_libseat handled 2 events
[ 341.196] (II) seatd_libseat event handler
[ 341.196] (II) [libseat/backend/seatd.c:212] Enabling seat
[ 341.196] (II) seatd_libseat enable
[ 341.206] (II) seatd_libseat try open /dev/input/event3
[ 341.206] (II) seatd_libseat opened /dev/input/event3 (2:20)
[ 341.207] (II) event3 - Power Button: is tagged by udev as: Keyboard
[ 341.207] (II) event3 - Power Button: device is a keyboard
[ 341.207] (II) seatd_libseat try open /dev/input/event5
[ 341.207] (II) seatd_libseat opened /dev/input/event5 (3:23)
[ 341.207] (II) event5 - Sleep Button: is tagged by udev as: Keyboard
[ 341.207] (II) event5 - Sleep Button: device is a keyboard
[ 341.207] (II) seatd_libseat try open /dev/input/event1
[ 341.207] (II) seatd_libseat opened /dev/input/event1 (4:24)
[ 341.207] (II) event1 - Video Bus: is tagged by udev as: Keyboard
[ 341.207] (II) event1 - Video Bus: device is a keyboard
[ 341.208] (II) seatd_libseat try open /dev/input/event4
[ 341.208] (II) seatd_libseat opened /dev/input/event4 (5:25)
[ 341.208] (II) event4 - VirtualBox mouse integration: is tagged by udev as: Mouse
[ 341.208] (II) event4 - VirtualBox mouse integration: device is a pointer
[ 341.208] (II) seatd_libseat try open /dev/input/event0
[ 341.208] (II) seatd_libseat opened /dev/input/event0 (6:26)
[ 341.208] (II) event0 - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[ 341.208] (II) event0 - AT Translated Set 2 keyboard: device is a keyboard
[ 341.209] (II) seatd_libseat try open /dev/input/event2
[ 341.209] (II) seatd_libseat opened /dev/input/event2 (7:27)
[ 341.209] (II) event2 - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[ 341.209] (II) event2 - ImExPS/2 Generic Explorer Mouse: device is a pointer
[ 341.209] (II) seatd_libseat handled 2 events

udev information:
-----------------
P: /devices/LNXSYSTM:00/LNXPWRBN:00/input/input4
E: DEVPATH=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4
E: EV=3
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXPWRBN:00
E: ID_PATH_TAG=acpi-LNXPWRBN_00
E: KEY=10000000000000 0
E: MODALIAS=input:b0019v0000p0001e0000-e0,1,k74,ramlsfw
E: NAME="Power Button"
E: PHYS="LNXPWRBN/button/input0"
E: PRODUCT=19/0/1/0
E: PROP=0
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1827828

P: /devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event3
N: input/event3
E: BACKSPACE=guess
E: DEVNAME=/dev/input/event3
E: DEVPATH=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event3
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXPWRBN:00
E: ID_PATH_TAG=acpi-LNXPWRBN_00
E: LIBINPUT_DEVICE_GROUP=19/0/1:LNXPWRBN/button
E: MAJOR=13
E: MINOR=67
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1874651
E: XKBLAYOUT=us
E: XKBMODEL=pc105

P: /devices/LNXSYSTM:00/LNXSLPBN:00/input/input6
E: DEVPATH=/devices/LNXSYSTM:00/LNXSLPBN:00/input/input6
E: EV=3
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXSLPBN:00
E: ID_PATH_TAG=acpi-LNXSLPBN_00
E: KEY=4000 0 0
E: MODALIAS=input:b0019v0000p0003e0000-e0,1,k8E,ramlsfw
E: NAME="Sleep Button"
E: PHYS="LNXSLPBN/button/input0"
E: PRODUCT=19/0/3/0
E: PROP=0
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1832618

P: /devices/LNXSYSTM:00/LNXSLPBN:00/input/input6/event5
N: input/event5
E: BACKSPACE=guess
E: DEVNAME=/dev/input/event5
E: DEVPATH=/devices/LNXSYSTM:00/LNXSLPBN:00/input/input6/event5
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXSLPBN:00
E: ID_PATH_TAG=acpi-LNXSLPBN_00
E: LIBINPUT_DEVICE_GROUP=19/0/3:LNXSLPBN/button
E: MAJOR=13
E: MINOR=69
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1900584
E: XKBLAYOUT=us
E: XKBMODEL=pc105

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2
E: EV=3
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXVIDEO:00
E: ID_PATH_TAG=acpi-LNXVIDEO_00
E: KEY=3e000b00000000 0 0 0
E: MODALIAS=input:b0019v0000p0006e0000-e0,1,kE0,E1,E3,F1,F2,F3,F4,F5,ramlsfw
E: NAME="Video Bus"
E: PHYS="LNXVIDEO/video/input0"
E: PRODUCT=19/0/6/0
E: PROP=0
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1760377

P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1
N: input/event1
E: BACKSPACE=guess
E: DEVNAME=/dev/input/event1
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_PATH=acpi-LNXVIDEO:00
E: ID_PATH_TAG=acpi-LNXVIDEO_00
E: LIBINPUT_DEVICE_GROUP=19/0/6:LNXVIDEO/video
E: MAJOR=13
E: MINOR=65
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1875363
E: XKBLAYOUT=us
E: XKBMODEL=pc105

P: /devices/pci0000:00/0000:00:04.0/input/input5
E: ABS=3
E: DEVPATH=/devices/pci0000:00/0000:00:04.0/input/input5
E: EV=b
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=pci-0000:00:04.0
E: ID_PATH_TAG=pci-0000_00_04_0
E: ID_SERIAL=noserial
E: KEY=10000 0 0 0 0
E: MODALIAS=input:b0001v80EEpCAFEe0000-e0,1,3,k110,ra0,1,mlsfw
E: NAME="VirtualBox mouse integration"
E: PRODUCT=1/80ee/cafe/0
E: PROP=0
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1828150

P: /devices/pci0000:00/0000:00:04.0/input/input5/event4
N: input/event4
S: input/by-path/pci-0000:00:04.0-event-mouse
E: DEVLINKS=/dev/input/by-path/pci-0000:00:04.0-event-mouse
E: DEVNAME=/dev/input/event4
E: DEVPATH=/devices/pci0000:00/0000:00:04.0/input/input5/event4
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=pci-0000:00:04.0
E: ID_PATH_TAG=pci-0000_00_04_0
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=68
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1893412

P: /devices/pci0000:00/0000:00:04.0/input/input5/js0
N: input/js0
S: input/by-path/pci-0000:00:04.0-mouse
E: DEVLINKS=/dev/input/by-path/pci-0000:00:04.0-mouse
E: DEVNAME=/dev/input/js0
E: DEVPATH=/devices/pci0000:00/0000:00:04.0/input/input5/js0
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=pci-0000:00:04.0
E: ID_PATH_TAG=pci-0000_00_04_0
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=0
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1878936

P: /devices/pci0000:00/0000:00:04.0/input/input5/mouse1
N: input/mouse1
S: input/by-path/pci-0000:00:04.0-mouse
E: DEVLINKS=/dev/input/by-path/pci-0000:00:04.0-mouse
E: DEVNAME=/dev/input/mouse1
E: DEVPATH=/devices/pci0000:00/0000:00:04.0/input/input5/mouse1
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=pci-0000:00:04.0
E: ID_PATH_TAG=pci-0000_00_04_0
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=33
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1831998

P: /devices/platform/i8042/serio0/input/input0
E: DEVPATH=/devices/platform/i8042/serio0/input/input0
E: EV=120013
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_INPUT_KEYBOARD=1
E: ID_PATH=platform-i8042-serio-0
E: ID_PATH_TAG=platform-i8042-serio-0
E: ID_SERIAL=noserial
E: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
E: LED=7
E: MODALIAS=input:b0011v0001p0001eAB41-e0,1,4,11,14,k71,72,73,74,75,76,77,79,7A,7B,7C,7D,7E,7F,80,8C,8E,8F,9B,9C,9D,9E,9F,A3,A4,A5,A6,AC,AD,B7,B8,B9,D9,E2,ram4,l0,1,2,sfw
E: MSC=10
E: NAME="AT Translated Set 2 keyboard"
E: PHYS="isa0060/serio0/input0"
E: PRODUCT=11/1/1/ab41
E: PROP=0
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1779765

P: /devices/platform/i8042/serio0/input/input0/event0
N: input/event0
S: input/by-path/platform-i8042-serio-0-event-kbd
E: BACKSPACE=guess
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-0-event-kbd
E: DEVNAME=/dev/input/event0
E: DEVPATH=/devices/platform/i8042/serio0/input/input0/event0
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_KEY=1
E: ID_INPUT_KEYBOARD=1
E: ID_PATH=platform-i8042-serio-0
E: ID_PATH_TAG=platform-i8042-serio-0
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=11/1/1:isa0060/serio0
E: MAJOR=13
E: MINOR=64
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1877837
E: XKBLAYOUT=us
E: XKBMODEL=pc105

P: /devices/platform/i8042/serio1/input/input3
E: DEVPATH=/devices/platform/i8042/serio1/input/input3
E: EV=7
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: KEY=1f0000 0 0 0 0
E: MODALIAS=input:b0011v0002p0006e0000-e0,1,2,k110,111,112,113,114,r0,1,6,8,amlsfw
E: NAME="ImExPS/2 Generic Explorer Mouse"
E: PHYS="isa0060/serio1/input0"
E: PRODUCT=11/2/6/0
E: PROP=1
E: REL=143
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1781426

P: /devices/platform/i8042/serio1/input/input3/event2
N: input/event2
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event2
E: DEVPATH=/devices/platform/i8042/serio1/input/input3/event2
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=11/2/6:isa0060/serio1
E: MAJOR=13
E: MINOR=66
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1876454

P: /devices/platform/i8042/serio1/input/input3/mouse0
N: input/mouse0
S: input/by-path/platform-i8042-serio-1-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-mouse
E: DEVNAME=/dev/input/mouse0
E: DEVPATH=/devices/platform/i8042/serio1/input/input3/mouse0
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: MAJOR=13
E: MINOR=32
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1782208

P: /devices/platform/pcspkr/input/input7
E: DEVPATH=/devices/platform/pcspkr/input/input7
E: EV=40001
E: ID_INPUT=1
E: ID_PATH=platform-pcspkr
E: ID_PATH_TAG=platform-pcspkr
E: ID_SERIAL=noserial
E: MODALIAS=input:b0010v001Fp0001e0100-e0,12,kramls1,2,fw
E: NAME="PC Speaker"
E: PHYS="isa0061/input0"
E: PRODUCT=10/1f/1/100
E: PROP=0
E: SND=6
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1877315

P: /devices/platform/pcspkr/input/input7/event6
N: input/event6
S: input/by-path/platform-pcspkr-event-spkr
E: DEVLINKS=/dev/input/by-path/platform-pcspkr-event-spkr
E: DEVNAME=/dev/input/event6
E: DEVPATH=/devices/platform/pcspkr/input/input7/event6
E: ID_INPUT=1
E: ID_PATH=platform-pcspkr
E: ID_PATH_TAG=platform-pcspkr
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=10/1f/1:isa0061
E: MAJOR=13
E: MINOR=70
E: SUBSYSTEM=input
E: USEC_INITIALIZED=1897371

DRM Information from dmesg:
---------------------------

-- System Information:
Distributor ID: Devuan
Description: Devuan GNU/Linux 5 (daedalus)
Release: 5
Codename: daedalus
Architecture: x86_64

Kernel: Linux 6.1.0-12-amd64 (SMP w/1 CPU thread; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_AU:en
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages xserver-xorg-core depends on:
ii eudev [udev] 3.2.12-1
ii keyboard-configuration 1.221
ii libaudit1 1:3.0.9-1
ii libbsd0 0.11.7-2
ii libc6 2.36-9+deb12u1
ii libdrm2 2.4.114-1+b1
ii libegl1 1.6.0-1
ii libepoxy0 1.5.10-1
ii libeudev1 3.2.12-1
ii libgbm1 22.3.6-1+deb12u1
ii libgcrypt20 1.10.1-3
ii libgl1 1.6.0-1
ii libpciaccess0 0.17-2
ii libpixman-1-0 0.42.2-1
ii libseat1 0.7.0-6
ii libselinux1 3.4-1+b6
ii libunwind8 1.6.2-3
ii libxau6 1:1.0.9-1
ii libxcvt0 0.1.2-1
ii libxdmcp6 1:1.1.2-3
ii libxfont2 1:2.0.6-1
ii libxshmfence1 1.3-1
ii xserver-common 2:21.1.7-3devuan2~exp1

Versions of packages xserver-xorg-core recommends:
ii libgl1-mesa-dri 22.3.6-1+deb12u1
pn xcvt <none>

Versions of packages xserver-xorg-core suggests:
ii xfonts-100dpi 1:1.0.5
ii xfonts-75dpi 1:1.0.5
ii xfonts-scalable 1:1.0.3-1.3
-- no debconf information

Sent with [Proton Mail](https://proton.me/) secure email.

---

From: Mark Hindley <[email-masked]>
Date: Tue, 12 Sep 2023 18:03:18 +0100

Control: tags -1 moreinfo

Thanks for this

Can you also attach the  logfile that shows the shutdown. 

On Tue, Sep 12, 2023 at 10:46:53AM +0000, 50r3n.2023 wrote:
>    Contents of most recent Xorg X server log file
>    (/home/soren/.local/share/xorg/Xorg.1.log):

It is probably ~/.local/share/xorg/Xorg.1.log.old

Thanks

Mark

---

From: "50r3n.2023" <[email-masked]>
Date: Wed, 13 Sep 2023 08:48:35 +0100

Sent with Proton Mail secure email.

------- Original Message -------

> It is probably ~/.local/share/xorg/Xorg.1.log.old

Hi Mark
Contents of ~/.local/share/xorg/Xorg.1.log.old 

[   314.294] 
X.Org X Server 1.21.1.7
X Protocol Version 11, Revision 0
[   314.294] Current Operating System: Linux devuan5 6.1.0-12-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.52-1 (2023-09-07) x86_64
[   314.294] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.1.0-12-amd64 root=UUID=f3aa871a-87fa-4176-9207-25f7c5b1df79 ro quiet
[   314.295] xorg-server 2:21.1.7-3devuan2~exp1 (https://www.devuan.org/os/community) 
[   314.295] Current version of pixman: 0.42.2
[   314.295] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   314.295] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   314.296] (==) Log file: "/home/soren/.local/share/xorg/Xorg.1.log", Time: Wed Sep 13 15:58:38 2023
[   314.296] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   314.296] (==) No Layout section.  Using the first Screen section.
[   314.296] (==) No screen section available. Using defaults.
[   314.296] (**) |-->Screen "Default Screen Section" (0)
[   314.296] (**) |   |-->Monitor "<default monitor>"
[   314.296] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   314.296] (==) Automatically adding devices
[   314.296] (==) Automatically enabling devices
[   314.296] (==) Automatically adding GPU devices
[   314.296] (==) Automatically binding GPU devices
[   314.296] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   314.296] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   314.296] 	Entry deleted from font path.
[   314.296] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[   314.296] (==) ModulePath set to "/usr/lib/xorg/modules"
[   314.296] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   314.296] (II) Loader magic: 0x55cea5487ea0
[   314.296] (II) Module ABI versions:
[   314.296] 	X.Org ANSI C Emulation: 0.4
[   314.296] 	X.Org Video Driver: 25.2
[   314.296] 	X.Org XInput driver : 24.4
[   314.296] 	X.Org Server Extension : 10.0
[   314.296] (++) using VT number 1

[   314.296] (II) seatd_libseat init
[   314.297] (II) [libseat/libseat.c:73] Seat opened with backend 'seatd'
[   314.297] (II) [libseat/backend/seatd.c:212] Enabling seat
[   314.297] (II) seatd_libseat enable
[   314.297] (II) seatd_libseat handled 2 events
[   314.397] (II) seatd_libseat client activated
[   314.397] (II) xfree86: Adding drm device (/dev/dri/card0)
[   314.397] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card0
[   314.397] (II) seatd_libseat try open graphics /dev/dri/card0
[   314.397] (II) seatd_libseat opened graphics: /dev/dri/card0 (1:12)
[   314.398] (--) PCI:*(0@0:2:0) 15ad:0405:15ad:0405 rev 0, Mem @ 0xe0000000/16777216, 0xf0000000/2097152, I/O @ 0x0000d010/16, BIOS @ 0x????????/131072
[   314.398] (II) LoadModule: "glx"
[   314.399] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   314.399] (II) Module glx: vendor="X.Org Foundation"
[   314.399] 	compiled for 1.21.1.7, module version = 1.0.0
[   314.399] 	ABI class: X.Org Server Extension, version 10.0
[   314.399] (==) Matched vmware as autoconfigured driver 0
[   314.399] (==) Matched modesetting as autoconfigured driver 1
[   314.399] (==) Matched fbdev as autoconfigured driver 2
[   314.399] (==) Matched vesa as autoconfigured driver 3
[   314.399] (==) Assigned the driver to the xf86ConfigLayout
[   314.399] (II) LoadModule: "vmware"
[   314.399] (WW) Warning, couldn't open module vmware
[   314.399] (EE) Failed to load module "vmware" (module does not exist, 0)
[   314.399] (II) LoadModule: "modesetting"
[   314.399] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   314.399] (II) Module modesetting: vendor="X.Org Foundation"
[   314.399] 	compiled for 1.21.1.7, module version = 1.21.1
[   314.399] 	Module class: X.Org Video Driver
[   314.399] 	ABI class: X.Org Video Driver, version 25.2
[   314.399] (II) LoadModule: "fbdev"
[   314.399] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   314.399] (II) Module fbdev: vendor="X.Org Foundation"
[   314.399] 	compiled for 1.21.1.3, module version = 0.5.0
[   314.399] 	Module class: X.Org Video Driver
[   314.399] 	ABI class: X.Org Video Driver, version 25.2
[   314.399] (II) LoadModule: "vesa"
[   314.400] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   314.400] (II) Module vesa: vendor="X.Org Foundation"
[   314.400] 	compiled for 1.21.1.3, module version = 2.5.0
[   314.400] 	Module class: X.Org Video Driver
[   314.400] 	ABI class: X.Org Video Driver, version 25.2
[   314.400] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   314.400] (II) FBDEV: driver for framebuffer: fbdev
[   314.400] (II) VESA: driver for VESA chipsets: vesa
[   314.400] xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)
[   314.400] (II) modeset(0): using drv /dev/dri/card0
[   314.400] (WW) Falling back to old probe method for fbdev
[   314.400] (II) Loading sub module "fbdevhw"
[   314.400] (II) LoadModule: "fbdevhw"
[   314.400] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   314.400] (II) Module fbdevhw: vendor="X.Org Foundation"
[   314.400] 	compiled for 1.21.1.7, module version = 0.0.2
[   314.400] 	ABI class: X.Org Video Driver, version 25.2
[   314.400] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   314.400] (II) modeset(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   314.400] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[   314.400] (==) modeset(0): RGB weight 888
[   314.400] (==) modeset(0): Default visual is TrueColor
[   314.400] (II) Loading sub module "glamoregl"
[   314.400] (II) LoadModule: "glamoregl"
[   314.400] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[   314.402] (II) Module glamoregl: vendor="X.Org Foundation"
[   314.402] 	compiled for 1.21.1.7, module version = 1.0.1
[   314.402] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   314.426] (II) modeset(0): Refusing to try glamor on llvmpipe
[   314.427] (II) modeset(0): glamor initialization failed
[   314.427] (II) modeset(0): ShadowFB: preferred NO, enabled NO
[   314.427] (II) modeset(0): Output Virtual-1 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-2 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-3 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-4 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-5 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-6 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-7 has no monitor section
[   314.427] (II) modeset(0): Output Virtual-8 has no monitor section
[   314.427] (II) modeset(0): EDID for output Virtual-1
[   314.427] (II) modeset(0): Printing probed modes for output Virtual-1
[   314.427] (II) modeset(0): Modeline "800x600"x60.0   42.75  800 850 900 950  600 650 700 750 -hsync +vsync (45.0 kHz eP)
[   314.427] (II) modeset(0): Modeline "2560x1600"x60.0  348.50  2560 2752 3032 3504  1600 1603 1609 1658 -hsync +vsync (99.5 kHz e)
[   314.427] (II) modeset(0): Modeline "2560x1440"x60.0  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync (88.8 kHz e)
[   314.427] (II) modeset(0): Modeline "1920x1440"x60.0  234.00  1920 2048 2256 2600  1440 1441 1444 1500 -hsync +vsync (90.0 kHz e)
[   314.427] (II) modeset(0): Modeline "1856x1392"x60.0  218.25  1856 1952 2176 2528  1392 1393 1396 1439 -hsync +vsync (86.3 kHz e)
[   314.427] (II) modeset(0): Modeline "1792x1344"x60.0  204.75  1792 1920 2120 2448  1344 1345 1348 1394 -hsync +vsync (83.6 kHz e)
[   314.427] (II) modeset(0): Modeline "1920x1200"x59.9  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync (74.6 kHz e)
[   314.427] (II) modeset(0): Modeline "1920x1080"x60.0  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync (67.2 kHz e)
[   314.427] (II) modeset(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
[   314.427] (II) modeset(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
[   314.427] (II) modeset(0): Modeline "1400x1050"x60.0  121.75  1400 1488 1632 1864  1050 1053 1057 1089 -hsync +vsync (65.3 kHz e)
[   314.427] (II) modeset(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[   314.427] (II) modeset(0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz e)
[   314.427] (II) modeset(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz e)
[   314.427] (II) modeset(0): Modeline "1360x768"x60.0   85.50  1360 1424 1536 1792  768 771 777 795 +hsync +vsync (47.7 kHz e)
[   314.427] (II) modeset(0): Modeline "1280x800"x59.8   83.50  1280 1352 1480 1680  800 803 809 831 +hsync -vsync (49.7 kHz e)
[   314.427] (II) modeset(0): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
[   314.427] (II) modeset(0): Modeline "1280x768"x59.9   79.50  1280 1344 1472 1664  768 771 778 798 -hsync +vsync (47.8 kHz e)
[   314.427] (II) modeset(0): Modeline "1280x720"x59.9   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync (44.8 kHz e)
[   314.427] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   314.427] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   314.427] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz e)
[   314.427] (II) modeset(0): EDID for output Virtual-2
[   314.427] (II) modeset(0): EDID for output Virtual-3
[   314.427] (II) modeset(0): EDID for output Virtual-4
[   314.427] (II) modeset(0): EDID for output Virtual-5
[   314.427] (II) modeset(0): EDID for output Virtual-6
[   314.427] (II) modeset(0): EDID for output Virtual-7
[   314.427] (II) modeset(0): EDID for output Virtual-8
[   314.427] (II) modeset(0): Output Virtual-1 connected
[   314.427] (II) modeset(0): Output Virtual-2 disconnected
[   314.427] (II) modeset(0): Output Virtual-3 disconnected
[   314.427] (II) modeset(0): Output Virtual-4 disconnected
[   314.427] (II) modeset(0): Output Virtual-5 disconnected
[   314.427] (II) modeset(0): Output Virtual-6 disconnected
[   314.427] (II) modeset(0): Output Virtual-7 disconnected
[   314.427] (II) modeset(0): Output Virtual-8 disconnected
[   314.427] (II) modeset(0): Using exact sizes for initial modes
[   314.427] (II) modeset(0): Output Virtual-1 using initial mode 800x600 +0+0
[   314.427] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[   314.427] (==) modeset(0): DPI set to (96, 96)
[   314.427] (II) Loading sub module "fb"
[   314.427] (II) LoadModule: "fb"
[   314.427] (II) Module "fb" already built-in
[   314.427] (II) UnloadModule: "fbdev"
[   314.427] (II) Unloading fbdev
[   314.427] (II) UnloadSubModule: "fbdevhw"
[   314.427] (II) Unloading fbdevhw
[   314.427] (II) UnloadModule: "vesa"
[   314.427] (II) Unloading vesa
[   314.427] (==) modeset(0): Backing store enabled
[   314.427] (==) modeset(0): Silken mouse enabled
[   314.428] (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
[   314.428] (==) modeset(0): DPMS enabled
[   314.428] (II) Initializing extension Generic Event Extension
[   314.428] (II) Initializing extension SHAPE
[   314.428] (II) Initializing extension MIT-SHM
[   314.428] (II) Initializing extension XInputExtension
[   314.428] (II) Initializing extension XTEST
[   314.428] (II) Initializing extension BIG-REQUESTS
[   314.428] (II) Initializing extension SYNC
[   314.428] (II) Initializing extension XKEYBOARD
[   314.428] (II) Initializing extension XC-MISC
[   314.428] (II) Initializing extension SECURITY
[   314.428] (II) Initializing extension XFIXES
[   314.428] (II) Initializing extension RENDER
[   314.428] (II) Initializing extension RANDR
[   314.429] (II) Initializing extension COMPOSITE
[   314.429] (II) Initializing extension DAMAGE
[   314.429] (II) Initializing extension MIT-SCREEN-SAVER
[   314.429] (II) Initializing extension DOUBLE-BUFFER
[   314.429] (II) Initializing extension RECORD
[   314.429] (II) Initializing extension DPMS
[   314.429] (II) Initializing extension Present
[   314.429] (II) Initializing extension DRI3
[   314.429] (II) Initializing extension X-Resource
[   314.429] (II) Initializing extension XVideo
[   314.429] (II) Initializing extension XVideo-MotionCompensation
[   314.429] (II) Initializing extension SELinux
[   314.429] (II) SELinux: Disabled on system
[   314.429] (II) Initializing extension GLX
[   314.429] (II) AIGLX: Screen 0 is not DRI2 capable
[   314.431] (II) IGLX: Loaded and initialized swrast
[   314.431] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[   314.431] (II) Initializing extension XFree86-VidModeExtension
[   314.431] (II) Initializing extension XFree86-DGA
[   314.431] (II) Initializing extension XFree86-DRI
[   314.431] (II) Initializing extension DRI2
[   314.432] (II) modeset(0): Damage tracking initialized
[   314.432] (II) modeset(0): Setting screen physical size to 211 x 158
[   314.447] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[   314.447] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[   314.447] (II) LoadModule: "libinput"
[   314.447] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   314.447] (II) Module libinput: vendor="X.Org Foundation"
[   314.447] 	compiled for 1.21.1.3, module version = 1.2.1
[   314.447] 	Module class: X.Org XInput Driver
[   314.447] 	ABI class: X.Org XInput driver, version 24.4
[   314.447] (II) Using input driver 'libinput' for 'Power Button'
[   314.447] (II) seatd_libseat try open /dev/input/event4
[   314.448] (II) seatd_libseat opened /dev/input/event4 (2:20)
[   314.448] (**) Power Button: always reports core events
[   314.448] (**) Option "Device" "/dev/input/event4"
[   314.448] (II) event4  - Power Button: is tagged by udev as: Keyboard
[   314.448] (II) event4  - Power Button: device is a keyboard
[   314.448] (II) event4  - Power Button: device removed
[   314.448] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event4"
[   314.448] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   314.448] (**) Option "xkb_model" "pc105"
[   314.448] (**) Option "xkb_layout" "us"
[   314.449] (II) event4  - Power Button: is tagged by udev as: Keyboard
[   314.449] (II) event4  - Power Button: device is a keyboard
[   314.449] (II) config/udev: Adding input device Sleep Button (/dev/input/event5)
[   314.449] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[   314.449] (II) Using input driver 'libinput' for 'Sleep Button'
[   314.449] (II) seatd_libseat try open /dev/input/event5
[   314.449] (II) seatd_libseat opened /dev/input/event5 (3:23)
[   314.449] (**) Sleep Button: always reports core events
[   314.449] (**) Option "Device" "/dev/input/event5"
[   314.449] (II) event5  - Sleep Button: is tagged by udev as: Keyboard
[   314.449] (II) event5  - Sleep Button: device is a keyboard
[   314.449] (II) event5  - Sleep Button: device removed
[   314.449] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSLPBN:00/input/input6/event5"
[   314.449] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 7)
[   314.449] (**) Option "xkb_model" "pc105"
[   314.449] (**) Option "xkb_layout" "us"
[   314.449] (II) event5  - Sleep Button: is tagged by udev as: Keyboard
[   314.450] (II) event5  - Sleep Button: device is a keyboard
[   314.450] (II) config/udev: Adding input device Video Bus (/dev/input/event1)
[   314.450] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[   314.450] (II) Using input driver 'libinput' for 'Video Bus'
[   314.450] (II) seatd_libseat try open /dev/input/event1
[   314.450] (II) seatd_libseat opened /dev/input/event1 (4:24)
[   314.450] (**) Video Bus: always reports core events
[   314.450] (**) Option "Device" "/dev/input/event1"
[   314.450] (II) event1  - Video Bus: is tagged by udev as: Keyboard
[   314.450] (II) event1  - Video Bus: device is a keyboard
[   314.450] (II) event1  - Video Bus: device removed
[   314.450] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input2/event1"
[   314.450] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[   314.450] (**) Option "xkb_model" "pc105"
[   314.450] (**) Option "xkb_layout" "us"
[   314.450] (II) event1  - Video Bus: is tagged by udev as: Keyboard
[   314.450] (II) event1  - Video Bus: device is a keyboard
[   314.451] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/event3)
[   314.451] (**) VirtualBox mouse integration: Applying InputClass "libinput pointer catchall"
[   314.451] (II) Using input driver 'libinput' for 'VirtualBox mouse integration'
[   314.451] (II) seatd_libseat try open /dev/input/event3
[   314.451] (II) seatd_libseat opened /dev/input/event3 (5:25)
[   314.451] (**) VirtualBox mouse integration: always reports core events
[   314.451] (**) Option "Device" "/dev/input/event3"
[   314.451] (II) event3  - VirtualBox mouse integration: is tagged by udev as: Mouse
[   314.451] (II) event3  - VirtualBox mouse integration: device is a pointer
[   314.451] (II) event3  - VirtualBox mouse integration: device removed
[   314.451] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.0/input/input4/event3"
[   314.451] (II) XINPUT: Adding extended input device "VirtualBox mouse integration" (type: MOUSE, id 9)
[   314.451] (**) Option "AccelerationScheme" "none"
[   314.451] (**) VirtualBox mouse integration: (accel) selected scheme none/0
[   314.451] (**) VirtualBox mouse integration: (accel) acceleration factor: 2.000
[   314.451] (**) VirtualBox mouse integration: (accel) acceleration threshold: 4
[   314.451] (II) event3  - VirtualBox mouse integration: is tagged by udev as: Mouse
[   314.451] (II) event3  - VirtualBox mouse integration: device is a pointer
[   314.452] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/js0)
[   314.452] (II) No input driver specified, ignoring this device.
[   314.452] (II) This device may have been added with another device file.
[   314.452] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/mouse1)
[   314.452] (II) No input driver specified, ignoring this device.
[   314.452] (II) This device may have been added with another device file.
[   314.452] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[   314.452] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[   314.452] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[   314.452] (II) seatd_libseat try open /dev/input/event0
[   314.452] (II) seatd_libseat opened /dev/input/event0 (6:26)
[   314.452] (**) AT Translated Set 2 keyboard: always reports core events
[   314.452] (**) Option "Device" "/dev/input/event0"
[   314.452] (II) event0  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[   314.452] (II) event0  - AT Translated Set 2 keyboard: device is a keyboard
[   314.452] (II) event0  - AT Translated Set 2 keyboard: device removed
[   314.452] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[   314.452] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[   314.452] (**) Option "xkb_model" "pc105"
[   314.452] (**) Option "xkb_layout" "us"
[   314.452] (II) event0  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[   314.452] (II) event0  - AT Translated Set 2 keyboard: device is a keyboard
[   314.453] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event2)
[   314.453] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "libinput pointer catchall"
[   314.453] (II) Using input driver 'libinput' for 'ImExPS/2 Generic Explorer Mouse'
[   314.453] (II) seatd_libseat try open /dev/input/event2
[   314.453] (II) seatd_libseat opened /dev/input/event2 (7:27)
[   314.453] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[   314.453] (**) Option "Device" "/dev/input/event2"
[   314.453] (II) event2  - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[   314.453] (II) event2  - ImExPS/2 Generic Explorer Mouse: device is a pointer
[   314.453] (II) event2  - ImExPS/2 Generic Explorer Mouse: device removed
[   314.453] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input3/event2"
[   314.453] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE, id 11)
[   314.453] (**) Option "AccelerationScheme" "none"
[   314.453] (**) ImExPS/2 Generic Explorer Mouse: (accel) selected scheme none/0
[   314.453] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[   314.453] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[   314.453] (II) event2  - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[   314.453] (II) event2  - ImExPS/2 Generic Explorer Mouse: device is a pointer
[   314.454] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[   314.454] (II) No input driver specified, ignoring this device.
[   314.454] (II) This device may have been added with another device file.
[   314.454] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
[   314.454] (II) No input driver specified, ignoring this device.
[   314.454] (II) This device may have been added with another device file.
[   314.461] (II) modeset(0): Allocate new frame buffer 1920x1200 stride
[   359.695] (**) Option "fd" "20"
[   359.695] (II) event4  - Power Button: device removed
[   359.695] (**) Option "fd" "23"
[   359.695] (II) event5  - Sleep Button: device removed
[   359.695] (**) Option "fd" "24"
[   359.695] (II) event1  - Video Bus: device removed
[   359.695] (**) Option "fd" "25"
[   359.695] (II) event3  - VirtualBox mouse integration: device removed
[   359.695] (**) Option "fd" "26"
[   359.695] (II) event0  - AT Translated Set 2 keyboard: device removed
[   359.695] (**) Option "fd" "27"
[   359.695] (II) event2  - ImExPS/2 Generic Explorer Mouse: device removed

---

From: Mark Hindley <[email-masked]>
Date: Wed, 13 Sep 2023 08:54:59 +0100

> Contents of ~/.local/share/xorg/Xorg.1.log.old 

[..]

> [   359.695] (II) event2  - ImExPS/2 Generic Explorer Mouse: device removed

So there is no shutdown here (hence the slow exit?).

How are you running startx? How are you terminating the running xorg?

Thanks

Mark

---

From: "50r3n.2023" <[email-masked]>
Date: Wed, 13 Sep 2023 13:44:59 +0100

------- Original Message -------
On Wednesday, September 13th, 2023 at 4:26 PM, Mark Hindley <[email-masked]> wrote:

> > [ 359.695] () Option "fd" "20"
> > [ 359.695] () Option "fd" "23"
> > [ 359.695] () Option "fd" "24"
> > [ 359.695] () Option "fd" "25"
> > [ 359.695] () Option "fd" "26"
> > [ 359.695] () Option "fd" "27"

Im trying two different window managers, icewm and jwm. This is what ive found out so far.

This is what my icewm .xinitrc looks like with the log out lag, just using icewm only.
[code]
xrdb -merge ~/.Xresources &
xrandr --output Virtual-1 --mode 1920x1200 &
(sleep 2s && exec dbus-launch --exit-with-session icewm)
[/code] 

This .xinitrc involves no lag in logging out using icewm-session
[code]
xrdb -merge ~/.Xresources &
xrandr --output Virtual-1 --mode 1920x1200 &
(sleep 2s && exec dbus-launch --exit-with-session icewm-session) 
[/code]

I need to use the sleep 2s so as to allow xresources dpi and display size to load with startx otherwise they fail to complete.

So using icewm-session solves the lag issue, using icewm only in .xinitrc the lag remains when logging out via icewm's menu.

Jwm only exits with no lag when using [jwm -exit] via the terminal and the lag remains when using jwm's menu option "log out".

Hope that helps?

---

From: Mark Hindley <[email-masked]>
Date: Wed, 13 Sep 2023 14:40:09 +0100

Control: tags -1 unreproducible

Thanks

I am afraid I am unable to reproduce this at all with either icewm, jwm or any
other wm.

> (sleep 2s && exec dbus-launch --exit-with-session icewm-session) 

This looks a bit strange to me, but I am unconvinced it is related to the
shutdown delay you experience.

I would expect to run  xrdb and xrandr in the foreground and then not bother
with the sleep or subshell.

On the off-chance that is the cause, does changing to something like this make
any difference?

 xrdb -merge ~/.Xresources 
 xrandr --output Virtual-1 --mode 1920x1200
 exec dbus-launch --exit-with-session icewm

Mark