Subject: bug#857: slim 1.4.1 auto_login window bug

From: tempforever <[email-masked]>
Date: Sat, 24 Aug 2024 20:14:09 -0400

Package: slim
Version: 1.4.1-1devuan1

devuan: excalibur

/etc/slim.conf setting:
auto_login yes

Upon slim start / auto login, a blank window is created, filling up the
desktop screen.  This does not happen with auto_login disabled.  I found
the issue in panel.cpp, the end of the file:

|// As we're only using one monitor, which is only part of the root
window, // replace Root with a viewport window Root =
XCreateSimpleWindow ( Dpy, RealRoot, result.x, result.y, result.width,
result.height, 0, 0, 0); XMapWindow(Dpy, Root); XFlush(Dpy); If those
lines are commented out, the blank window is not created even with
auto_login enabled. I don't know if that will cause a different issue,
though. I only have 1 monitor on that computer for now, I have not
tested with multiple monitors. Maybe someone who actually knows what
they are doing can fix this? |

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 17 Dec 2024 12:39:22 +0100 (MET)

I want to confirm the bug.

Devuan Excalibur always starts with a "nameless" window. This window takes 
up the entire screen, it has a black background and no scroll bar.

I hope, this will be fixed.

---

From: Mark Hindley <[email-masked]>
Date: Tue, 26 Aug 2025 15:15:56 +0100

Control: tags -1 help

Thanks.

The lines you have highlighted[1] were added upstream in version 1.4.1. I know
Rob has had health issues and is no longer active.

I have no means to check the wider effects of this change.
We need some help to test what they might be.

Mark

[1]  https://git.devuan.org/devuan/slim/src/branch/suites/unstable/panel.cpp#L957

---

From: Mark Hindley <[email-masked]>
Date: Tue, 26 Aug 2025 15:39:21 +0100

On Tue, Aug 26, 2025 at 03:15:56PM +0100, Mark Hindley wrote:
> The lines you have highlighted[1] were added upstream in version 1.4.1.

Specifically added in this svn commit:

  https://sourceforge.net/p/slim-fork/code/61/

Mark

---

From: tempforever <[email-masked]>
Date: Wed, 27 Aug 2025 12:22:34 -0400

# See attachment
diff --git a/app.h b/app.h
index 7453e34..a32dcb0 100644
--- a/app.h
+++ b/app.h
@@ -14,6 +14,7 @@
 #define _APP_H_
 
 #include <X11/Xlib.h>
+#include <string>
 
 #ifdef USE_PAM
 #include "PAM.h"
diff --git a/panel.cpp b/panel.cpp
index 7268706..e5f6c57 100644
--- a/panel.cpp
+++ b/panel.cpp
@@ -956,10 +956,10 @@ Rectangle Panel::GetPrimaryViewport()
 
 	// As we're only using one monitor, which is only part of the root window,
 	// replace Root with a viewport window
-	Root = XCreateSimpleWindow ( Dpy, RealRoot, 
-					result.x, result.y, result.width, result.height, 0, 0, 0);
-	XMapWindow(Dpy, Root);
-	XFlush(Dpy);
+//	Root = XCreateSimpleWindow ( Dpy, RealRoot, 
+//					result.x, result.y, result.width, result.height, 0, 0, 0);
+//	XMapWindow(Dpy, Root);
+//	XFlush(Dpy);
 
 	return result;
 }

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Wed, 27 Aug 2025 17:36:03 +0000

This is an automatic notification regarding your bug report
which was filed against the slim package:

#857: slim 1.4.1 auto_login window bug

It has been closed by [email-masked].

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact [email-masked] by
replying to this email.

-- 
857: https://bugs.devuan.org/cgi/bugreport.cgi?bug=857
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: #857: fixed in src:slim version 1.4.1-1devuan2
From: [email-masked]
To: [email-masked]
Date: Wed, 27 Aug 2025 17:33:53 +0000

Version: 1.4.1-1devuan2

Source package slim (1.4.1-1devuan2) added to Devuan suite unstable.

This closes bug report 857.

Thanks

DAK managing the Devuan archive

Format: 1.8
Date: Wed, 27 Aug 2025 17:39:25 +0100
Source: slim
Architecture: source
Version: 1.4.1-1devuan2
Distribution: unstable
Urgency: medium
Maintainer: Devuan Dev Team <[email-masked]>
Changed-By: Mark Hindley <[email-masked]>
Closes: 857
Changes:
 slim (1.4.1-1devuan2) unstable; urgency=medium
 .
   [ tempforever ]
   * Patch to fix auto_login regression introduced in 1.4.1. (Closes: #857)
 .
   [ Mark Hindley ]
   * app.h: add missing include to fix FTBFS.
   * d/control: bump Standards Version (no changes).
Checksums-Sha1:
 09ed35ea52ffb8fb171310748d2227234450b195 1814 slim_1.4.1-1devuan2.dsc
 f6ded9ff71314882c9486367309ccf2c4dca51b1 34356 slim_1.4.1-1devuan2.debian.tar.xz
 bd0701173890d77403b75f1fb45a13c1f7c92a90 5582 slim_1.4.1-1devuan2_source.buildinfo
Checksums-Sha256:
 824f7933556ebacffd5142f64f4e9008a6e83acea8c201bfe9ba51c25e801acc 1814 slim_1.4.1-1devuan2.dsc
 7648e8a1d1e9018364abae29ad2cf7725b8077535e2fb0f07acca1bbcbde269b 34356 slim_1.4.1-1devuan2.debian.tar.xz
 aaf135d08f8174c4d820c0c4617a7ae63c60b59b3155b5848fab6243421d0707 5582 slim_1.4.1-1devuan2_source.buildinfo
Files:
 b2915549d9e20c959bd00841c149fed5 1814 x11 optional slim_1.4.1-1devuan2.dsc
 25379621fef7661e16690705243e37c0 34356 x11 optional slim_1.4.1-1devuan2.debian.tar.xz
 6bced7ff09ce5229d0cfdfbd6b5d384a 5582 x11 optional slim_1.4.1-1devuan2_source.buildinfo

Subject: slim 1.4.1 auto_login window bug
From: tempforever <[email-masked]>
To: [email-masked]
Date: Sat, 24 Aug 2024 20:14:09 -0400

Package: slim
Version: 1.4.1-1devuan1

devuan: excalibur

/etc/slim.conf setting:
auto_login yes