Subject: bug#867: eudev: Undeclared conflict

From: Mark Hindley <[email-masked]>
Date: Sat, 14 Dec 2024 22:11:47 +0000

Package: eudev
Version: 3.2.14-2
Severity: normal
Control: affects -1 mdadm

Boian,

eudev has and undeclared file conflict with systemd-dev:

Unpacking eudev (3.2.14-2) ...
dpkg: error processing archive /var/cache/apt/archives/eudev_3.2.14-2_amd64.deb (--unpack):
 trying to overwrite '/usr/share/pkgconfig/udev.pc', which is also in package systemd-dev 257-2

I suppose it needs a Conflicts, but that needs testing to ensure that
build-depends we require are still co-installable. I came across this while
debugging mdadm autopkgtest failures.

Mark.

---

From: Mark Hindley <[email-masked]>
Date: Sat, 5 Apr 2025 17:54:21 +0100

Boian,

I have been trying (again!) to get mdadm autopkgtests to be meaningful.

Is the solution here for eudev to have

Breaks: systemd-dev (>= 253.2)

The relevant changelog

systemd (253-2) experimental; urgency=medium

  * Add systemd-dev package for pkg-config files. Move systemd.pc and
    udev.pc to systemd-dev, so that packages can build-depend on a small
    package instead of the whole set of binaries. (Closes: #945922,
    #917549)

 -- Luca Boccassi <[email-masked]>  Mon, 12 Jun 2023 00:22:52 +0100

Mark

---

From: Boian Bonev <[email-masked]>
Date: Thu, 24 Apr 2025 14:43:24 +0300

I see no reason whatsoever for eudev to ship development files
(usr/share/pkgconfig/udev.pc).

Moving that file to libeudev-dev seems the proper way to go, and adding
"libeudev-dev breaks eudev" to be able to install in the proper order
and "libeudev-dev breaks systemd-dev" for avoiding co-installing
libeudev-dev and systemd-dev. Or maybe it is better to convert the last
one to conflict?

The part that I didn't verify is how the packages that require udev.pc
are declaring that dependency - I am afraid currently it is a side
effect of something else transitively pulling in eudev.

With best regards,
b.

---

From: Mark Hindley <[email-masked]>
Date: Thu, 24 Apr 2025 18:59:47 +0100

Hi,

> effect of something else transitively pulling in eudev.

Yes, this is the less certain part. For forked sources the B-D can be
adjusted. For unforked they might use systemd-dev. So long as systemd-dev, eudev
and libeudev1 remain coinstallable, I think it is all OK.

It would be good to find a concrete example to check my thought experiment.

Mark

---

From: Mark Hindley <[email-masked]>
Date: Sat, 26 Apr 2025 07:40:24 +0100

Hi,

One further thing, the compiled udev.pc still contains an aliased path:

 udev_dir=/lib/udev

Mark

---

From: Mark Hindley <[email-masked]>
Date: Sat, 26 Apr 2025 08:22:51 +0100

> One further thing, the compiled udev.pc still contains an aliased path:

Sorry, this was perhaps a bit cryptic. This was with your current git HEAD.

Mark

---

From: Mark Hindley <[email-masked]>
Date: Tue, 6 May 2025 11:13:08 +0100

> One further thing, the compiled udev.pc still contains an aliased path:

I had a quick look at this. There is a quick hack just to edit
src/udev/udev.pc.in, but it isn't really 'correct'

udev_dir is set from $udevlibexecdir and that from $rootlibexecdir, but the
handling of configure --with-rootlibexecdir appears broken.

Can you have a look?

Thanks

Mark

---

From: "Devuan bug Tracking System" <[email-masked]>
Date: Tue, 06 May 2025 13:22:03 +0000

This is an automatic notification regarding your bug report
which was filed against the eudev package:

#867: eudev: Undeclared conflict

It has been closed by [email-masked].

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact [email-masked] by
replying to this email.

-- 
867: https://bugs.devuan.org/cgi/bugreport.cgi?bug=867
Devuan Bug Tracking System
Contact [email-masked] with problems

Subject: #867: fixed in src:eudev version 3.2.14-3
From: [email-masked]
To: [email-masked]
Date: Tue, 06 May 2025 13:20:12 +0000

Version: 3.2.14-3

Source package eudev (3.2.14-3) added to Devuan suite unstable.

This closes bug report 867.

Thanks

DAK managing the Devuan archive

Format: 1.8
Date: Wed, 23 Apr 2025 22:35:00 +0000
Source: eudev
Architecture: source
Version: 3.2.14-3
Distribution: unstable
Urgency: medium
Maintainer: Devuan Dev Team <[email-masked]>
Changed-By: Boian Bonev <[email-masked]>
Closes: 867 885
Changes:
 eudev (3.2.14-3) unstable; urgency=medium
 .
   * Bump standards to 4.7.2
     - install in non-aliased locations (Closes: #885)
   * Replace pkg-config with pkgconf
   * Update GPL obtaining instructions
   * Update copyright years
   * Add upstream signing key
   * Move usr/share/pkgconfig/udev.pc to libeudev-dev (Closes: #867)
Checksums-Sha1:
 527ea66e5f51b176cbfb3a1753a6e93940790a1c 2379 eudev_3.2.14-3.dsc
 7c03650274424a474e8d8bc96f4bd14fae87c0f8 67728 eudev_3.2.14-3.debian.tar.xz
 bbe5dd338f04fcb385016e336258011237c845d0 5412 eudev_3.2.14-3_source.buildinfo
Checksums-Sha256:
 67715dd0c1d24a6ed2556669de8d18fad057e4b59a541f388ef31192a08964b1 2379 eudev_3.2.14-3.dsc
 8a272a04ff1842e310fd4f8a52e2e47bd70e9b0b4d74c2c04205cc2344e789db 67728 eudev_3.2.14-3.debian.tar.xz
 63d9481a01096ef2c330bacdc2e141a63e9fa57788ca05074affbaf34b9c123b 5412 eudev_3.2.14-3_source.buildinfo
Files:
 13c28d8321ffe96b620e90d7bd78d2f7 2379 admin optional eudev_3.2.14-3.dsc
 053422653ad7c310a3fac312f0a2f682 67728 admin optional eudev_3.2.14-3.debian.tar.xz
 0ae94a87b33190a423d02b806ab5ec37 5412 admin optional eudev_3.2.14-3_source.buildinfo

Subject: eudev: Undeclared conflict
From: Mark Hindley <[email-masked]>
To: Devuan Bug Tracking System <[email-masked]>
Date: Sat, 14 Dec 2024 22:11:47 +0000

Package: eudev
Version: 3.2.14-2
Severity: normal

Boian,

Mark.