Subject: orphan-sysvinit-scripts: please include scripts for kexec-tools

From: Arthur Marsh <[email-masked]>
Date: Wed, 01 Jan 2025 00:02:34 +1030

Package: orphan-sysvinit-scripts
Version: 0.17
Severity: wishlist

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

package kexec-tools no longer includes init-scripts

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 6 (excalibur/ceres)
Release:	6
Codename:	excalibur ceres
Architecture: x86_64

Kernel: Linux 6.13.0-rc5+ (SMP w/4 CPU threads; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB
Shell: /bin/sh linked to /usr/bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages orphan-sysvinit-scripts depends on:
ii  ucf  3.0046

orphan-sysvinit-scripts recommends no packages.

orphan-sysvinit-scripts suggests no packages.

-- no debconf information

---

From: Mark Hindley <[email-masked]>
Date: Tue, 31 Dec 2024 13:50:35 +0000

Control: tags -1 debian

Arthur,

Thanks. However, I am not sure this is necessary or required. The relevant
changelog entry says

   Package now provides a script - kexec-load-kernel. To perform a kexec reboot,
   ensure /etc/default/kexec has the desired value for USE_GRUB_CONFIG. Use the
   sequence "kexec-load-kernel; systemctl kexec" or "kexec-load-kernel; reboot"

I think there is no initscript anymore. There are no systemd unit files either.

If you really think there is something for orphan-sysvinit-scripts to include,
note that Devuan does not fork orphan-sysvinit-scripts and uses Debian's
packages directly without recompilation. So this shoudl be reported to Debian's
BTS.

Thanks

Mark

---

From: Mark Hindley <[email-masked]>
Date: Thu, 30 Jan 2025 07:28:04 +0000

On Tue, Dec 31, 2024 at 01:50:36PM +0000, Mark Hindley wrote:
> Control: tags -1 debian
> 
> Arthur,
> 
> Thanks. However, I am not sure this is necessary or required.

I don't think there is anything to be done here, so closing.

Do reopen in Debian's BTS if I have missed something.

Thanks

Mark

---

From: Mark Hindley <[email-masked]>
Date: Fri, 22 Aug 2025 17:22:18 +0100

Control: reopen -1
Control: forwarded -1 http://bugs.debian.org/1111737

> Do reopen in Debian's BTS if I have missed something.

I was premature and the same issue has surfaced in Debian.
Reopening.

Mark