Devuan bug report logs - #175
The eudev package doesn't provide expected udev

Package: eudev; Reported by: Alexei Sorokin <sor.alexei@meowr.ru>; Done: KatolaZ <katolaz@freaknet.org>; Maintainer for eudev is (unknown).


Message received at 175@bugs.devuan.org:


Received: (at 175) by bugs.devuan.org; 20 Mar 2018 08:20:04 +0000
From: Idar <idart@hotmail.com>
To: "175@bugs.devuan.org" <175@bugs.devuan.org>
Subject: Broke upgrade
Date: Tue, 20 Mar 2018 08:12:53 +0000

Hmmm... I think this change may have
caused the following upgrade snafu:


Setting up eudev (3.2.2-12) ...
insserv: script eudev: service udev already provided!
[ ok ] Stopping the hotplug events dispatcher: udevd.
[ ok ] Starting the hotplug events dispatcher: udevd.

*******************************************************
  Warning: eudev will default to the older network
  interface names, such as eth0 or wlan0. If you use
  the new names, such as enp0s3, you will need to add
  the following to the boot command:
                net.ifnames=3D1
********************************************************

update-initramfs: deferring update (trigger activated)
insserv: script eudev: service udev already provided!
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package eudev (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-6-amd64
I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=3D601cd31c-7907-4959-82a6-2deae047b12a)
I: Set the RESUME variable to override this.
Errors were encountered while processing:
 eudev
E: Sub-process /usr/bin/dpkg returned an error code (1)




Acknowledgement sent to Idar <idart@hotmail.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.


Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#175; Package eudev. Full text available.


Message received at 175-done@bugs.devuan.org:


Received: (at 175-done) by bugs.devuan.org; 16 Mar 2018 19:30:06 +0000
Date: Fri, 16 Mar 2018 19:20:30 +0000
From: KatolaZ <katolaz@freaknet.org>
To: 175-done@bugs.devuan.org
Subject: Fixed


--S5Rg6oz6PtEXgjQf
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

Fixed in eudev-3.2.2-12

--S5Rg6oz6PtEXgjQf
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlqsGP4ACgkQXyCzrgtfBi/ZfACeJ5+4mvRwuOhv+/Zyq51hjt2z
1RYAniIU3WxKIn0zLOfB3fMyrz6k2sbK
=iInl
-----END PGP SIGNATURE-----

--S5Rg6oz6PtEXgjQf--


Notification sent to Alexei Sorokin <sor.alexei@meowr.ru>:
bug acknowledged by developer. Full text available.


Reply sent to KatolaZ <katolaz@freaknet.org>:
You have taken responsibility. Full text available.


Message received at 175@bugs.devuan.org:


Received: (at 175) by bugs.devuan.org; 8 Mar 2018 12:10:03 +0000
Subject: New version of eudev available: 3.2.2-12
From: Svante Signell <svante.signell@gmail.com>
To: 175@bugs.devuan.org
Date: Thu, 08 Mar 2018 13:02:55 +0100

Hi,

Can you try to see if the latest version of eudev (3.2.2-12) solves your
problems. Unfortunately I cannot reproduce your problems running OpenRC in a VM.

Thanks!



Acknowledgement sent to svante.signell@gmail.com:
Extra info received and forwarded to list. Copy sent to owner@bugs.devuan.org. Full text available.


Information forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#175; Package eudev. Full text available.


Message received at maintonly@bugs.devuan.org:


Received: (at maintonly) by bugs.devuan.org; 16 Jan 2018 16:40:04 +0000
Date: Tue, 16 Jan 2018 19:32:13 +0300
From: Alexei Sorokin <sor.alexei@meowr.ru>
To: maintonly@bugs.devuan.org
Subject: The eudev package doesn't provide expected udev

Package: eudev
Version: 3.2.2-9

I'm using OpenRC on Devuan ascii.
It seems that there's a race condition between mountdevsubfs.sh and 
eudev on
boot which is probably due to "# Should-Start: udev" there not firing 
for
eudev, resulting in /dev/pts/ and /dev/shm/ not populating.
If I change "# Provides: eudev" to "# Provides: eudev udev" in
/etc/init.d/eudev, /dev/pts/ and /dev/shm/ populate fine so I conclude 
that
either the eudev package should provide "udev" or initscripts should 
rather
expect eudev than udev.

Thanks.


Acknowledgement sent to Alexei Sorokin <sor.alexei@meowr.ru>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.


Report forwarded to owner@bugs.devuan.org:
bug#175; Package eudev. Full text available.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sat, 18 Aug 2018 16:39:01 UTC