Devuan bug report logs - #248
Pip3 can't list outdated packages.

Package: python3-pip; Reported by: =?UTF-8?B?zpPOuc+Oz4HOs86/z4IgzprPic+Dz4TPjM+Azr/Phc67zr/Pgg==?= <giorgosk67@gmail.com>; dated Sat, 13 Oct 2018 16:33:01 UTC; Maintainer for python3-pip is (unknown).

Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 13 Oct 2018 16:20:02 +0000
Return-Path: <giorgosk67@gmail.com>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Sat, 13 Oct 2018 18:20:02 +0200 (CEST)
Received: from mail-it1-f173.google.com (mail-it1-f173.google.com [209.85.166.173])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	(No client certificate requested)
	by vm6.ganeti.dyne.org (Postfix) with ESMTPS id 18A9EF608A5
	for <submit@bugs.devuan.org>; Sat, 13 Oct 2018 18:13:05 +0200 (CEST)
Authentication-Results: vm6.ganeti.dyne.org;
	dkim=pass (2048-bit key; unprotected) header.d=gmail.com header.i=@gmail.com header.b="E6v45Jgi";
	dkim-atps=neutral
Received: by mail-it1-f173.google.com with SMTP id q70-v6so23087884itb.3
        for <submit@bugs.devuan.org>; Sat, 13 Oct 2018 09:12:38 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
        h=mime-version:from:date:message-id:subject:to;
        bh=u0HtxclO9dlImhTtWVk9/I/oXaBzJYmHJ9hoS9EOixY=;
        b=E6v45Jgi1509l0cYPKNhRlhxf96MJ5f+O3Ilee61/ld/h+yv86yQPf9N9Qh/HKzjHq
         qLeD/cyWCJIUBsHKddS+1eoHoajqL/xm/BrnIcgxq4LVkpT7EdEGu014lujQGL3ts8fa
         ledA9RvGSaRNxRSbiD+hDFZrlkHlpUIdkgA3gC3W8TLlC1J0jt1SZSYxVLWmdgLaZ8o+
         EmOPibu7VvvJvjnm0sjYt3WSIsPBZSz/II9EJtW9noWme0IwimSe1fI3rLZvMbz5uYNG
         4ioIW09VBWFK8X9r59pB2Bq25ZIO8bt23o8u3TY9Oh7XnQ9ybDyujDIC9VQiE+rBq/mq
         zElQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:from:date:message-id:subject:to;
        bh=u0HtxclO9dlImhTtWVk9/I/oXaBzJYmHJ9hoS9EOixY=;
        b=UjNWRLtuoL+stws6GaaY/sM2qhvPyEteioMFqx3hEQ0H0DF6O7bpwvqX8FxMo3gUGi
         aB/op2/DWRB6eqL5++7FkCKKx5SgPQTW+IyNtUk1c8hpgiNLTscW/We54A3olegET1QZ
         q+/nVmThcX0t9TXpcPV8MVxbyVMzkiOP0kz1Nrn7rwrs+FA3q63otV5Gg/Kl5h+kCW3U
         ggI0zF8RhCs/NRa5BkQlepsUJ2skugc+tIng4ea3kGtZbyJmApHLC8CgR4aAJDy3/u4l
         4jAfQwGO1Wh0d6FyaPjpf7N0uauGcePHuEYtoDmroyzNgc5PkoP7J0oju52jxmk3aFof
         8BSg==
X-Gm-Message-State: ABuFfoghI9jf0SUf7rU5e0aeHJ9AXtlTqwkkJXxnOVw29ecIQXAVowPu
	9daixPU5fnc5m6Y8JdF28rkdKwik9vele2fpXfwGSP+QY1E=
X-Google-Smtp-Source: ACcGV61uPsL1YaD6LVVM/rMDUkkr7vm/i0CF7CRUpJSKbpeXOxi3+Bo7xb6hsgqW7qoAPvGPgoDsIcndyCD8P6jk6Jw=
X-Received: by 2002:a02:8544:: with SMTP id g62-v6mr8701152jai.53.1539447156692;
 Sat, 13 Oct 2018 09:12:36 -0700 (PDT)
MIME-Version: 1.0
From: =?UTF-8?B?zpPOuc+Oz4HOs86/z4IgzprPic+Dz4TPjM+Azr/Phc67zr/Pgg==?= <giorgosk67@gmail.com>
Date: Sat, 13 Oct 2018 19:12:03 +0300
Message-ID: <CABhBvQsRkUYcn_8-wC7cowxbSkja-3j0u7m2dib+J641mj4OkA@mail.gmail.com>
Subject: Pip3 can't list outdated packages.
To: submit@bugs.devuan.org
Content-Type: text/plain; charset="UTF-8"
X-Spam-Status: No, score=-2.6 required=5.0 tests=DKIM_SIGNED,DKIM_VALID,
	DKIM_VALID_AU,FREEMAIL_ENVFROM_END_DIGIT,FREEMAIL_FROM,RCVD_IN_DNSWL_NONE,
	RCVD_IN_MSPIKE_H2,SPF_PASS autolearn=disabled version=3.4.1
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on tupac3.dyne.org

Package: python3-pip
Version: 9.0.1-2

Pip3 fails to locate packages, needs updating.
Trying to do that, throws an exception.

Please take a look, at the following console output:
>pip3 list -o
Exception:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/usr/lib/python3/dist-packages/pip/commands/list.py", line 157, in run
    packages = self.get_outdated(packages, options)
  File "/usr/lib/python3/dist-packages/pip/commands/list.py", line
168, in get_outdated
    dist for dist in self.iter_packages_latest_infos(packages, options)
  File "/usr/lib/python3/dist-packages/pip/commands/list.py", line
169, in <listcomp>
    if dist.latest_version > dist.parsed_version
TypeError: unorderable types: Version() > SetuptoolsVersion()
>

On ASCII x64 KDE.


Acknowledgement sent to =?UTF-8?B?zpPOuc+Oz4HOs86/z4IgzprPic+Dz4TPjM+Azr/Phc67zr/Pgg==?= <giorgosk67@gmail.com>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.
Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#248; Package python3-pip. Full text available.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 2 Jun 2020 02:39:02 UTC