Devuan bug report logs - #318
pulseaudio: autospawn is required on Beowulf (Ceres)

Package: pulseaudio; Reported by: Gour <gour@atmarama.com>; dated Fri, 19 Apr 2019 05:03:01 UTC; Maintainer for pulseaudio is (unknown).


Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 19 Apr 2019 04:50:08 +0000
Date: Fri, 19 Apr 2019 06:49:20 +0200
From: Gour <gour@atmarama.com>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: pulseaudio: autospawn is required on Beowulf (Ceres)

--Sig_/eXSDtCePdDgp1agd/8r_wEr
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: quoted-printable

Package: pulseaudio
Version: 12.2-4
Severity: important

Dear Maintainer,

   * What led up to the situation?

   I've PulseAudio selected as 'autostart', but there is no sound.

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

   * What was the outcome of this action?

   Inspecting my Beowulf system I noticed that only this was running:

   /usr/lib/x86_64-linux-gnu/xfce4/panel/wrapper-2.0 /usr/lib/x86_64-linux-
gnu/xfce4/panel/plugins/libpulseaudio-plugin.so 21 18874412 pulseaudio
PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system

   Moreover, attempt to start pavucontrol or mixer from the Xfce panel
   results in the mixer hanging with ""Establishing connection to
   PulseAudio" message.

   * What outcome did you expect instead?

   Running pulseaudio and working sound.

    However, I've found the solution to the problem by browsing Debian's
    bugtracker - see:
    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=3D923203

    So, solution, for Beowulf and probably Ceres is to uncomment

    #00-disable-autospawn.conf

    line in $ /etc/pulse/client.conf.d/00-disable-autospawn.conf

    and then pulseaudio is correctly started as it is visible by:

    $ ps ax | grep pulse
 3587 ?        Sl
    0:03 /usr/lib/x86_64-linux-gnu/xfce4/panel/wrapper-2.0 /usr/lib/x86_64-=
linux-gnu/xfce4/panel/plugins/libpulseaudio-plugin.so
    21 18874412 pulseaudio PulseAudio Plugin Adjust the audio volume of
    the PulseAudio sound system
 3614 ?        S<l    0:00 /usr/bin/pulseaudio --start
    --log-target=3Dsyslog




-- Package-specific info:
File '/etc/default/pulseaudio' does not exist


-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux beowulf/ceres
Release:	10
Codename:	n/a
Architecture: x86_64

Kernel: Linux 4.19.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=3Dhr_HR.UTF-8, LC_CTYPE=3Dhr_HR.UTF-8 (charmap=3DUTF-8),
LANGUAGE=3Den_GB:en (charmap=3DUTF-8) Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages pulseaudio depends on:
ii  adduser                      3.118
ii  libasound2                   1.1.8-1
ii  libasound2-plugins           1.1.8-1
ii  libc6                        2.28-8
ii  libcap2                      1:2.25-2
ii  libdbus-1-3                  1.12.12-1+devuan2
ii  libgcc1                      1:8.3.0-6
ii  libice6                      2:1.0.9-2
ii  libltdl7                     2.4.6-9
ii  liborc-0.4-0                 1:0.4.28-3.1
ii  libpulse0                    12.2-4
ii  libsm6                       2:1.2.3-1
ii  libsndfile1                  1.0.28-6
ii  libsoxr0                     0.1.2-3
ii  libspeexdsp1                 1.2~rc1.2-1+b2
ii  libstdc++6                   8.3.0-6
ii  libsystemd0                  241-3
ii  libtdb1                      1.3.16-2+b1
pn  libudev1                     <none>
ii  libwebrtc-audio-processing1  0.3-1
ii  libx11-6                     2:1.6.7-1
ii  libx11-xcb1                  2:1.6.7-1
ii  libxcb1                      1.13.1-2
ii  libxtst6                     2:1.2.3-1
ii  lsb-base                     10.2019031300
ii  pulseaudio-utils             12.2-4

Versions of packages pulseaudio recommends:
pn  dbus-user-session                <none>
ii  libpam-elogind [libpam-systemd]  234.4-2
ii  rtkit                            0.11-6

Versions of packages pulseaudio suggests:
pn  paman        <none>
pn  paprefs      <none>
ii  pavucontrol  3.0-4
pn  pavumeter    <none>
ii  udev         1:3.2.7+devuan1.1

-- no debconf information



--=20

--Sig_/eXSDtCePdDgp1agd/8r_wEr
Content-Type: application/pgp-signature
Content-Description: OpenPGP digital signature

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEWDpE0TZF+khoOctpNyVpzrf8dgUFAly5U1AACgkQNyVpzrf8
dgVQGhAAqUSLwxn/OCD6wHw7ayeq+QOh6pXVdCByLItIruX4znHJp6y8hMihnFsr
+ey+sd8QmkMMIikZ4gsc3E4/o3X8ORDovHTAaPh8NoxvdlzHF48Ml4S1XPYfKeet
gfaroEcZQmS+Nw8Fq7qZuPaX2GHT4tzFu5A6r6S+BhGiULD7eGE+hVmOvq4nRU2n
AGDqvmOzcruGHNnmmR4EyWw7qWwNjmDP49NV8OO1ecD1UUm1TpN2/4OyqiTy7oRO
/xPa+LAdn3+scd8Izs3WXgVgf9Kpx6rQoKZyOHn0y4AOpJ7vwdn8s4Rw97qwg18E
QZdUu1oN6ERXWt/leDaWCtMR1tOpxTlRwt8UZEMEaG3uqlN++EaIVwuAGLtvwhPM
GUCTVx3GyipBgyH0E8pi+6On8woYiOBYYTh4iFDUYhx84cCNRJpn7RZVQsaKJd12
SLXJmK8Bwl18t3aK5BrpgDNSwzbDb+ypTQZ6XxQvUqWb6+RdPF6rE0Ly+aC+SW/Z
iHpz+lPkmZf/+0mpQdG3Wu7L+eLV8z7A1nAAAjcQRz8kZkaJB+Wi3UMuwKhnUksq
MjJQoTrZYAn/qFLnzQIVmI3FwEiUW6/RQqcdTPAUWAg3nMFswr0m8O/wJs3Cthhc
reYnq7JOsbnqYDgQteoIeNlzKzr9anhUiQm5C7R/Hny7Gi0V6Mk=
=VBNR
-----END PGP SIGNATURE-----

--Sig_/eXSDtCePdDgp1agd/8r_wEr--


Acknowledgement sent to Gour <gour@atmarama.com>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org.

Your message specified a Severity: in the pseudo-header, but the severity value important was not recognised. The default severity normal is being used instead. The recognised values are: critical, grave, normal, minor, wishlist.

Full text available.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#318; Package pulseaudio. Full text available.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue, 18 Jun 2019 06:39:01 UTC