Devuan bug report logs - #332
CephFS in fstab

Package: ceph-fs-common; Reported by: Geoffray Levasseur <geoffray.levasseur@legos.obs-mip.fr>; dated Tue, 11 Jun 2019 11:03:01 UTC; Maintainer for ceph-fs-common is (unknown).

Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 11 Jun 2019 10:50:05 +0000
Return-Path: <geoffray.levasseur@legos.obs-mip.fr>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Tue, 11 Jun 2019 12:50:05 +0200 (CEST)
Received: from smtp-out1.legos.obs-mip.fr (smtp-out1.legos.obs-mip.fr [195.220.93.51])
	by vm6.ganeti.dyne.org (Postfix) with ESMTP id 09A59F60EB8
	for <submit@bugs.devuan.org>; Tue, 11 Jun 2019 12:48:34 +0200 (CEST)
Received: from smtp.legos.obs-mip.fr (smtp.legos.obs-mip.fr [10.6.101.60])
	by smtp-out1.legos.obs-mip.fr (Postfix) with ESMTP id 70ECC9962
	for <submit@bugs.devuan.org>; Tue, 11 Jun 2019 12:48:33 +0200 (CEST)
Received: from pc-levasseur.localnet (pc-levasseur.legos.obs-mip.fr [10.3.1.52])
	by smtp.legos.obs-mip.fr (Postfix) with ESMTPS id 6C0A9449
	for <submit@bugs.devuan.org>; Tue, 11 Jun 2019 12:48:33 +0200 (CEST)
From: Geoffray Levasseur <geoffray.levasseur@legos.obs-mip.fr>
To: submit@bugs.devuan.org
Subject: CephFS in fstab
Date: Tue, 11 Jun 2019 12:48:33 +0000
Message-ID: <2559382.rRp93VLO8l@pc-levasseur>
Organization: LEGOS
User-Agent: KMail/4.14.1 (Linux/4.9.0-0.bpo.6-amd64; KDE/4.14.2; x86_64; ; )
MIME-Version: 1.0
Content-Transfer-Encoding: 7Bit
Content-Type: text/plain; charset="us-ascii"
X-Spam-Status: No, score=-0.0 required=5.0 tests=RCVD_IN_DNSWL_NONE,SPF_PASS
	autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org

Package: ceph-fs-common
Version: 10.2.11-2

Hi,

I'm running CephFS filesystem on Proxmox servers. Virtual machines runs Devuan 
ASCII or Devuan Beowulf. Almost all the virtual machines will need access to a 
CephFS storage, and services like Apache or nsd will require access to CephFS 
to run.

So I've put CephFS entry in fstab with an existing mount point not forgetting 
the _netdev option. Manual mount with "mount /mountpoint" works just 
perfectly.

At start-up, the mount is not done and services that depends on it are failing 
to start.

I had the same issue with GlusterFS. NFS in an other hand works perfectly, 
thanks to a dedicated script called (as far as I remember) nfs-mount in 
/etc/init.d.

I think the nfs-mount startup script should be renamed net-mount and any 
_netdev optioned entry in fstab should be mounted by it. Elsewhere, other 
network filesystem should come with dedicated mount script or a sample script 
in documentation.

Thank you,
-- 
Geoffray Levasseur
Technicien UPS - UMR CNRS 5566 / LEGOS - Service Informatique
        <geoffray.levasseur@legos.obs-mip.fr>
        <fatalerrors@geoffray-levasseur.org>
        http://www.geoffray-levasseur.org/
GNU/PG public key : C89E D6C4 8BFC C9F2 EEFB 908C 89C2 CD4D CD9E 23AA
Quod gratis asseritur gratis negatur.


Acknowledgement sent to Geoffray Levasseur <geoffray.levasseur@legos.obs-mip.fr>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.
Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#332; Package ceph-fs-common. Full text available.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sun, 16 Jan 2022 18:39:01 UTC