Devuan bug report logs - #337
prelink: kodi binary segfaults if prelinked

Package: prelink; Reported by: Arthur Marsh <arthur.marsh@internode.on.net>; dated Tue, 25 Jun 2019 14:03:01 UTC; Maintainer for prelink is (unknown).


Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 25 Jun 2019 14:00:02 +0000
From: Arthur Marsh <arthur.marsh@internode.on.net>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: prelink: kodi binary segfaults if prelinked
Date: Tue, 25 Jun 2019 23:29:19 +0930

Package: prelink
Version: 0.0.20131005-1+b10
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

running prelink after installing kodi-bin, then attempting to run kodi 
resulted in:

[New LWP 30718]
[New LWP 30721]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/lib/x86_64-linux-gnu/kodi/kodi.bin'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x000055d4a40c4030 in ?? ()
[Current thread is 1 (Thread 0x7feb76f7f340 (LWP 30718))]

Thread 2 (Thread 0x7feb76f78700 (LWP 30721)):
#0  0x00007feb8724100c in futex_wait_cancelable (private=0, expected=0, futex_wo
rd=0x560536a71c30) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007feb8724100c in __pthread_cond_wait_common (abstime=0x0, mutex=0x56053
6a71c48, cond=0x560536a71c08) at pthread_cond_wait.c:502
#2  0x00007feb8724100c in __pthread_cond_wait (cond=0x560536a71c08, mutex=0x5605
36a71c48) at pthread_cond_wait.c:655
#3  0x0000560535893c01 in ANNOUNCEMENT::CAnnouncementManager::Process() ()
#4  0x0000560535efc27f in CThread::Action() ()
#5  0x0000560535efc39e in CThread::staticThread(void*) ()
#6  0x00007feb8723afa3 in start_thread (arg=<optimized out>) at pthread_create.c
:486
#7  0x00007feb834584cf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:
95

Thread 1 (Thread 0x7feb76f7f340 (LWP 30718)):
#0  0x000055d4a40c4030 in  ()
#1  0x0000560535d08750 in CXBMCTinyXML::SaveFile(std::__cxx11::basic_string<char
, std::char_traits<char>, std::allocator<char> > const&) const ()
#2  0x00005605359bdbb5 in CProfilesManager::Save(std::__cxx11::basic_string<char
, std::char_traits<char>, std::allocator<char> > const&) const ()
#3  0x00005605359bdce2 in CProfilesManager::Save() const ()
#4  0x0000560535a61c81 in CSettingsManager::OnSettingsSaved() const ()
#5  0x0000560535a68ca9 in CSettingsManager::Save(TiXmlNode*) const ()
#6  0x0000560535488796 in CSettings::Save(std::__cxx11::basic_string<char, std::
char_traits<char>, std::allocator<char> > const&) ()
#7  0x0000560535488b5d in CSettings::Load(std::__cxx11::basic_string<char, std::
char_traits<char>, std::allocator<char> > const&) ()
#8  0x0000560535488ba7 in CSettings::Load() ()
#9  0x0000560535ad8e8f in CApplication::Create() ()
#10 0x00005605358db34d in XBMC_Run ()
#11 0x0000560535407035 in main ()


   * What exactly did you do (or not do) that was effective (or
     ineffective)?

reinstalling kodi-bin and not running prelink, kodi then ran fine.

   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux beowulf/ceres
Release:	10
Codename:	n/a
Architecture: x86_64

Kernel: Linux 5.2.0-rc6+ (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: sysvinit (via /sbin/init)

Versions of packages prelink depends on:
ii  execstack  0.0.20131005-1+b10

prelink recommends no packages.

prelink suggests no packages.

-- Configuration Files:
/etc/prelink.conf changed:
-b *.la
-b *.png
-b *.py
-b *.pl
-b *.pm
-b *.sh
-b *.xml
-b *.xslt
-b *.a
-b *.js
-b /lib/modules
-b /usr/lib/locale
-l /usr/local/sbin
-l /sbin
-l /usr/sbin
-l /usr/local/bin
-l /bin
-l /usr/bin
-l /usr/games
-l /usr/local/lib
-l /lib
-l /usr/lib


-- no debconf information


Acknowledgement sent to Arthur Marsh <arthur.marsh@internode.on.net>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#337; Package prelink. Full text available.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Fri, 15 Nov 2019 23:39:01 UTC