Devuan bug report logs - #454
devuan-installer: beowulf beta netinstall ISO image does not configure locale or timezone

Package: devuan-installer; Reported by: Matthew T Hoare <matthew.t.hoare@gmail.com>; dated Sun, 10 May 2020 11:03:06 UTC; Maintainer for devuan-installer is (unknown).

Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 10 May 2020 11:02:30 +0000
X-Envelope-From: <matthew.t.hoare@gmail.com>
X-Envelope-To: <submit@bugs.devuan.org>
Received: from [127.0.1.1] (170.86.6.51.dyn.plus.net [51.6.86.170])
	by vm6.ganeti.dyne.org (Postfix 3.1.14/8.13.0) with SMTP id unknown
	Thu, 02 Apr 2020 16:05:27 +0200
	(envelope-from <matthew.t.hoare@gmail.com>);
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Matthew T Hoare <matthew.t.hoare@gmail.com>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: devuan-installer: beowulf beta netinstall ISO image does not configure locale or timezone
Message-ID: <158583632604.1753.15260338606466622538.reportbug@devuan>
X-Mailer: reportbug 7.5.3+devuan3
Date: Thu, 02 Apr 2020 14:05:26 +0000
X-Debbugs-Cc: matthew.t.hoare@gmail.com

Package: devuan-installer
Severity: normal
Tags: l10n

Dear Maintainer,

   * What led up to the situation?
I downloaded the Devuan beowulf beta netinstall ISO image and attempted to install a system under QEMU/KVM (Debian buster host).

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
I selected the English language, UK location and the Europe/London timezone during the installation process.

   * What was the outcome of this action?
When I booted into the new system the locale & timezone were not set: /etc/locale.gen had no un-commented lines and the timezone was set to 'Etc/UTC'.

   * What outcome did you expect instead?
I would expect that the locale would be set to the UK and the timezone would be set to Europe/London. The errors resulting from an unset locale can be seen below.


-- System Information:
Distributor ID:	Debian
Description:	Devuan GNU/Linux 3 (beowulf)
Release:	3
Codename:	beowulf
Architecture: x86_64

Kernel: Linux 4.19.0-8-amd64 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=C.UTF-8 (charmap=locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
UTF-8), LANGUAGE=en_GB:en (charmap=locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Acknowledgement sent to Matthew T Hoare <matthew.t.hoare@gmail.com>:
New bug report received and forwarded. Copy sent to matthew.t.hoare@gmail.com, Ralph Ronnquist <ralph.ronnquist@gmail.com>. Full text available.
Report forwarded to devuan-bugs@lists.dyne.org, matthew.t.hoare@gmail.com, Ralph Ronnquist <ralph.ronnquist@gmail.com>:
bug#454; Package devuan-installer. Full text available.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Sat, 4 Jul 2020 02:39:02 UTC