Devuan bug report logs - #459
autopkgtest-build-qemu does not set up /dev/ttyS[01]

Package: autopkgtest; Severity: minor; Reported by: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>; Keywords: ceres debian beowulf; dated Sat, 16 May 2020 08:18:01 UTC; Maintainer for autopkgtest is (unknown).

Message received at 459@bugs.devuan.org:


Received: (at 459) by bugs.devuan.org; 16 May 2020 10:00:02 +0000
Return-Path: <matsumoto.r.aa@m.titech.ac.jp>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by doc.devuan.org with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 16 May 2020 10:00:02 +0000 (UTC)
Received: from mail001.nap.gsic.titech.ac.jp (mail001.nap.gsic.titech.ac.jp [131.112.13.101])
	by vm6.ganeti.dyne.org (Postfix) with SMTP id 74DFDF60C8D
	for <459@bugs.devuan.org>; Sat, 16 May 2020 11:56:14 +0200 (CEST)
Received: from 172.22.40.202
	by mail001.nap.gsic.titech.ac.jp with Mail2000 ESMTP Server V7.00(2611:0:AUTH_RELAY)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 18:56:13 +0900 (JST)
Received: from mail001.nap.gsic.titech.ac.jp (mail001.nap.gsic.titech.ac.jp [131.112.13.101])
	by drweb05.nap.gsic.titech.ac.jp (Postfix) with SMTP id 02BA167C;
	Sat, 16 May 2020 18:56:13 +0900 (JST)
Received: from 114.145.251.241
	by mail001.nap.gsic.titech.ac.jp with Mail2000 ESMTPA Server V7.00(2600:0:AUTH_LOGIN)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 18:56:11 +0900 (JST)
Date: Sat, 16 May 2020 18:56:11 +0900 (JST)
Message-Id: <20200516.185611.1962218483321776546.ryutaroh@ict.e.titech.ac.jp>
To: mark@hindley.org.uk
Cc: 459@bugs.devuan.org
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
From: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>
In-Reply-To: <20200516094141.GJ32762@hindley.org.uk>
References: <20200516092947.GG32762@hindley.org.uk>
	<20200516.183326.1310545322032497068.ryutaroh@ict.e.titech.ac.jp>
	<20200516094141.GJ32762@hindley.org.uk>
X-Mailer: Mew version 6.8 on Emacs 26.3
Mime-Version: 1.0
Content-Type: Text/Plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Spam-Status: No, score=-2.3 required=5.0 tests=RCVD_IN_DNSWL_MED
	autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org

>> I don't think this is a Debian issue.
>> Debian PID 1 is systemd,
> 
> No. Both sysvinit and runit-init are available in Debian. So this issue would be
> present on a Debian system not running systemd as PID1.

Umm, but is there any option to instruct autopkgtest to
make a Debian qemu image with PID 1 not being systemd?
I do not know such an option.

How can anybody reproduce this issue on Debian??
Do you have any idea?

Best regards, Ryutaroh


From: Mark Hindley <mark@hindley.org.uk>
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
Date: Sat, 16 May 2020 10:41:41 +0100

> On Sat, May 16, 2020 at 06:33:26PM +0900, Ryutaroh Matsumoto wrote:
>> Dear Mark, Thank you for your attention and response. But,
>> 
>> > autopkgtest is not a forked package and Devuan uses Debian's packages directly.
>> > Can you report this to Debian BTS, please?
>> 
>> I don't think this is a Debian issue.
>> Debian PID 1 is systemd,
> 
> No. Both sysvinit and runit-init are available in Debian. So this issue would be
> present on a Debian system not running systemd as PID1.
> 
> Best wishes
> 
> Mark

Acknowledgement sent to Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. Full text available.
Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#459; Package autopkgtest. Full text available.

Message received at 459@bugs.devuan.org:


Received: (at 459) by bugs.devuan.org; 16 May 2020 09:50:04 +0000
Return-Path: <mark@hindley.org.uk>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by doc.devuan.org with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 16 May 2020 09:50:04 +0000 (UTC)
Received: from mx.hindley.org.uk (mohindley.plus.com [81.174.245.179])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	(No client certificate requested)
	by vm6.ganeti.dyne.org (Postfix) with ESMTPS id 5AB62F60CBC
	for <459@bugs.devuan.org>; Sat, 16 May 2020 11:41:44 +0200 (CEST)
Received: from apollo.hindleynet ([192.168.1.3] helo=hindley.org.uk)
	by mx.hindley.org.uk with smtp (Exim 4.84_2)
	(envelope-from <mark@hindley.org.uk>)
	id 1jZtK9-0002Ac-TO; Sat, 16 May 2020 10:41:41 +0100
Received: (nullmailer pid 32264 invoked by uid 1000);
	Sat, 16 May 2020 09:41:41 -0000
Date: Sat, 16 May 2020 10:41:41 +0100
From: Mark Hindley <mark@hindley.org.uk>
To: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>
Cc: 459@bugs.devuan.org
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
Message-ID: <20200516094141.GJ32762@hindley.org.uk>
References: <20200516.170318.2170101985550811941.ryutaroh@ict.e.titech.ac.jp>
 <20200516092947.GG32762@hindley.org.uk>
 <20200516.183326.1310545322032497068.ryutaroh@ict.e.titech.ac.jp>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <20200516.183326.1310545322032497068.ryutaroh@ict.e.titech.ac.jp>
User-Agent: Mutt/1.10.1 (2018-07-13)
X-Spam-Status: No, score=-0.0 required=5.0 tests=SPF_PASS autolearn=disabled
	version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org

On Sat, May 16, 2020 at 06:33:26PM +0900, Ryutaroh Matsumoto wrote:
> Dear Mark, Thank you for your attention and response. But,
> 
> > autopkgtest is not a forked package and Devuan uses Debian's packages directly.
> > Can you report this to Debian BTS, please?
> 
> I don't think this is a Debian issue.
> Debian PID 1 is systemd,

No. Both sysvinit and runit-init are available in Debian. So this issue would be
present on a Debian system not running systemd as PID1.

Best wishes

Mark

Acknowledgement sent to Mark Hindley <mark@hindley.org.uk>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. Full text available.
Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#459; Package autopkgtest. Full text available.

Message received at 459@bugs.devuan.org:


Received: (at 459) by bugs.devuan.org; 16 May 2020 09:40:03 +0000
Return-Path: <matsumoto.r.aa@m.titech.ac.jp>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by doc.devuan.org with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 16 May 2020 09:40:03 +0000 (UTC)
Received: from mail001.nap.gsic.titech.ac.jp (mail001.nap.gsic.titech.ac.jp [131.112.13.101])
	by vm6.ganeti.dyne.org (Postfix) with SMTP id ECBB9F60CC6
	for <459@bugs.devuan.org>; Sat, 16 May 2020 11:33:31 +0200 (CEST)
Received: from 172.22.40.205
	by mail001.nap.gsic.titech.ac.jp with Mail2000 ESMTP Server V7.00(2613:1:AUTH_RELAY)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 18:33:27 +0900 (JST)
Received: from mail002.nap.gsic.titech.ac.jp (mail002.nap.gsic.titech.ac.jp [131.112.13.102])
	by drweb08.nap.gsic.titech.ac.jp (Postfix) with SMTP id 5006AEB;
	Sat, 16 May 2020 18:33:27 +0900 (JST)
Received: from 114.145.251.241
	by mail002.nap.gsic.titech.ac.jp with Mail2000 ESMTPA Server V7.00(2641:1:AUTH_LOGIN)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 18:33:26 +0900 (JST)
Date: Sat, 16 May 2020 18:33:26 +0900 (JST)
Message-Id: <20200516.183326.1310545322032497068.ryutaroh@ict.e.titech.ac.jp>
To: mark@hindley.org.uk
Cc: 459@bugs.devuan.org
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
From: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>
In-Reply-To: <20200516092947.GG32762@hindley.org.uk>
References: <20200516.170318.2170101985550811941.ryutaroh@ict.e.titech.ac.jp>
	<20200516092947.GG32762@hindley.org.uk>
X-Mailer: Mew version 6.8 on Emacs 26.3
Mime-Version: 1.0
Content-Type: Text/Plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Spam-Status: No, score=-2.3 required=5.0 tests=RCVD_IN_DNSWL_MED
	autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org

Dear Mark, Thank you for your attention and response. But,

> autopkgtest is not a forked package and Devuan uses Debian's packages directly.
> Can you report this to Debian BTS, please?

I don't think this is a Debian issue.
Debian PID 1 is systemd,
and with systemd ttyS[01] are available
in autopkgtest-built qemu images.

I believe "tag debian" should be removed.

Best regards, Ryutaroh

From: Mark Hindley <mark@hindley.org.uk>
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
Date: Sat, 16 May 2020 10:29:48 +0100

> Control: tags -1 debian
> 
> Ryutaroh,
> 
> Thanks for this
> 
> On Sat, May 16, 2020 at 05:03:18PM +0900, Ryutaroh Matsumoto wrote:
>> Package: autopkgtest
>> Version: 5.13.1
>> Severity: minor
>> Tags: beowulf ceres
>> Control: found -1 5.10
>> 
>> Dear Maintainer,
>> 
>> "man autopkgtest-virt-qemu" says:
>> REQUIREMENTS
>>        autopkgtest-virt-qemu  assumes  that you have already prepared a suitable Debian based QEMU image (see BUILDING IMAGES below for how to create them).
>>        But you can use any VM which has python3 or python installed and either
>> 
>>        *   opens a root shell on ttyS1, or
>> 
>>        *   has a serial console on ttyS0 where you can log in (getty or similar) with specified user and password. This will then be used to  start  a  root
>>            shell on ttyS1, to reduce this to the first case and to not assume that ttyS0 stays operational throughout the whole test.
>> 
>> But autopkgtest-build-qemu does not adjust /etc/inittab inside the qemu image,
>> and autopkgtest-virt-qemu always fails.
>> Workaround is easy, just modify /etc/inittab in the qemu image.
>> 
>> This issue is found in package versions 5.13.1 and 5.10.
> 
> autopkgtest is not a forked package and Devuan uses Debian's packages directly.
> 
> Can you report this to Debian BTS, please?
> 
> Thanks
> 
> Mark

Acknowledgement sent to Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>:
Extra info received and forwarded to list. Copy sent to devuan-dev@lists.dyne.org. Full text available.
Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#459; Package autopkgtest. Full text available.
Added tag(s) debian. Request was from Mark Hindley <mark@hindley.org.uk> to 459-submit@bugs.devuan.org. Full text available.

Message received at 459@bugs.devuan.org:


Received: (at 459) by bugs.devuan.org; 16 May 2020 09:30:03 +0000
Return-Path: <mark@hindley.org.uk>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by doc.devuan.org with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 16 May 2020 09:30:03 +0000 (UTC)
Received: from mx.hindley.org.uk (mohindley.plus.com [81.174.245.179])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	(No client certificate requested)
	by vm6.ganeti.dyne.org (Postfix) with ESMTPS id AA257F60C92
	for <459@bugs.devuan.org>; Sat, 16 May 2020 11:29:51 +0200 (CEST)
Received: from apollo.hindleynet ([192.168.1.3] helo=hindley.org.uk)
	by mx.hindley.org.uk with smtp (Exim 4.84_2)
	(envelope-from <mark@hindley.org.uk>)
	id 1jZt8e-00024o-LU; Sat, 16 May 2020 10:29:48 +0100
Received: (nullmailer pid 24073 invoked by uid 1000);
	Sat, 16 May 2020 09:29:48 -0000
Date: Sat, 16 May 2020 10:29:48 +0100
From: Mark Hindley <mark@hindley.org.uk>
To: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>, 459@bugs.devuan.org
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
Message-ID: <20200516092947.GG32762@hindley.org.uk>
References: <20200516.170318.2170101985550811941.ryutaroh@ict.e.titech.ac.jp>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <20200516.170318.2170101985550811941.ryutaroh@ict.e.titech.ac.jp>
X-Debbugs-No-Ack: No Thanks
User-Agent: Mutt/1.10.1 (2018-07-13)
X-Spam-Status: No, score=-0.0 required=5.0 tests=SPF_PASS autolearn=disabled
	version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org

Control: tags -1 debian

Ryutaroh,

Thanks for this

On Sat, May 16, 2020 at 05:03:18PM +0900, Ryutaroh Matsumoto wrote:
> Package: autopkgtest
> Version: 5.13.1
> Severity: minor
> Tags: beowulf ceres
> Control: found -1 5.10
> 
> Dear Maintainer,
> 
> "man autopkgtest-virt-qemu" says:
> REQUIREMENTS
>        autopkgtest-virt-qemu  assumes  that you have already prepared a suitable Debian based QEMU image (see BUILDING IMAGES below for how to create them).
>        But you can use any VM which has python3 or python installed and either
> 
>        *   opens a root shell on ttyS1, or
> 
>        *   has a serial console on ttyS0 where you can log in (getty or similar) with specified user and password. This will then be used to  start  a  root
>            shell on ttyS1, to reduce this to the first case and to not assume that ttyS0 stays operational throughout the whole test.
> 
> But autopkgtest-build-qemu does not adjust /etc/inittab inside the qemu image,
> and autopkgtest-virt-qemu always fails.
> Workaround is easy, just modify /etc/inittab in the qemu image.
> 
> This issue is found in package versions 5.13.1 and 5.10.

autopkgtest is not a forked package and Devuan uses Debian's packages directly.

Can you report this to Debian BTS, please?

Thanks

Mark

Information forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#459; Package autopkgtest. Full text available.
Marked as found in versions 5.10. Request was from Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp> to submit@bugs.devuan.org. Full text available.

Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 16 May 2020 08:10:02 +0000
Return-Path: <matsumoto.r.aa@m.titech.ac.jp>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by doc.devuan.org with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 16 May 2020 08:10:02 +0000 (UTC)
Received: from mail002.nap.gsic.titech.ac.jp (mail002.nap.gsic.titech.ac.jp [131.112.13.102])
	by vm6.ganeti.dyne.org (Postfix) with SMTP id 17D19F60B98
	for <submit@bugs.devuan.org>; Sat, 16 May 2020 10:03:25 +0200 (CEST)
Received: from 172.22.40.203
	by mail002.nap.gsic.titech.ac.jp with Mail2000 ESMTP Server V7.00(2633:0:AUTH_RELAY)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 17:03:22 +0900 (JST)
Received: from mail003.nap.gsic.titech.ac.jp (mail003.nap.gsic.titech.ac.jp [131.112.13.103])
	by drweb06.nap.gsic.titech.ac.jp (Postfix) with SMTP id 8AE82EB
	for <submit@bugs.devuan.org>; Sat, 16 May 2020 17:03:22 +0900 (JST)
Received: from 114.145.251.241
	by mail003.nap.gsic.titech.ac.jp with Mail2000 ESMTPA Server V7.00(2614:0:AUTH_LOGIN)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 17:03:21 +0900 (JST)
Date: Sat, 16 May 2020 17:03:18 +0900 (JST)
Message-Id: <20200516.170318.2170101985550811941.ryutaroh@ict.e.titech.ac.jp>
To: Devuan Bug Tracking System <submit@bugs.devuan.org>
Subject: autopkgtest-build-qemu does not set up /dev/ttyS[01]
From: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>
X-Mailer: Mew version 6.8 on Emacs 26.3
Mime-Version: 1.0
Content-Type: Text/Plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Spam-Status: No, score=-2.3 required=5.0 tests=RCVD_IN_DNSWL_MED
	autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org

Package: autopkgtest
Version: 5.13.1
Severity: minor
Tags: beowulf ceres
Control: found -1 5.10

Dear Maintainer,

"man autopkgtest-virt-qemu" says:
REQUIREMENTS
       autopkgtest-virt-qemu  assumes  that you have already prepared a suitable Debian based QEMU image (see BUILDING IMAGES below for how to create them).
       But you can use any VM which has python3 or python installed and either

       *   opens a root shell on ttyS1, or

       *   has a serial console on ttyS0 where you can log in (getty or similar) with specified user and password. This will then be used to  start  a  root
           shell on ttyS1, to reduce this to the first case and to not assume that ttyS0 stays operational throughout the whole test.

But autopkgtest-build-qemu does not adjust /etc/inittab inside the qemu image,
and autopkgtest-virt-qemu always fails.
Workaround is easy, just modify /etc/inittab in the qemu image.

This issue is found in package versions 5.13.1 and 5.10.

Best regards, Ryutaroh Matsumoto


-- System Information:
Distributor ID:	Debian
Description:	Devuan GNU/Linux 3 (beowulf)
Release:	3
Codename:	beowulf
Architecture: x86_64

Kernel: Linux 4.19.0-9-amd64 (SMP w/2 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8), LANGUAGE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages autopkgtest depends on:
ii  apt-utils       1.8.2.1
ii  libdpkg-perl    1.19.7
ii  procps          2:3.3.15-2+devuan1
ii  python3         3.7.3-1
ii  python3-debian  0.1.35

Versions of packages autopkgtest recommends:
ii  autodep8  0.18

Versions of packages autopkgtest suggests:
pn  lxc               <none>
pn  lxd               <none>
ii  ovmf              0~20181115.85588389-3+deb10u1
pn  qemu-efi-aarch64  <none>
pn  qemu-efi-arm      <none>
pn  qemu-system       <none>
ii  qemu-utils        1:3.1+dfsg-8+deb10u5
pn  schroot           <none>
ii  vmdb2             0.13.2+git20190215-1

-- no debconf information

Acknowledgement sent to Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>:
New bug report received and forwarded. Copy sent to devuan-dev@lists.dyne.org. Full text available.
Report forwarded to devuan-bugs@lists.dyne.org, devuan-dev@lists.dyne.org:
bug#459; Package autopkgtest. Full text available.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Fri, 10 Jul 2020 14:39:01 UTC