Devuan bug report logs - #68
udev logging not working in Devuan Jessie rc

Package: udev; Reported by: Enrico Menotti <enrico.menotti@libero.it>; Done: KatolaZ <katolaz@freaknet.org>; Maintainer for udev is (unknown).


bug closed, send any further explanations to Enrico Menotti <enrico.menotti@libero.it> Request was from KatolaZ <katolaz@freaknet.org> to control@bugs.devuan.org. Full text available.


Message received at submit@bugs.devuan.org:


Received: (at submit) by bugs.devuan.org; 29 Apr 2017 18:20:04 +0000
Date: Sat, 29 Apr 2017 20:19:52 +0200 (CEST)
From: Enrico Menotti <enrico.menotti@libero.it>
To: submit@bugs.devuan.org
Subject: udev logging not working in Devuan Jessie rc

------=_Part_11158_1516137687.1493489992609
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit

Package: udev

Version: 215-17+deb8u6

I had the need to get a log from udev. I found four ways to do this:

1. changing /etc/udev/udev.conf, and inserting there udev_log="debug"

2. passing to the kernel the parameter udev.log-priority=debug (at boot time)

3. declaring the environment variable UDEV_LOG=debug

4. using udevadm (this only works after boot)

I tried the first three options (I needed a log at boot), and none worked.

So I downgraded udev to the version included with Debian Wheezy (175-7.2). This allowed a log (I used the first method) in /var/log/daemon.log.

I suspect udev in Jessie to rely on systemd for producing logs.
------=_Part_11158_1516137687.1493489992609
MIME-Version: 1.0
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit

<!DOCTYPE html>
<html><head>
    <meta charset="UTF-8">
</head><body><p>Package: udev</p><p>Version:&#160;215-17+deb8u6</p><p>I had the need to get a log from udev. I found four ways to do this:</p><p>1. changing /etc/udev/udev.conf, and inserting there udev_log=&#34;debug&#34;</p><p>2. passing to the kernel the parameter&#160;udev.log-priority=debug (at boot time)</p><p>3. declaring the environment variable UDEV_LOG=debug</p><p>4. using udevadm (this only works after boot)</p><p>I tried the first three options (I needed a log at boot), and none worked.</p><p>So I downgraded udev to the version included with Debian Wheezy (175-7.2). This allowed a log (I used the first method) in /var/log/daemon.log.</p><p>I suspect udev in Jessie to rely on systemd for producing logs.</p></body></html>
 
------=_Part_11158_1516137687.1493489992609--


Acknowledgement sent to Enrico Menotti <enrico.menotti@libero.it>:
New bug report received and forwarded. Copy sent to owner@bugs.devuan.org. Full text available.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#68; Package udev. Full text available.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Thu, 16 Aug 2018 10:39:01 UTC