Devuan bug report logs - #164
gnutls: gnutls_handshake() failed: Public key signature verification has failed.

Package: libcurl3-gnutls; Maintainer for libcurl3-gnutls is (unknown);

Reported by: david <david@unixrox.net>

Date: Tue, 28 Nov 2017 11:33:01 UTC

Severity: normal

Tags: ascii

Done: KatolaZ <katolaz@freaknet.org>

Full log


Message #15 received at 164@bugs.devuan.org (full text, mbox, reply):

Received: (at 164) by bugs.devuan.org; 28 Nov 2017 15:10:03 +0000
Return-Path: <gauchard@laas.fr>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Tue, 28 Nov 2017 16:10:03 +0100 (CET)
Received: from laas.laas.fr (laas.laas.fr [140.93.0.15])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by vm6.ganeti.dyne.org (Postfix) with ESMTPS id 0C9F2F6049D
	for <164@bugs.devuan.org>; Tue, 28 Nov 2017 16:05:25 +0100 (CET)
Received: from sorcerer.laas.fr (pumpkin.laas.fr [IPv6:2001:660:6602:4:529a:4cff:fe19:8d6a])
	by laas.laas.fr (8.15.2/8.15.2) with SMTP id vASF5Mak008846
	for <164@bugs.devuan.org>; Tue, 28 Nov 2017 16:05:22 +0100 (CET)
Received: by sorcerer.laas.fr (sSMTP sendmail emulation); Tue, 28 Nov 2017 16:05:22 +0100
Date: Tue, 28 Nov 2017 16:05:22 +0100
From: David Gauchard <gauchard@laas.fr>
To: 164@bugs.devuan.org
Subject: Re: Irreproducible
Message-ID: <20171128150522.GA25843@laas.fr>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.24 (2015-08-30)
X-Spam-Status: No, score=-2.3 required=5.0 tests=FAKE_REPLY_C,
	RCVD_IN_DNSWL_MED,RCVD_IN_MSPIKE_H3,RCVD_IN_MSPIKE_WL,RP_MATCHES_RCVD,
	SPF_PASS autolearn=disabled version=3.4.1
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on tupac3.dyne.org
Thanks.

My setup has been a continuously upgraded debian system for more than 15
years when I recently upgraded to devuan/stable=jessie, and very recently to
devuan/ascii.  I'm using aptitude, and I it says it is up to date.

When I switched jessie to ascii from I had lots of conflicts that I did not
try to resolve at that time.  Then they recently solved by themselve with
apt and no tweaking. Then I realized that git+https problem.

The not truncated message is:
	$ git clone https://github.com/devuan/jenkins-debian-glue
	Cloning into 'jenkins-debian-glue'...
	fatal: unable to access 'https://github.com/devuan/jenkins-debian-glue/': gnutls_handshake() failed: Public key signature verification has failed.

It happens with every accounts, so it is not a git misconfiguration. 

I realize that git is otherwise working with protocol ssh://git@
I have no problem with:
	git clone git@github.com:devuan/jenkins-debian-glue.git

I just moved /etc/ssl/certs to /etc/ssl/certs.old and reinstalled
ca-certificates, but the problem remains.

I tried with lynx (accepting all cookies) with no problem:
	lynx https://github.com/devuan/jenkins-debian-glue/

It is not clear to me where to search for the origin of my problem,
considering that you say it is flawlessly working on other ascii
installations.

My /etc/apt/sources.list is:
-------------------------------------------------------------
deb     http://auto.mirror.devuan.org/merged ascii main
deb-src http://auto.mirror.devuan.org/merged ascii main
deb     http://auto.mirror.devuan.org/merged ascii-updates main
deb-src http://auto.mirror.devuan.org/merged ascii-updates main
deb     http://auto.mirror.devuan.org/merged ascii-security main
deb-src http://auto.mirror.devuan.org/merged ascii-security main

deb     http://packages.devuan.org/merged ascii-security main
deb-src http://packages.devuan.org/merged ascii-security main

#deb     http://auto.mirror.devuan.org/merged ascii-proposed main
#deb-src http://auto.mirror.devuan.org/merged ascii-proposed main

deb     http://auto.mirror.devuan.org/merged ascii-backports main
deb-src http://auto.mirror.devuan.org/merged ascii-backports main

#deb     http://auto.mirror.devuan.org/devuan experimental main
#deb-src http://auto.mirror.devuan.org/devuan experimental main
-------------------------------------------------------------
I also have in sources.list.d/:

-------------------------------------------------------------
deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/Debian_7.0/ /
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
-------------------------------------------------------------


and also: Thanks again for devuan :)


Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Thu Oct 22 23:23:45 2020;