Devuan bug report logs - #164
gnutls: gnutls_handshake() failed: Public key signature verification has failed.

Package: libcurl3-gnutls; Maintainer for libcurl3-gnutls is (unknown);

Reported by: david <>

Date: Tue, 28 Nov 2017 11:33:01 UTC

Severity: normal

Tags: ascii

Done: KatolaZ <>

Full log

Message #20 received at (full text, mbox, reply):

Received: (at 164) by; 28 Nov 2017 15:20:05 +0000
Return-Path: <>
Received: from []
	by fulcanelli with IMAP (fetchmail-6.3.26)
	for <debbugs@localhost> (single-drop); Tue, 28 Nov 2017 16:20:05 +0100 (CET)
Received: from ( [])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by (Postfix) with ESMTPS id AE25FF604F8
	for <>; Tue, 28 Nov 2017 16:16:40 +0100 (CET)
Received: from tunnel (unknown [])
	by (Postfix) with ESMTP id 897DC5FFFE
	for <>; Tue, 28 Nov 2017 16:16:37 +0100 (CET)
Received: by tunnel (Postfix, from userid 9043)
	id 4D13E1533035; Tue, 28 Nov 2017 16:16:37 +0100 (CET)
Subject: Re: Irreproducible
MIME-Version: 1.0
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: 8bit
Message-Id: <20171128151637.4D13E1533035@tunnel>
Date: Tue, 28 Nov 2017 16:16:37 +0100 (CET)
From: (david)
X-Spam-Status: No, score=-3.5 required=5.0 tests=RCVD_IN_DNSWL_LOW,
	RCVD_IN_MSPIKE_H2 autolearn=disabled version=3.4.1
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on

My setup has been a continuously upgraded debian system for more than 15
years when I recently upgraded to devuan/stable=jessie, and very recently to
devuan/ascii.  I'm using aptitude, and I it says it is up to date.

When I switched jessie to ascii from I had lots of conflicts that I did not
try to resolve at that time.  Then they recently solved by themselve with
apt and no tweaking. Then I realized that git+https problem.

The not truncated message is:
        $ git clone
        Cloning into 'jenkins-debian-glue'...
        fatal: unable to access '': gnutls_handshake() failed: Public key signature verification has failed.

It happens with every accounts, so it is not a git misconfiguration.

I realize that git is otherwise working with protocol ssh://git@
I have no problem with:
        git clone

I just moved /etc/ssl/certs to /etc/ssl/certs.old and reinstalled
ca-certificates, but the problem remains.

I tried with lynx (accepting all cookies) with no problem:

It is not clear to me where to search for the origin of my problem,
considering that you say it is flawlessly working on other ascii

My /etc/apt/sources.list is:
deb ascii main
deb-src ascii main
deb ascii-updates main
deb-src ascii-updates main
deb ascii-security main
deb-src ascii-security main

deb ascii-security main
deb-src ascii-security main

#deb ascii-proposed main
#deb-src ascii-proposed main

deb ascii-backports main
deb-src ascii-backports main

#deb experimental main
#deb-src experimental main
I also have in sources.list.d/:

deb /
deb [arch=amd64] stable main

and also: Thanks again for devuan :)

Send a report that this bug log contains spam.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <>.
Last modified: Thu Oct 22 23:35:06 2020;