Devuan bug report logs - #220
libwebkit2gtk-4.0-37: Attempting to install atril or libwebkit2gtk-4.0-37 fails (same cause)

Package: libwebkit2gtk-4.0-37; Reported by: Stefan Baur <newsgroups.mail2@stefanbaur.de>;
Date: Sun, 10 Jun 2018 19:03:01 UTC;
Done: KatolaZ <katolaz@freaknet.org>;
Maintainer for libwebkit2gtk-4.0-37 is (unknown).

View this report as an mbox folder.


Report forwarded to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:
bug#220; Package libwebkit2gtk-4.0-37. Full text available.



Message sent to devuan-bugs@lists.dyne.org, owner@bugs.devuan.org:

Subject: bug#220: libwebkit2gtk-4.0-37: Attempting to install atril or libwebkit2gtk-4.0-37 fails (same cause)
To: submit@bugs.devuan.org
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
Date: Sun, 10 Jun 2018 20:41:24 +0200

Package: libwebkit2gtk-4.0-37
Severity: normal

Dear Maintainer,

   * What led up to the situation?

I tried to run an upgrade from Devuan Jessie to Devuan ASCII using "apt
update" and "apt dist-upgrade".

The latter tried to deinstall the package "atril".

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

I aborted the process and upgraded packages manually until I found the
package causing the problem.

   * What was the outcome of this action?

apt install libwebkit2gtk-4.0-37 -t ascii
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (<
 1.10.5) but 1:1.10.4-dmo2 is to be installed
 E: Unable to correct problems, you have held broken packages.

   * What outcome did you expect instead?

the possibility to install/upgrade atril.

I think it's weird that it lists a dependency "<1.10.5", then states it
is going to install 1.10.4, which is obviously "<1.10.5", so the
requirement would be fulfilled, yet it still claims the dependency is
not met.


-- System Information:
Distributor ID: Devuan
Description:    Devuan GNU/Linux 2.0 (ascii)
Release:        2.0
Codename:       ascii

Architecture: x86_64

Kernel: Linux 4.9.0-6-amd64 (SMP w/4 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)





Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Fri, 15 Nov 2019 02:45:58 UTC