Devuan bug report logs - #459
autopkgtest-build-qemu does not set up /dev/ttyS[01]

Package: autopkgtest; Maintainer for autopkgtest is (unknown); Source for autopkgtest is src:autopkgtest.

Reported by: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>

Date: Sat, 16 May 2020 08:18:01 UTC

Severity: minor

Tags: beowulf, ceres, debian

Found in versions 5.10, 5.13.1

Full log


Message #27 received at 459@bugs.devuan.org (full text, mbox, reply):

Received: (at 459) by bugs.devuan.org; 16 May 2020 10:00:02 +0000
Return-Path: <matsumoto.r.aa@m.titech.ac.jp>
Delivered-To: devuanbugs@dyne.org
Received: from tupac3.dyne.org [195.169.149.119]
	by doc.devuan.org with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 16 May 2020 10:00:02 +0000 (UTC)
Received: from mail001.nap.gsic.titech.ac.jp (mail001.nap.gsic.titech.ac.jp [131.112.13.101])
	by vm6.ganeti.dyne.org (Postfix) with SMTP id 74DFDF60C8D
	for <459@bugs.devuan.org>; Sat, 16 May 2020 11:56:14 +0200 (CEST)
Received: from 172.22.40.202
	by mail001.nap.gsic.titech.ac.jp with Mail2000 ESMTP Server V7.00(2611:0:AUTH_RELAY)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 18:56:13 +0900 (JST)
Received: from mail001.nap.gsic.titech.ac.jp (mail001.nap.gsic.titech.ac.jp [131.112.13.101])
	by drweb05.nap.gsic.titech.ac.jp (Postfix) with SMTP id 02BA167C;
	Sat, 16 May 2020 18:56:13 +0900 (JST)
Received: from 114.145.251.241
	by mail001.nap.gsic.titech.ac.jp with Mail2000 ESMTPA Server V7.00(2600:0:AUTH_LOGIN)
	(envelope-from <matsumoto.r.aa@m.titech.ac.jp>); Sat, 16 May 2020 18:56:11 +0900 (JST)
Date: Sat, 16 May 2020 18:56:11 +0900 (JST)
Message-Id: <20200516.185611.1962218483321776546.ryutaroh@ict.e.titech.ac.jp>
To: mark@hindley.org.uk
Cc: 459@bugs.devuan.org
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
From: Ryutaroh Matsumoto <ryutaroh@ict.e.titech.ac.jp>
In-Reply-To: <20200516094141.GJ32762@hindley.org.uk>
References: <20200516092947.GG32762@hindley.org.uk>
	<20200516.183326.1310545322032497068.ryutaroh@ict.e.titech.ac.jp>
	<20200516094141.GJ32762@hindley.org.uk>
X-Mailer: Mew version 6.8 on Emacs 26.3
Mime-Version: 1.0
Content-Type: Text/Plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Spam-Status: No, score=-2.3 required=5.0 tests=RCVD_IN_DNSWL_MED
	autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on tupac3.dyne.org
>> I don't think this is a Debian issue.
>> Debian PID 1 is systemd,
> 
> No. Both sysvinit and runit-init are available in Debian. So this issue would be
> present on a Debian system not running systemd as PID1.

Umm, but is there any option to instruct autopkgtest to
make a Debian qemu image with PID 1 not being systemd?
I do not know such an option.

How can anybody reproduce this issue on Debian??
Do you have any idea?

Best regards, Ryutaroh


From: Mark Hindley <mark@hindley.org.uk>
Subject: Re: bug#459: autopkgtest-build-qemu does not set up /dev/ttyS[01]
Date: Sat, 16 May 2020 10:41:41 +0100

> On Sat, May 16, 2020 at 06:33:26PM +0900, Ryutaroh Matsumoto wrote:
>> Dear Mark, Thank you for your attention and response. But,
>> 
>> > autopkgtest is not a forked package and Devuan uses Debian's packages directly.
>> > Can you report this to Debian BTS, please?
>> 
>> I don't think this is a Debian issue.
>> Debian PID 1 is systemd,
> 
> No. Both sysvinit and runit-init are available in Debian. So this issue would be
> present on a Debian system not running systemd as PID1.
> 
> Best wishes
> 
> Mark

Send a report that this bug log contains spam.


Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <owner@bugs.devuan.org>.
Last modified: Tue Oct 4 13:36:19 2022;