Devuan bug report logs - #633
qemu-guest-agent: Guest agent does not shut down the guest when requested to

version graph

Package: sysvinit; Maintainer for sysvinit is Devuan Developers <>; Source for sysvinit is src:sysvinit.

Reported by: Fabio Muzzi <>

Date: Sat, 20 Nov 2021 19:12:01 UTC

Severity: grave

Tags: chimaera

Found in version 2.96-7+devuan1

Fixed in versions 3.00-1+devuan1, 2.96-7+devuan2


Full log

Message #5 received at (full text, mbox, reply):

Received: (at submit) by; 20 Nov 2021 19:10:02 +0000
Return-Path: <>
Received: from []
	by with IMAP (fetchmail-6.4.0.beta4)
	for <debbugs@localhost> (single-drop); Sat, 20 Nov 2021 19:10:02 +0000 (UTC)
Received: from fileserver.geldue.locale ( [])
	by (Postfix) with ESMTP id 3D8BFF60934
	for <>; Sat, 20 Nov 2021 20:07:03 +0100 (CET)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Fabio Muzzi <>
To: Devuan Bug Tracking System <>
Subject: qemu-guest-agent: Guest agent does not shut down the guest when requested to
Message-ID: <163743517558.1458.16031504645366650167.reportbug@fileserver.geldue.locale>
Date: Sat, 20 Nov 2021 20:06:15 +0100
X-Spam-Status: No, score=1.0 required=5.0 tests=SPF_SOFTFAIL
	autolearn=disabled version=3.4.2
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
Package: qemu-guest-agent
Version: 1:5.2+dfsg-11+deb11u1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

I have installed a Devuan 4 guest in a PVE 7.1 host, with Quemu guest
enabled in PVE and the guest agent package installed in the guest.

When commanding a guest shutdown from the host, a shutdown command is
sent to the guest agent (because the host knows the guest has the agent
installed, otherwise it would use an ACPI command to "press the power

The guest gets the command, and writes in the syslog the following line:

Nov 20 18:50:09 fileserver qemu-ga: info: guest-shutdown called, mode:

Then a shutdown should be initiated, but nothing happens. The guest
keeps running.

I can send multiple shutdown commands from the host, they are all
received by the guest, but nothing happens, they just get logged in the

I would expect the guest agent to start a shutdown.

Tried installing a Debian 11 virtual on the same PVE host, and the
shutdown command works as expected, logging the same line and then
immediately commanding a shutdown.

I suppose that this version of qemu-ga requires systemd to actually command a shutdown? 

Qemu-ga is version 5.2.0

It worked in Devuan 3.

Kind regards

-- System Information:
Distributor ID:	Devuan
Description:	Devuan GNU/Linux 4 (chimaera)
Release:	4
Codename:	chimaera
Architecture: x86_64

Kernel: Linux 5.10.0-9-amd64 (SMP w/2 CPU threads)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages qemu-guest-agent depends on:
ii  init-system-helpers   1.60+devuan1
ii  libc6                 2.31-13+deb11u2
ii  libeudev1 [libudev1]  3.2.9-10~chimaera1
ii  libglib2.0-0          2.66.8-1
ii  liburing1             0.7-3
ii  lsb-base              11.1.0

qemu-guest-agent recommends no packages.

qemu-guest-agent suggests no packages.

-- no debconf information

Send a report that this bug log contains spam.

Devuan BTS -- Powered by Debian bug tracking system
Copyright (C) 1999 Darren O. Benham,
1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson,
2005-2017 Don Armstrong, and many other contributors.

Devuan Bugs Owner <>.
Last modified: Wed Apr 17 14:46:31 2024;